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Preface 

Thank you very much for purchasing the EATON HMi Series Human Machine Interface 

(hereinafter “HMi ” ) products.  

This manual will be helpful in the installation, operation and specifications of Eaton HMi  

product and HMi Soft software program. Before using the product, please read this user 

manual to ensure correct use.  

You should thoroughly understand all safety precautions (DANGERS, WARNINGS and STOPS) 

before proceeding with the installation, wiring and operation. If you do not understand please 

contact your local Eaton sales representative. Place this user manual in a safe location for 

future reference. 

 

 Using This Manual 

 Contents of this manual 

 This manual is a user guide that provides the information on how to install 

and operate Eaton HMi products and HMi Soft software program.  

 Who should use this manual 

This user manual is intended for the following users: 

 Those who are responsible for designing. 

 Those who are responsible for installing or wiring. 

 Those who are responsible for operating or programming. 

 Important precautions 

Before using the product, please read this user manual thoroughly to ensure correct 

use and store this manual in a safe and handy place for quick reference whenever 

necessary. Please observe the following precautions:  

 Install the product in a clean and dry location free from corrosive and 

inflammable gases or liquids. 

 Ensure that HMi is correctly connected to a ground. The grounding method 

must comply with the electrical standard of the country. 

 Do not modify or remove wiring when power is applied to HMi. 

 Before starting the operation, make sure the emergency stop equipment is 

installed and operational. 

 Do not touch the power supply during operation. Otherwise, it may cause 

electric shock. 

 

 
The content of this manual may be revised without prior notice. Please consult 
our distributors or download the most updated version at 
http://www.eaton.com/oi.  
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Chapter 1  Introduction 

1.1 HMi Series Human Machine Interface 

HMi series is manufactured by adopting easy-to-use software and high-speed hardware to 

provide a powerful and stable programmable interface. HMiSoft software program (hereinafter 

“HmiSoft”) is a user-friendly program editor of HMi series for Windows. Please refer to the 

following section for an introduction to its features and functions. 

 

1.2 Features 

 PLC Serial Drives Support 

HMi series supports more than twenty brands of PLCs, including Eaton, AB, Omron, 

Siemens, Mitsubishi, GE, etc. (All trademarks in this manual are property of their 

respective companies.) 

 Windows® Fonts Support  

HMiSoft supports all fonts used by Windows®. 

 Quick Execution and Communication Macro 

HMiSoft is able to handle complicated calculations by executing macros. In addition, the 

users can create a communication protocol by using communication macro command and 

connect to the specific system or the controller via the COM port. 

 Rapid USB Upload/Download  

The users can use HMiSoft to upload and download screen data and programs via USB 

interface.  RS 232 upload/download is also available. 

 Recipes 

HMiSoft provides a useful recipe editor that is similar to Microsoft Excel for the users to 

edit and input multiple recipes easily. HMi Recipes can be downloaded as a complete set 

or individually. 

 Direct Communication with Three PLC Protocols 

HMi series is capable of communicating with up to three simultaneous serial protocols. 

This allows the HMi to display information from multiple PLC’s of different manufacturers 

at the same time, as well as acting as a gateway from one network to another.  
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 Support Multiple PLCs Connections 

One HMi is able to connect to multiple controllers using the RS-485 interface port of 

COM2 and COM3. (NOTE 1).  

 Simulation Function (NOTE 2) 

HMiSoft provides simulation feature which allows the users to develop and debug 

software on a PC before downloading it to the HMi. 

Off-line Simulation: When the editing and compile operation is completed, the users can 

use off-line simulation function to simulate HMi operation on a stand-alone a PC without 

connecting to the controller. 

On-line Simulation: When the editing and compile operation is completed, the users can 

use on-line simulation function to simulate HMi operation on a stand-alone PC connected 

to the controller. 

 USB Host Port (USB Host) Equipped 

HMi series has a built-in USB Host interface for the connection to USB disk, card reader 

and printer with a USB socket. The users can save data, copy programs, print screen, and 

increase the data storage space. 

 Print Function 

HMi series has USB and COM port support for selected printers. 

 Multiple Security Protection  

HMi series provides passwords to protect the designer’s intellectual property rights and 

also for the designer to set the user accessibility to important elements and functions. 

 Multi-language Support 

Up to 16 languages can be selected and used without installing a multilingual operating 

system. 

NOTE  
1) A controller with a RS-485 interface or converter is required. 

2) Off-line/On-line simulation is not available for all functions provided by HMiSoft. Some 

functions can only be tested in a unit that is connected to a controller. Also, the on-line 

simulation will run for 30 minutes at a time. After the simulation time has finished, it will 

return to the main screen of HMiSoft. The developer can then start the on-line simulation if 

more testing time is required. 

3) When executing simulation function, the resolution of PC screen should be set to 24bit and 

higher, otherwise the simulation function may not work normally. 
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Chapter 2  Hardware Devices 

2.1 Usage of SD Card and USB Disk 

 SD Card 

An SD card (supports SDHC) can be used to save and copy data.  To use a SD card, it must 

be formatted to FAT32 via the HMi. Only SD card that formatted by HMi can be used on 

both HMi and Windows® OS. Errors will occur if the SD is formatted by a Windows® OS.  

 USB Disk  

A USB disk can be used to save and copy data.  To use a USB disk, it must be formatted to 

FAT32 via the HMi. Only USB disks that formatted by HMi can be used on both the HMi 

and Windows® OS. Errors will occur if the USB disk is formatted by a Windows® OS.  

 When using USB disk to save data, it is recommend that the storage capacity is less than 

2GB. Proper procedures should be used when removing a USB disk. 

There are two methods for removing the USB disk: 

1. Press SYS button for 3 seconds to enter into the system setting screen. Then choose 

the function to remove the USB disk. 

2. Create a “Remove storage” button on a screen. Pressing this button to allow the 

removal of the USB disk. For more information on “Remove storage” button, please 

refer to section 3.8.2.7 in Chapter 3. 

 

Failure to properly remove the USB disk could result in loss of data. 
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Chapter 3  Creating and Editing Screens 

This chapter will introduce installation, and general functions of HMiSoft.  Detail information 

for each function will be discussed in following chapters. 

3.1 HMiSoft Setup 

 Recommended System Requirements 

 CPU: Pentium® IV or equivalent AMD Athlon® processor 

 Memory: 1GB RAM or greater 

 Hard Disk: 400MB and above free hard disk space 

 Monitor Display: 1024 × 768 resolution higher full-color display recommended 

 Printer: Printer compatible with Windows® 2000 / Windows® XP 

 Operation System: Windows® 2000 / Windows® XP / Windows® Vista / Windows® 7 

 

 Software installation 

The user can download the HMiSoft program via the link below:  

http://eg.eaton.com/Form/HMiSoftware/ 

To install HMiSoft, follow the steps below: 

Step 1: Boot the computer to Win2000/WinXP/Vista/Windows 7 (Fig. 3-1-1). 
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Fig. 3-1-1 Open Microsoft Windows 

 

Step 2: Execute HMiSoft setup.exe (name may change to reflect version changes) by 

double clicking on the executable, or from Windows taskbar by clicking “Start” > 

“Run”, browse to the executable, and press OK. The system will setup automatically 

and you will get the following dialog box to select the desired display language (Fig. 3-

1-2).  
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Fig. 3-1-2 Select Language 

 

After pressing OK, system will setup automatically and you will get the following 

dialog box to choose destination location (Fig. 3-1-3).  

 

Fig. 3-1-3 Directory for installing HMiSoft software program 

 

To select the default directory C:\Program Files\EATON \HMiSoft Series 2.00.XX\, 

click Next>. 

To select a directory other than the default directory, click Browse. A list of available 

directories appears. Highlight the desired directory for HMiSoft and click OK, then 

Next>. If necessary, click < Back button to take you back through Setup dialog boxes 

one by one. 

Please remember the location of the destination directory.  If the destination directory 

is missing or changed, the user cannot upgrade the software successfully. 

 

Step 3: After pressing Next>, system will ask you to select the installation software, i.e. 

HMiSoft (Fig. 3-1-4). 
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Fig. 3-1-4 Select HMiSoft program 

Step 4: Then click Install button to start HMiSoft Installation (Fig. 3-1-5, Fig. 3-1-6). 

 

Fig. 3-1-5 Starting HMiSoft installation 
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Fig. 3-1-6 Finish installing Screen Editor 

Step 5: After finishing the install of HMiSoft (Fig. 3-1-6), and connecting a HMi, the system will 

ask you to install HMi USB driver. 

 

 

 

 

 

 

 

 

 

 

 

 
Fig. 3-1-7 Install HMi USB driver 

 

Step 6: When prompted by the Hardware Wizard to connect to Windows update, Select “No, 

not this time”, then select Next>. (Fig. 3-1-7) 
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Fig. 3-1-8 Install HMi USB driver 

Step 7: When prompted by the Hardware Wizard select “Install the software automatically 

(Recommended)” then select Next>. (Fig 3-1-8) 

 

 

 

 

 

 

 

 

 

 
Fig. 3-1-9 Install HMi USB driver 

 

Step 8: If a Software Installation warning is displayed, select “Continue Anyway”. (Fig 3-1-

9)HMi 
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Fig. 3-1-10 Install HMi USB driverStep 

9: After installing HMi USB driver, click Finish to complete the installation. (Fig 3-1-10)  
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3.2 How to Start HMiSoft  

1. Start HMiSoft by clicking HMiSoft Launcher 2.00.XX shortcut on the desk (Fig. 3-2-1) or 

from Windows taskbar, click Start > Programs > Eaton > HMiSoft Series > HMiSoft 

launcher 2.00.XX. 

 

Fig. 3-2-1 
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Fig. 3-2-2 Start-up display 

When HMiSoft Launcher is activated (Fig. 3-2-2), choose the correct version of the software for 

the appropriate hardware. Supported hardware is displayed on the right hand side of the 

window.  

 

1.  When HMiSoft program is activated for the first time, the first window to show up is as 

follows.  

 

Fig. 3-2-3 Screen without editing file 

2. To create a new application press  or click File > New, a new project dialog box will 

shown the following (Fig. 3-2-4). 
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Fig. 3-2-4 Creating a New project 

 

 

 

3. Enter the Project Name, Screen Name, Screen No. and select HMi Type, Base Port 

Controller and or printer. Then, click OK. A new program will be available as shown in the 

following (Fig. 3-2-5). 

 

Fig. 3-2-5 New project screen of Screen Editor 
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 The following are the five main components for editing a HMiSoft application Menu 

Bar 

Menu Bar is used to for file control, screen editing, system changes, and access to 
Help.  

 Toolbars  

Toolbars (Fig. 3-2-6)  Are easy to use and may be relocated for HMiSoft most used 

functions. 

1. Standard Toolbar 

 

2. Zoom Toolbar 

 

3. Text Toolbar 

 

4. Bitmap Toolbar 

 

5. Element Toolbar 

 

6. Layout Toolbar 

 
 

 

7. Drawing Toolbar 
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Fig. 3-2-6 Toolbar of HMiSoft  

 

Fig. 3-2-7 Element Toolbar has been moved 

 Element Tool Window 

The Element Tool window provides various kinds of element icons for selection (Fig. 3-2-8). 

Position of toolbar 
can be moved. 
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The user can use the mouse to select the desired element icon and drag it onto the work 

place to create a new element. In addition, the user can save the element in the Element 

Bank for editing the element next time (Fig. 3-2-9). 

           
 Fig. 3-2-8 Fig. 3-2-9 

 Property Table  

The Property Table displays the element property settings for each element (Fig. 3-2-10 & 

Fig. 3-2-11).  

 

All elements on the current 
editing screen 

 

 

Element state selection 
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Fig. 3-2-10 Property Table and Editing Screen Preview 

 

 

 Record and Output Window 

The Output Window displays all the editing actions and output message when a compile is 

completed (Fig. 3-2-11). When HMi program is compiled, if any errors occur, the error 

messages will be displayed in Output Window. To get to the element window that contains 

the error, click on the error message. 

     

Fig. 3-2-11 Output window 

 Work Place 

Following is an example of an editing display (Fig. 3-2-12). 
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Fig. 3-2-12 Work Place of Screen Editor 
 
 
 
 
 
 

 Status Bar 

Following is the status bar of HMiSoft (Fig. 3-2-13).  

 

 

 

 

 

 

 

 

 

 
Fig. 3-2-13 Status Bar of Screen Editor 

 
 

Editing Area 

Download 

Interface 

Mouse location 

 

Element Coordinate 
and Size 

Function HMi Model  
CAP LOCK 

NUM LOCK 

SCROLL LOCK 
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3.3 Internal Memory 

There are six kinds of registers for selection, internal register “$”, Non-volatile Internal Register 

“$M”, Indirect Address Register “*$”, Recipe Number Register “RCPNO”, Recipe Group Register 

“RCPG” and Recipe Register “RCP” (Fig. 3-3-1). For more details on settings, please refer to the 

following descriptions.  

 

Fig. 3-3-1 HMi Internal Memory 

3.3.1 Internal Register (Read / Write) : $ 

Word Access : $n  ( n : 0-65535 ) 

Bit Access   : $n.b( n : 0-65535, b : 0-15 ) 

The HMi provides 65536 16-bit internal registers ($0.0 - $65535.15). 

Note: The values of the registers are NOT retained when power is off. 

3.3.2 Non-volatile Internal Register (Read / Write) : $M 

Word Access: $Mn   ( n : 0-1023 ) 

Bit Access   : $Mn.b( n : 0-1023, b : 0-15 ) 

The HMi provides 1024 16-bit non-volatile internal registers ($M0.0 - $M1023.15).  

Note: The values of the registers ARE retained when the power is off, allowing for data such 

as setpoints to be saved during a power cycle, or power loss. 

 

3.3.3 Indirect Address Register (Read / Write) : *$ 

Word Access：*$n( n : 0-65535 ) 

Indirect address register is a register that stores the address of another register.  
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For example: if $7 = 20; $20 = 39; then *$7 = 39. 

The general formula：if $n = m; $m = x, then *$n = x (m : 0-65535)。 

The value of m must not be more than 65535. 

Note: The values of the registers are not retained when power is off. 

3.3.4 Recipe Number Register (Read / Write) : RCPNO 

The register is used to specify the recipe data number (Fig. 3-3-2). When 

uploading/downloading the data to HMi or PLC. If RCPNO is set to 1, it indicates it is defined 

as 1st recipe of recipe data. If RCPNO is set to 4, it indicates it is defined as 4th recipe of recipe 

data. In addition, when editing the recipe data, the user can set the size of each number of 

recipe data. For more details, please refer to the descriptions of Recipe Register RCP.  

Note: The value of the register is not retained when power is off. 

 

Fig. 3-3-2 Recipe Editing Screen 

 

 

 

3.3.5 Recipe Group Register (Read / Write) : RCPG 

The register is used to specify the 32-bit recipe group (Fig. 3-3-3). It is different than RCPNO. 

The difference is that when using 32 bit recipes, the Recipe Number Register “RCP” and the 

Recipe Group Register “RCPG” must both be used. When the user wants to upload/download 

the recipe data of the 1st recipe of the 1st group, RCPG must be set to 1 and RCPNO must be 

1st Number, RCPNO = 1 

4th Group, RCPNO = 4 



HMi Chapter 3 Creating and Editing Screens 

   3-19 

set to 1. If HMi or PLC needs to read/write the recipe data of the 4th recipe of the 3rd group, 

RCPG must be set to 3 and RCPNO must be set to 4. The recipe group number is determined 

when editing the recipe table. For more details, please refer to the descriptions of Recipe 

Register RCP.  

Note: The value of the register is not retained when power is off. 

 

 

Fig. 3-3-3 Recipe Group Editing Screen 

3.3.6 Recipe Register (Read / Write) : RCP 

The registers hold the data that is used to create the recipe that is downloaded from the HMi 

to the controller, or upload from the controller to the HMi. There are two kinds of recipe 

register, 16-bit recipe register and 32-bit recipe register.  

16-bit Recipe Register 

The size of this register is 16bit (1 Word). If the data storage area is an external memory, i.e. 

a USB disk or SM card is connected; the maximum data space of 16-bit recipe registers are 

4MB words. If the data storage area is in internal memory, the data space of 16-bit recipe 

registers is 64K words. 

 

Assume that the data size is L and the recipe number is N, and the actual recipe data space is 

equal to L x N words, i.e. L x N recipe registers are occupied. The HMi has a recipe buffer area 

(Table 3-3-2) which stores the selected recipe data by the user. The size of this buffer area is 

the same as the data size of the selected recipe. It also means that L recipe registers are 

occupied in recipe buffer area. Therefore, there will be L x (N+1) registers occupied in one 

recipe table. Use the following method to access data that set with recipe. 

1st Group, RCPG = 1 3rd Group, RCPG = 3 

1st Number, RCPNO = 1 
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Word Access： RCPn ( n : 0-L*(N+1)-1 ) 

Note: -1 indicates that the number of RCP starts from 0. 

 

 

 

 

 Table 3-3-1 Recipe Table           Table 3-3-2 Layout of Recipe Registers  

 

Example 1: 

Table 3-3-1 is an example of how to access data. The size L is set to 2 and the number N is 

set to 3 with the recipe data. Thus the layout of the recipe data will be shown as Table 3-3-2, 

i.e. RCP0~RCP7 are occupied. When RCPNO is set to 1 and the recipe buffer area will show the 

1st recipe of recipe data. If RCPNO is change to 3, the recipe buffer area will show 3rd recipe of 

recipe data shown as in Table 3-3-4.  

 

 

 

 

 

 

 

 

 

 

Table 3-3-3 Recipe Table           Table 3-3-4 Layout of Recipe Registers  

 

 

 

 

RCP0 
36

RCP1 
42

RCP2 
36

RCP3 
42

RCP4 
12

RCP5 
33

RCP6 
27

RCP7 
51

Recipe Buffer 
Area

1st Number of Recipe
Data 

RCPNO = 1

RCP0 
27

RCP1 
51

RCP2 
36

RCP3 
42

RCP4 
12

RCP5 
33

RCP6 
27

RCP7 
51

RCPNO = 3

Recipe Buffer 
Area

3rd Number of Recipe
Data 
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Example 2: 

In table 3-3-5, the size L is set to 3 and the number N is set to 2 with the recipe data. Thus the 

layout of the recipe data will be shown as Table 3-3-6, i.e. RCP0~RCP8 are occupied. When 

RCPNO is set to 2 and the recipe buffer area will show the 2nd number of recipe data.  

 

 

 

 

     Table 3-3-5 Recipe Table        Table 3-3-6 Layout of Recipe Registers  

 

32-bit Recipe Register 

The size of this register is 32bit (2 Words or Double Word, DW). If the data storage area is an 

external memory, i.e. a USB disk or SM card is connected, the data space of 32-bit recipe 

register is 50MB words. If the data storage area is an internal memory, the data space of 

32-bit recipe register depends on the specification of HMi flash memory. The user can refer 

to the specifications shown on HMi series catalogue. For more details, please refer to HMi 

Memory dialog by clicking View > Memory List (Fig. 3-3-4). 

 

Fig. 3-3-4 HMi Memory 

Assume that the data size is L and the recipe number is N, and the actual recipe data space is 

Recipe Buffer 
Area

2nd Number of 
Recipe Data 

RCP0 
12

RCP1 
33

RCP2 
76 

RCP3 
36

RCP4 
42

RCP5 
1 

RCP6 
12

RCP7 
33

RCP8 
76 

RCPNO = 2
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equal to L x N DW words, i.e. L x N recipe registers are occupied. The HMi has a recipe buffer 

area (Table 3-3-8) which stores the selected recipe data by the user. The size of this buffer 

area is the same as the data size of the selected recipe. It also means that L recipe registers 

are occupied in recipe buffer area. Therefore, there will be L x (N+1) registers occupied in 

one recipe table. Use the following method to access data that set with recipe. 

Double Word Access: RCPn ( n : 0-L*(N+1)-1 ) 

Note: -1 indicates that the number of RCP starts from 0. 

 

 

 

 

 
     Table 3-3-7 Recipe Table                  Table 3-3-8 Layout of Recipe Registers  

 

Example 1: 

Table 3-3-7 is an example of how to access data in the first group (RCPG=1). The size L is set 

to 3 and the number N is set to 4 with the recipe data. Thus the layout of the recipe data will 

be shown as Table 3-3-8, i.e. RCP0~RCP14 are occupied. When RCPNO is set to 1 and the 

recipe buffer area will show the 1st number of recipe data. If RCPNO is change to 3, the recipe 

buffer area will show 3rd number of recipe data shown as in Table 3-3-10.  

 

 

 

 

 
     Table 3-3-9 Recipe Table                   Table 3-3-10 Layout of Recipe Registers  

 

 

 

Example 2: 

Recipe Buffer 
Area 

1st Number of 
Recipe Data

RCPNO = 1

RCP0 
1

RCP1 
2 

RCP3 
1

RCP4 
2 

RCP6 
4

RCP7 
5 

RCP9 
7

RCP10 
8 

RCP2 
3

RCP5 
3

RCP8 
6

RCP11 
9

RCP12 
10

RCP13 
11 

RCP14 
12

RCP0 
7

RCP1 
8 

RCP3 
1

RCP4 
2 

RCP6 
4

RCP7 
5 

RCP9 
7

RCP10 
8 

Recipe Buffer 
Area 

3rd Number of 
Recipe Data 

RCPNO = 3

RCP2 
9

RCP5 
3

RCP8 
6

RCP11 
9

RCP12 
10

RCP13 
11 

RCP14 
12
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Table 3-3-11, is an example of how to access data in the first group (RCPG=1). The size L is 

set to 2 and the number N is set to 3 with the recipe data. Thus the layout of the recipe data 

will be shown as Table 3-3-12, i.e. RCP0~RCP7 are occupied. When RCPNO is set to 3 and the 

recipe buffer area will show the 3rd number of recipe data.  

 

 

 

 
    

Table 3-3-11 Recipe Table         Table 3-3-12 Layout of Recipe Registers  

RCP0 
14

RCP1 
15

RCP2 
10

RCP3 
11

RCP4 
12

RCP5 
13

RCP6 
14

RCP7 
15

Recipe Buffer 
Area 

RCPNO = 3

3rd Number of 
Recipe Data 
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3.4 Control Block and Status Block 

For two-way communication of Control and Status between HMi and any controller, the address 

of the control block and status block must be defined. These settings are located in the 

Configuration dialog box (Fig. 3-4-2) by clicking Options > Configuration (Fig. 3-4-1). For 

more details on settings, please refer to the following descriptions. 

  
Fig. 3-4-1 Clicking Configuration Command 

   
Fig. 3-4-2 Configuration Dialog Box 
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Note: Checking of Auto reset flags will reset the control block flags (Bits) automatically after 

the desired procedure has been executed. If this box is not checked, the system will need the 

user to reset the flags. 

 

3.4.1 Control Block 

The control block is the way a controller is used to control the HMi. By setting the control 

address to registers in the controller, the controller can initiate internal operation, i.e. screen 

switch, backlight on and off, current priority, curve sampling data and clear flag, etc. The 

registers are a continuous data block and its length is from 0 to 8 words (Fig. 3-4-2). When 

using control block features, the actual length of control block is determined by the length. It 

is important to select the correct length for the control features required. For example, when 

Screen Switch feature (Screen Number Designation Register) is used, the control block must 

be set to a length of 1 or more. If the length is set to 1, only Screen Number Designation 

Register can be used. One more example, when using History Buffer features (Sampling 

History Buffer Register), the control block must be set to a length of 4 or more. In addition, 

when using the function of Multi-language Setting Value Bit (System Control Flag Register), 

the length of the control block must be set to 8 words. When the control block is set to a 

length of zero, the control block is disabled. 

The function and explanation of each WORD is listed as Table 3-4-1 below. In the following 

table, example 1, we assume that the user uses a Eaton ELC, so the available starting 

addresses in control block are Dn ~ Dn+7 (D0 ~ D7). In example 2, we assume that the user 

uses HMi internal register $, so the available starting address in control block is$n ~ $n+7 

($15 ~ $22). The user can choose if the control block designations are stored in a PLC or HMi. 

Example 1 
(ELC register) 

Example 2 
(HMi register) Word 

Number Register Number 
Address Example Address Example 

1 Screen Number Designation Register (SNIR) Dn D0 $n $15 

2 Control Flag Register (CFR) Dn+1 D1   $n+1 $16 

3 Curve Control Register (CUCR) Dn+2 D2 $n+2 $17 

4 Sampling History Buffer Register (HBSR) Dn+3 D3 $n+3 $18 

5 Clearing History Buffer Register (HBCR) Dn+4 D4 $n+4 $19 

6 Recipe Control Register (RECR) Dn+5 D5 $n+5 $20 

7 Recipe Number Designation Register (RBIR) Dn+6 D6 $n+6 $21 

8 System Control Flag Register Dn+7 D7 $n+7 $22 

Table 3-4-1 Control Block Designations 

 

Screen Number Designation Register (SNIR) 
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The HMi will change to the screen equal to the value in the register. For example (refer to 

Table 3-4-1), if set D0 or $15.0 to 1, HMi will change to the 1st screen. If set D0 or $15.0 to 

7, HMi will change to 7th screen. 

Control Flag Register (CFR) 

Bit 
Binary Display of Relative 

Position (x) 
Function 

0 0000 0000 0000 000x Enable / Disable Communication 

1 0000 0000 0000 00x0 Enable / Disable Backlight 

2 0000 0000 0000 0x00 Enable / Disable Buzzer 

3 0000 0000 0000 x000 Clear Alarm Buffer 

4 0000 0000 000x 0000 Clear Alarm Counter 

5 0000 0000 00x0 0000 Update USB Data 

6-7 0000 0000 xx00 0000 Reserved 

8 0000 000x 0000 0000 Set User Security Level (Level 1) 

9 0000 00x0 0000 0000 Set User Security Level (Level 2) 

10 0000 0x00 0000 0000 Set User Security Level (Level 4) 

11-15 xxxx x000 0000 0000 Reserved 

 Enable / Disable Communication 

In conjunction with the Communications Interrupt check box, bit 0 controls the 

restoring of HMi communication to a controller. When bit 0 is turned ON, HMi 

communication has been disabled due to a communications fault. When bit 0 is 

turned OFF, the HMi will attempt to communicate again with the controller that it lost 

communications with.  

By checking the Communication Interrupt check box (Fig. 3-4-3) under the 

Communication tab of the Configuration dialog box this feature is enabled. When 

enabled, if the communication is lost between one PLC, the bit is turned ON and 

communications is disabled automatically without a communication fault message 

(this will not affect the communications between other PLCs). Then, the user or logic 

can clear the bit to enable the communication again. If this check box is not checked, 

this flag is disabled. 

Note: To disable and enable the communication manually, the user can use 

OPENCOM/CLOSECOM macro commands. For more details on macro commands, 

please refer to section 3.14 

For example (refer to Table 3-4-1 and Fig. 3-4-4), if the PLC connected via the COM2 

port has a communication error, and the communication retry time has been reached 

three times. The HMi will disable the communication to that PLC automatically (but 

will not disable the communication between other PLCs) and will not show a 
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communication errors. At this time, if D1 or $16.0 is set to 0, i.e. the communication 

flag is turned OFF, the communication will be enabled again and HMi will 

communicate with that PLC again.  

   
Fig. 3-4-3 Communication tab            Fig. 3-4-4 PLC Connections 

 Enable / Disable Backlight 

Bit 1 controls the backlight of HMi. When bit 1 is turned ON, the HMi backlight turns 

OFF. When bit 1 is turned OFF, the HMi backlight turns ON. For example (refer to Table 

3-4-1), if D1 is set to 2 or $16.1 is set to 1, this flag is enabled and the HMi backlight 

turns OFF. When D1 = 2, it indicates that Bit 1 of D1 is 1(0000 0000 0000 0010). 

 Enable / Disable Buzzer 

Bit 2 controls the buzzer of HMi. When bit 2 is turned ON, the HMi buzzer turns ON. 

When bit 2 is turned OFF, the HMi buzzer turns OFF. For example (refer to Table 3-4-1), 

if D1 is set to 4 or $16.2 is set to 1, the HMi buzzer turns ON. When D1 = 4, it indicates 

that Bit 2 of D1 is 1 (0000 0000 0000 0100). 

 Clear Alarm Buffer 

Bit 3 clears the alarm buffer. When an alarm history table is used, setting this bit clears 

all data inside of that table. When bit 3 is turned ON, the alarm buffer is cleared. To 

clear the alarm buffer again, this flag must be turned OFF and then ON again, if “Auto 

Reset Flags” is not selected for example (refer to Table 3-4-1), if D1 is set to 8 or $16.3 

is set to 1, this flag is turned ON and the alarm buffer will be cleared. When D1 = 8, it 

indicates that Bit 3 of D1 is 1 (0000 0000 0000 1000). 

 Clear Alarm Counter 

Bit 4 clears the alarm counter. When an alarm frequency table is used, setting this bit 

is able to clear the values for the alarms. When bit 4 is turned ON, the alarm counter is 

cleared. To clear the alarm counter again, this flag must be turned OFF and then ON 

again, if “Auto Reset Flags” is not selected. For example (refer to Table 3-4-1), if D1 is 

set to 16 or $16.4 is set to 1, this flag is turned ON and the alarm counter will be 

Communication retry is set 

to 3 times 
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cleared. When D1 = 16, it indicates that bit 4 of D1 is 1 (0000 0000 0001 0000). 

 Update USB Data 

Bit 5 updates the USB data. When this flag is used, the user can update the stored data 

in alarm buffer area into the USB disk. If one of alarm buffer, history buffer or recipe 

function is activated, and the non-volatile memory area is set to USB disk, when this 

flag is enable, the HMi will backup, and update the data that is stored in buffer area 

into USB disk in real-time. Please note that all the data will be stored in the buffer area 

first. Before reaching the limit of the buffer memory (the memory capacity of buffer 

area is 64KB and it can be user-defined as well in Configuration dialog box), the 

system will not backup and update the data into USB disk. The purpose is not to 

frequently overwrite in order to avoid damage to USB disk. Therefore, if the amount of 

data is less than the memory capacity (default is 64k), the data may be lost. The user 

can avoid this by enable the flag and updating the data into USB disk. 

For example (refer to Table 3-4-1), if D1 is set to 32 or $16.5 is set to 1, this flag is 

turned ON and the function of update USB data will be enabled. When D1 = 32, it 

indicates that Bit 5 of D1 is 1 (0000 0000 0010 0000). 

 Set User Security Level 

Bits 8 to 10 set the user security level. HMi security lever is based on the binnary value 

in bits 8 (LSB), 9, and 10(MSB), 

Flag Control 
Level 

ON OFF 
Binary Display 

Level 0  Bit 8, Bit 9, Bit 10 0000 0000 0000 0000 

Level 1 Bit 8 Bit 9, Bit 10 0000 0001 0000 0000 

Level 2 Bit 9 Bit 8, Bit 10 0000 0010 0000 0000 

Level 3 Bit 8, Bit 9 Bit 10 0000 0011 0000 0000 

Level 4 Bit 10 Bit 8, Bit 9 0000 0100 0000 0000 

Level 5 Bit 8, Bit 10 Bit 9 0000 0101 0000 0000 

Level 6 Bit 9, Bit 10 Bit 8 0000 0110 0000 0000 

Level 7 Bit 8, Bit 9, Bit 10  0000 0111 0000 0000 

For example (refer to Table 3-4-1), if D1 is set to 1280 or $16.8 and $16.10 is set to 1, 

this flag is enabled and the user security level is 5. When D1 = 1280, it indicates that 

Bit 8 and Bit 10 of D1 are both 11(0000 0101 0000 0000). 

 

 

Curve Control Register (CUCR) 

Bit Binary Display of Relative Function 
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Position (x) 

0 0000 0000 0000 000x Curve Sampling Flag 1 

1 0000 0000 0000 00x0 Curve Sampling Flag 2 

2 0000 0000 0000 0x00 Curve Sampling Flag 3 

3 0000 0000 0000 x000 Curve Sampling Flag 4 

4-7 0000 0000 xxxx 0000 Reserved 

8 0000 000x 0000 0000 Curve Clear Flag 1 

9 0000 00x0 0000 0000 Curve Clear Flag 2 

10 0000 0x00 0000 0000 Curve Clear Flag 3 

11 0000 x000 0000 0000 Curve Clear Flag 4 

12-15 xxxx 0000 0000 0000 Reserved 

 Curve Sampling Flag 

Bits 0 to 3 (flags 1 to 4) control the curve (Trend Graph, X-Y Chart, X-Y distribution or 

Curve Input) sampling. When this flag is turned ON, HMi will read consecutive 

addresses dependent on the number of samples once, changes the data to the graph 

and shows it on HMi screen (For more details on the settings of curve element, please 

refer to section 3.8.10). To control the curve sampling flag again, this flag must be 

turned OFF and then ON again. 

Each curve element has to be assigned to a sampling flag where the sample flag is 

setup in the detail property of the element. To enable the curve element, set the 

corresponding bit in this register. For example (refer to Table 3-4-1 and Fig. 3-4-5), if 

D2 or $17.0 is set to 1, the curve of figure 1 will be activated and show on the screen 

and the curves of figure 2, 3 and 4 will not. When D2=1, it indicates that Bit 0 of D2 is 

0 (0000 0000 0000 0001). 
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Fig. 3-4-5 Curve Elements on HMi Screen 

 Curve Clear Flag 

Bits 8 to 11 (flags 1 to 4) clear the curve (Trend Graph, X-Y Chart, X-Y distribution or 

Curve Input) when this flag is turned ON (For more details on the settings of curve 

element, please refer to section 3.8.10). To control the curve clear flag again, this flag 

must be turned OFF and then ON again. 

For example (refer to Table 3-4-1 and Fig. 3-4-5), if D2 is set to 512 or $17.9 is set to 

1, the curves of figure 3 will be cleared and the curves of figure 1, 2 and 4 will not. 

When D2=512, it indicates that Bit 9 of D2 is 1(0000 0010 0000 0000). 

 Sampling History Buffer Flag 

Bits 0 to 11 control the sampling history buffer operation of HMi by the PLC. When 

trigger source in the History Buffer is set up to PLC and a flag is turned ON, The HMi 

will samples one time. To control the sampling history buffer flag again, this flag must 

be turned OFF and then ON again.  

 

Corresponding Flag 
Corresponding 

Buffer Area Bit 
Binary Display of Relative 

Position (x) 
Function 

Buffer Area 1 0 0000 0000 0000 000x Sampling History Buffer 1 
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Corresponding Flag 
Corresponding 

Buffer Area Bit 
Binary Display of Relative 

Position (x) 
Function 

Buffer Area 2 1 0000 0000 0000 00x0 Sampling History Buffer 2 

Buffer Area 3 2 0000 0000 0000 0x00 Sampling History Buffer 3 

Buffer Area 4 3 0000 0000 0000 x000 Sampling History Buffer 4 

Buffer Area 5 4 0000 0000 000x 0000 Sampling History Buffer 5 

Buffer Area 6 5 0000 0000 00x0 0000 Sampling History Buffer 6 

Buffer Area 7 6 0000 0000 0x00 0000 Sampling History Buffer 7 

Buffer Area 8 7 0000 0000 x000 0000 Sampling History Buffer 8 

Buffer Area 9 8 0000 000x 0000 0000 Sampling History Buffer 9 

Buffer Area 10 9 0000 00x0 0000 0000 Sampling History Buffer 10 

Buffer Area 11 10 0000 0x00 0000 0000 Sampling History Buffer 11 

Buffer Area 12 11 0000 x000 0000 0000 Sampling History Buffer 12 

 12-15 xxxx 0000 0000 0000 Reserved 

 

 
Fig. 3-4-6 History Setup 

 

Clearing History Buffer Register (HBCR) 

The history buffer when controlled by a PLC can also be cleared by the PLC.  
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Corresponding Flag 
Corresponding 

Buffer Area Bit 
Binary Display of Relative 

Position (x) 
Function 

Buffer Area 1 0 0000 0000 0000 000x Clearing History Buffer Flag 1 

Buffer Area 2 1 0000 0000 0000 00x0 Clearing History Buffer Flag 2 

Buffer Area 3 2 0000 0000 0000 0x00 Clearing History Buffer Flag 3 

Buffer Area 4 3 0000 0000 0000 x000 Clearing History Buffer Flag 4 

Buffer Area 5 4 0000 0000 000x 0000 Clearing History Buffer Flag 5 

Buffer Area 6 5 0000 0000 00x0 0000 Clearing History Buffer Flag 6 

Buffer Area 7 6 0000 0000 0x00 0000 Clearing History Buffer Flag 7 

Buffer Area 8 7 0000 0000 x000 0000 Clearing History Buffer Flag 8 

Buffer Area 9 8 0000 000x 0000 0000 Clearing History Buffer Flag 9 

Buffer Area 10 9 0000 00x0 0000 0000 Clearing History Buffer Flag 10 

Buffer Area 11 10 0000 0x00 0000 0000 Clearing History Buffer Flag 11 

Buffer Area 12 11 0000 x000 0000 0000 Clearing History Buffer Flag 12 

 12-15 xxxx 0000 0000 0000 Reserved 

 Clearing History Buffer Flag 

Bits 0 to 11 clear the history buffer. When this flag is turned ON, HMi clears the history 

buffer one time. To control the clearing history buffer flag again, this flag must be 

turned OFF and then ON again.  

Recipe Control Register (RECR) 

Bit 
Binary Display of Relative 

Position (x) 
Function 

0 0000 0000 0000 000x Change Recipe Number Flag 

1 0000 0000 0000 00x0 
Read Recipe Flag (PLC → HMi): 

Read recipe data from PLC and store it in HMi 

2 0000 0000 0000 0x00 
Write Recipe Flag (PLC ← HMi) 

Write recipe data from HMi into PLC  

3 0000 0000 0000 x000 Change Recipe Group Number Flag  

4-7 0000 0000 xxxx 0000 Reserved 

8-15 xxxx xxxx 0000 0000 Designate Recipe Group Number  

 Change Recipe Number Flag 

To change recipe number, the user can use Recipe Number Register RCPNO directly or 

use this flag. To specify the recipe number, write the recipe number into the Recipe 

Number Designation Register (RBIR see below) and then turn ON this flag (Bit 0). To 

control the change recipe number flag again, this flag must be turned OFF and then 
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ON again.  

For example (refer to Table 3-4-1), if set D6 to 3 and set D5 or $20.0 to 1 

simultaneously, the recipe number will become 3 (RCPNO=3). When D6 = 3, it 

indicates that the designated recipe number is 3. When D5 = 1, it indicates that Bit 0 of 

D5 is 1(0000 0000 0000 0001). 

 Read Recipe Flag 

Bit 1 reads the recipe data from PLC and stores the recipe data in the specified area of 

HMi. To read and store the recipe data, specify the recipe number and turn this flag 

ON. To control the read recipe flag again, this flag must be turned OFF and then ON 

again. 

For example (refer to Table 3-4-1), if the designated recipe number is 4 (RCPNO=4), 

set D5 to 2 or $20.1 to 1 and the recipe data saved in PLC will be read and stored in 

the 4th recipe register. The original data saved in the 4th recipe register will be 

updated as well. When D5 = 2, it indicates that Bit 1 of D5 is 1(0000 0000 0000 0010). 

 Write Recipe Flag 

Bit 2 write the recipe data from HMi into PLC. To write the recipe data, specify the 

recipe number and turn this flag ON. To control the write recipe flag again, this flag 

must be turned OFF and then ON again. 

For example (refer to Table 3-4-1), if the designated recipe number is 2 (RCPNO=2), 

set D5 to 4 or $20.2 to 1 and the recipe data saved in HMi will be written into the PLC 

register immediately. The original data saved in the PLC register will be updated as 

well. When D5 = 4, Bit 2 of D5 is 1(0000 0000 0000 0100). 

 Change Recipe Group Number 

To change the recipe group number, the user can use Recipe Group Register RCPG 

directly or use this flag. To specify the recipe group number, write the recipe group 

number into the Designate Recipe Group Number Register (Bits 8 to 15) and then turn 

ON this flag. To control the change recipe group number flag again, this flag must be 

turned OFF and then ON again.  

For example (refer to Table 3-4-1), if set D5 to 520 or set$20.3 and $20.9 to 1 

simultaneously, the recipe group number will become 2 (RCPG=2). When D5 = 520, it 

indicates that Bit 3 and Bit 9 of D5 are both 1(0000 0010 0000 1000). 

 Designate Recipe Group Number 

Bits 8 to Bit 15 designate the recipe group number. When the recipe group number is 

designated and the Change Recipe Group Number flag is turn ON, HMi will change the 

value of RCPG and change the recipe group number automatically.  

For example (refer to Table 3-4-1), if set D5 to 520 or set$20.3 and $20.9 to 1 

simultaneously, the recipe group number will become 2 (RCPG=2). When D5 = 520, it 

indicates that Bit 3 and Bit 9 of D5 are both 1(0000 0010 0000 1000). 



Chapter 3 Creating and Editing Screens HMi 

3-34   

For more detailed settings, please refer to the following descriptions. 

How to designate recipe group number: 

D5 = 520(0000 0010 0000 1000) 

High Byte 

(Recipe Group Designation Register) 

0000 0010 

Low Byte 

(Other control flags relevant to Recipe) 

0000 1000 

If dividing D5 into high byte and low byte, it is easily to see that high byte determines 

the recipe group number (regardless of low byte). When the high byte setting is set to 

0000 0010, it indicates that the designated group number is the 2nd group. If the 

high byte setting is changed to 0000 0011, it indicates that the designated group 

number is changed to 3rd group and vise versa.  

Recipe Number Designation Register (RBIR) 

This register is used to specify the recipe. When the Change Recipe Number flag is turned 

ON, the system will write the designated recipe group number into Recipe Number 

Designation Register (RBIR). After Change Recipe Number Flag is turned ON, HMi will 

change the value of RCPNO and change the recipe number as well.  

For example (refer to Table 3-4-1), if set D6 to 3 and set D5 or $20.0 to 1 at the same time, 

the recipe number will become 3 (RCPNO=3) When D6 is set to 3, it indicates that the 

designated recipe number is 3. When D5 = 1, it indicates that Bit 0 of D5 is 1(0000 0000 

0000 0001). 

System Control Flag Register 

Bit 
Binary Display of Relative 

Position (x) 
Function 

0-7 0000 0000 xxxx xxxx Multi-language Setting Value 

8 0000 000x 0000 0000 Printer Flag 

9 0000 00x0 0000 0000 Printer Form Feed Flag 

10-15 xxxx xx00 0000 0000 Reserved 

 Multi-language Setting Value 

Bits 0 to 7 save the designated multi-language setting (Fig. 3-4-7). These settings 

allow the HMi to switch to the specified language (For more details on multi-language 

settings, please refer to section 3.10). 

For example (refer to Table 3-4-1 and Fig. 3-4-7), if language setting value 1 is Chinese, 

and D7 or $22.0 is set to 1, all the text in HMi will change to the text in Chinese. When 

D7 =1, it indicates that Bit 0 of D7 is 1(0000 0000 0000 0001).  

For more detailed settings, please refer to the following descriptions. 

How to designate the multi-language: 
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D7 = 1(0000 0000 0000 0001) 

High Byte 

(Other control flags relevant to System 

Control) 

0000 0000 

Low Byte 

(Multi-language Setting Value Register) 

0000 0001 

If dividing D7 into high byte and low byte, it is easily to see that low byte determines 

the multi-language setting value (regardless of high byte). When the low byte setting 

is set to 0000 0001, it indicates that the multi-language setting value is 1, i.e. the 

language setting is Chinese. If the low byte setting is changed to 0000 0011, it 

indicates that the multi-language setting value is 3, i.e. the language setting is 

Japanese. Please note that the range of multi-language setting value is from 0 to 255. 

 

Fig. 3-4-7 Multi-language Settings 

 Printer Flag 

When this flag is turned ON, the current display (Hard Copy) or the editing screen can 

be printed out. When this flag is turned OFF, the printer function is disabled.  

For example (refer to Table 3-4-1), if D7 is set to 256 or set $22.8 to 1, HMi will 

perform printing function. When D7 = 256, it indicates that Bit 8 of D7 is 1(0000 0001 

0000 0000). 

 Printer Form Feed Flag 

When this flag is turned ON, the printer will retract the paper and align the paper for 
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the next run automatically. When this flag is set to OFF, the printer form feed function 

is disabled.  

For example (refer to Table 3-4-1), if D7 is set to 512 or set $22.9 to 1, HMi will retract 

the paper and align the paper for the next run automatically. When D7 = 512, it 

indicates that Bit 9 of D7 is 1(0000 0010 0000 0000). 

 

3.4.2 Status Block 

The status block provides feedback from the HMi to the PLC, i.e. screen switch, backlight on 

and off, current security level, curve sampling data and clear flag, etc. information. The 

status block consists of 8 continuous words and this cannot be changed (Fig. 3-4-2) When the 

user set the address in Status Block, the controller can read the status of the HMi. Please note 

that when the function Control Block is disabled, the function of Status Block is disabled as 

well. In addition, ensure that the addresses of Control Block and Start Block are different and 

do not overlap. 

The function and explanation of each WORD is listed as Table 3-4-2 below. In the following 

table, example 1 we assume that the user uses a Eaton ELC, so the available starting 

addresses in status block are Dm ~ Dm+7 (D10 ~ D17). In example 2, we assume that the 

user uses HMi internal register $, so the available starting address in control block is $m ~ 

$m+7 ($25 ~ $32). The user can choose if the status block designations are stored in PLC or 

HMi. 

Example 1 
(PLC register) 

Example 2 
(HMi register) Word Control Register 

Address Example Address Example 

0 General Control Status Register (GCSR) Dm D10 $m $25 

1 Screen Number Status Register (SNSR) Dm+1 D11   $m+1 $26 

2 Curve Control Status Register (CCSR) Dm+2 D12 $m+2 $27 

3 Sampling History Buffer Status Register (HSSR) Dm+3 D13 $m+3 $28 

4 Clearing History Buffer Status Register (HCSR) Dm+4 D14 $m+4 $29 

5 Recipe Status Register (RESR) Dm+5 D15 $m+5 $30 

6 Recipe Number Status Register (RBSR) Dm+6 D16 $m+6 $31 

7 General Control Status Register 2 (GCSR2) Dm+7 D17 $m+7 $32 

Table 3-4-2 Status Block Designations 

General Control Status Register (GCSR) 

Bit 
Binary Display of Relative 

Position (x) 
Function 

0 0000 0000 0000 000x Screen Switch Status Flag 

1-2 0000 0000 0000 0xx0 Reserved 

3 0000 0000 0000 x000 Clear Status of Alarm Buffer  
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4 0000 0000 000x 0000 Clear Status of Alarm Counter 

5-7 0000 0000 xxx0 0000 Reserved 

8 0000 000x 0000 0000 User Security Level Flag (Level 1) 

9 0000 00x0 0000 0000 User Security Level Flag (Level 2) 

10 0000 0x00 0000 0000 User Security Level Flag (Level 4) 

11-15 xxxx x000 0000 0000 Reserved 

 Screen Switch Status Flag 

When HMi switches the screen, this flag is turned ON. After the screen switch is 

completed, this flag is turned OFF.  

 Clear Status of Alarm Buffer 

When HMi clears the alarm buffer, this flag is turned ON. After this function is 

completed, this flag is turned OFF.  

 Clear Status of Alarm Counter 

When HMi clears the alarm counter, this flag is turned ON. After this function is 

completed, this flag is turned OFF.  

 User Security Level Flag 

Bits 8 to 10 hold the current user security level. 

Flag Control 
Level 

ON  
Binary Display 

Level 0  Bit 8, Bit 9, Bit 10 0000 0000 0000 0000 

Level 1 Bit 8 Bit 9, Bit 10 0000 0001 0000 0000 

Level 2 Bit 9 Bit 8, Bit 10 0000 0010 0000 0000 

Level 3 Bit 8, Bit 9 Bit 10 0000 0011 0000 0000 

Level 4 Bit 10 Bit 8, Bit 9 0000 0100 0000 0000 

Level 5 Bit 8, Bit 10 Bit 9 0000 0101 0000 0000 

Level 6 Bit 9, Bit 10 Bit 8 0000 0110 0000 0000 

Level 7 Bit 8, Bit 9, Bit 10  0000 0111 0000 0000 

Screen Number Status Register (SNSR) 

This register stores the last screen number (includes sub screen) that the user opened 

(refer to D11 or $26 of Table 3-4-2).  

Curve Control Status Register (CCSR) 

Bit 
Binary Display of Relative 

Position (x) 
Function 

0 0000 0000 0000 000x Curve Sampling Status Flag 1 

1 0000 0000 0000 00x0 Curve Sampling Status Flag 2 
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2 0000 0000 0000 0x00 Curve Sampling Status Flag 3 

3 0000 0000 0000 x000 Curve Sampling Status Flag 4 

4-7 0000 0000 xxxx 0000 Reserved 

8 0000 000x 0000 0000 Curve Clear Status Flag 1 

9 0000 00x0 0000 0000 Curve Clear Status Flag 2 

10 0000 0x00 0000 0000 Curve Clear Status Flag 3 

11 0000 x000 0000 0000 Curve Clear Status Flag 4 

12-15 xxxx 0000 0000 0000 Reserved 

 Curve Sampling Status Flag 

When the HMi samples a trend graph or X-Y chart, the curve sampling status flag (bits 

0 to 3) is turned ON. After the sampling operation is completed, the curve sampling 

status flag is turned OFF. Curve Sampling Flag 1 of control block corresponds to Curve 

Sampling Status Flag 1 of status block, Curve Sampling Flag 2 of control block 

corresponds to Curve Sampling Status Flag 2 of status block and vise versa.  

 Curve Clear Status Flag 

When the HMi clears trend graph or X-Y chart, the curve clear status flag (bits 8 to 11) 

is turned ON. After the clear operation is completed, the curve clear status flag is 

turned OFF. Curve Clear Flag 1 of control block corresponds to Curve Clear Status Flag 

1 of status block, Curve Clear Flag 2 of control block corresponds to Curve Clear 

Status Flag 2 of status block and vise versa.  

Sampling History Buffer Status Register (HSSR) 

Corresponding Flag 
Corresponding 

Buffer Area Bit 
Binary Display of 

Relative Position (x) 
Function 

Buffer Area 1 0 0000 0000 0000 000x Sampling History Buffer Status Flag 1 

Buffer Area 2 1 0000 0000 0000 00x0 Sampling History Buffer Status Flag 2 

Buffer Area 3 2 0000 0000 0000 0x00 Sampling History Buffer Status Flag 3 

Buffer Area 4 3 0000 0000 0000 x000 Sampling History Buffer Status Flag 4 

Buffer Area 5 4 0000 0000 000x 0000 Sampling History Buffer Status Flag 5 

Buffer Area 6 5 0000 0000 00x0 0000 Sampling History Buffer Status Flag 6 

Buffer Area 7 6 0000 0000 0x00 0000 Sampling History Buffer Status Flag 7 

Buffer Area 8 7 0000 0000 x000 0000 Sampling History Buffer Status Flag 8 

Buffer Area 9 8 0000 000x 0000 0000 Sampling History Buffer Status Flag 9 

Buffer Area 10 9 0000 00x0 0000 0000 Sampling History Buffer Status Flag 10 

Buffer Area 11 10 0000 0x00 0000 0000 Sampling History Buffer Status Flag 11 

Buffer Area 12 11 0000 x000 0000 0000 Sampling History Buffer Status Flag 12 

 12-15 xxxx 0000 0000 0000 Reserved 
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 Sampling History Buffer Status Flag 

When sampling the history buffer, the sampling history buffer status flag will be set to 

ON (Bits 0 to 11 is set to ON). After the sampling operation is completed, the sampling 

history buffer status flag will be OFF. 

Clearing History Buffer Status Register (HCSR) 

Corresponding Flag 
Corresponding 

Buffer Area Bit 
Binary Display of 

Relative Position (x) 
Function 

Buffer Area 1 0 0000 0000 0000 000x Clearing History Buffer Status Flag 1 

Buffer Area 2 1 0000 0000 0000 00x0 Clearing History Buffer Status Flag 2 

Buffer Area 3 2 0000 0000 0000 0x00 Clearing History Buffer Status Flag 3 

Buffer Area 4 3 0000 0000 0000 x000 Clearing History Buffer Status Flag 4 

Buffer Area 5 4 0000 0000 000x 0000 Clearing History Buffer Status Flag 5 

Buffer Area 6 5 0000 0000 00x0 0000 Clearing History Buffer Status Flag 6 

Buffer Area 7 6 0000 0000 0x00 0000 Clearing History Buffer Status Flag 7 

Buffer Area 8 7 0000 0000 x000 0000 Clearing History Buffer Status Flag 8 

Buffer Area 9 8 0000 000x 0000 0000 Clearing History Buffer Status Flag 9 

Buffer Area 10 9 0000 00x0 0000 0000 Clearing History Buffer Status Flag 10 

Buffer Area 11 10 0000 0x00 0000 0000 Clearing History Buffer Status Flag 11 

Buffer Area 12 11 0000 x000 0000 0000 Clearing History Buffer Status Flag 12 

 12-15 xxxx 0000 0000 0000 Reserved 

 Clearing History Buffer Status Flag 

When clearing the history buffer, the clearing history buffer status flag will be set to 

ON (Bits 0 to 11 is set to ON). After the clearing operation is completed, the clearing 

history buffer status flag will be OFF. 

Recipe Status Register (RESR) 

Bit 
Binary Display of Relative 

Position (x) 
Function 

0 0000 0000 0000 000x Change Status of Recipe Number 

1 0000 0000 0000 00x0 Recipe Read Status (PLC → HMi) 

2 0000 0000 0000 0x00 Recipe Write Status (PLC ← HMi) 

3 0000 0000 0000 x000 Change Status of Recipe Group Number 

4~7 0000 0000 xxxx 0000 Reserved 

8~15 xxxx xxxx 0000 0000 Designate Status of Recipe Group Number  

 Change Status of Recipe Number 
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When the recipe number is changed, this flag is turned ON. After the recipe number is 

changed and the value of RCPNO is updated, this flag is turned OFF.  

 Recipe Read Status 

When HMi reads one value of recipe data from PLC, this flag is turned ON. After read 

operation is completed and the recipe data is stored in HMi, this flag is turned OFF.  

 Recipe Write Status 

When HMi sends one value of recipe data to PLC, this flag is turned ON. After write 

operation is completed and the recipe data is written into PLC, this flag is turned OFF.  

 Change Status of Recipe Group Number 

When the recipe group number is changed, this flag is turned ON. After the recipe 

group number is changed and the value of RCPG is updated, this flag is turned OFF.  

 Designate Status of Recipe Group Number 

No matter if the value of RCPG is designated by PLC or HMi, when the designated 

recipe group number is changed, this flag is turned ON so that the system can echo 

back the updated recipe group number to the Designate Recipe Group Number 

Register. 

Recipe Number Status Register (RBSR) 

No matter the value of RCPNO is designated by PLC or HMi, when the designated recipe 

number is changed, this flag is turned ON so that the system can feedback the updated 

recipe group number to the Designate Recipe Number Register. 

 

General Control Status Register 2 (GCSR2) 

Bit 
Binary Display of Relative 

Position (x) 
Function 

0-7 0000 0000 xxxx xxxx Multi-language Status Value 

8 0000 000x 0000 0000 Printer Status Flag 

9 0000 00x0 0000 0000 Printer Form Feed Status Flag 

10-15 xxxx xx00 0000 0000 Reserved 

 Multi-language Status Value 

Bits 0 to 7 read the current language that HMi shows from the multi-language status 

value. 

 Printer Status Flag 

When this flag is turned ON, it indicates that the printer is printing the current display 

or editing screen. When this flag is turned OFF, the printer function is disabled.  
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 Printer Form Feed Status Flag 

When this flag is turned ON, it indicates that the printer is retracting the paper and 

aligning the paper for the next run automatically. When this flag is turned OFF, the 

printer form feed function is disabled.  
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3.5 Menu Bar and Toolbar (File) 

 
3.5.1 New 

Create a new project by choosing File > New (Fig. 2.3.2) or clicking the New icon  from 

toolbar (Fig. 2.3.3), or pressing Ctrl + N.  

When new project is selected the following dialog box (Fig. 3-5-1) will show allowing the user 

to input project name, screen name, screen number, HMi type and communications with the 

base port controller.  

 
Fig. 3-5-1 New project dialog box 
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If a project is open, the user will get the following dialog box to remind the user of saving 

project (Fig. 3-5-2) before creating new project. Press Yes button to save the existed file, 

press No button not to save the file and press Cancel button to cancel the save operation. 

After the user press the Yes or No button, the new project dialog box will appear again (Fig. 

3-5-1).  

 

圖 3-5-2 Saving dialog box 

Input project name, screen name, select HMi model and connecting base port controller (Fig. 

3-5-3), and then press OK button.  

          

圖 3-5-3 HMi model and base port controller options 

 

3.5.2 Open 

Open existing project by choosing File > Open (Fig. 3-5-4) or clicking the Open icon  
from toolbar, or pressing Ctrl + O.  

If an other project is open, the user will get the Saving dialog box (Fig. 3-5-2) to remind the 

user to save the project. 

When the save operation is complete, or no current project open, the following dialog box for 

opening  an existing dpb file (Fig. 3-5-4) will appear. 
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Fig. 3-5-4 Open an old project in HMiSoft 

3.5.3 Close 

Close Project. Closes project by clicking File > Close. 

If project didn’t get saved before issuing the command of closing project, the user will get 

save dialog box (Fig. 3-5-5) to remind the user to save the project. The user can press the Yes 

button to close the project. 

 

Fig. 3-5-5 Saving dialog box 

3.5.4 Save 

Save current project with extension file “dpb” by choosing File > Save or clicking the Save 

icon , or pressing Ctrl + S. If the project is a new file, the Save as dialog box will show up 

(Fig. 3-5-6). If the project is an old file, the Save function will perform immediately and the 

Save as dialog box will not show up. 
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3.5.5 Save as  

Save current project to another file name by clicking File > Save As. The user will get Save as 

dialog box (Fig. 3-5-6) to input project name with extension file dpb. This dialog also appears 

automatically the first time any project file is saved. 

 

Fig. 3-5-6 Save as dialog box 

3.5.6 Make Ext. Memory Data 

Before using this command, compile project or an error message dialog box will show (Fig. 

3-5-7). After executing a compile, click File > Make Ext. Memory Data to copy the compiled 

HMi program into SD card or a USB disk (Fig. 3-5-8). If the SD card or USB disk with compiled 

HMi program stored inside is inserted into HMi. The HMi will read the data on SD card or USB 

disk upon boot. 

 

Fig. 3-5-7 Error message dialog box when making ext. memory data 
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Fig. 3-5-8 Make Ext. Memory Data dialog box 

 

3.5.7 Open Ext. Memory Data 

To open the screen data, select File > Open Ext. Memory Data or press Ctrl+I. A dialog box 

is displayed allowing the project to be selected.  

 

3.5.8 Password Protect 

The user can enable and disable password protect function (Fig. 3-5-9 & Fig. 3-5-10) by 

clicking File > Password protect. Once the password protect function is enabled, the dpb file 

is password protected and the user will need to input a password before opening dpb file. 

The password is set by clicking Options > Configuration > General > Security) (Fig. 3-5-11). 

If the password protect function is disabled, the Fig. 3-5-10 dialog box will show up.  

 

Fig. 3-5-9 Password protect function is enabled 
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Fig. 3-5-10 Password protect function is disabled 

 

Fig. 3-5-11 Password settings – Security 

 

3.5.9 Print 

Print current screen by choosing File > Print, or clicking the Print icon  from toolbar, or 

pressing Ctrl + P.  

 

3.5.10 Print Preview 

To preview the screen print before sending the image to the printer, select File > Print 

Preview (Fig. 3-5-12).  
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Fig. 3-5-12 Print Preview dialog box 

 

3.5.11 Print Setup 

To choose the printer and paper options, select File > Print Setup (Fig. 3-5-13). 

 

Fig. 3-5-13 Print Setup dialog box 

 

3.5.12 File Quick Access 

By default, HMiSoft presents a list of the four most recent used files on the File menu for 

quick access (Fig. 3-5-14).  
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Fig. 3-5-14 Most recent used files 

 

3.5.13 Exit 

Exit function will close all open editing files, give the user the option to save those that have 

not been save yet, and exit HMiSoft. Select this function by clicking File > Exit. If the file has 

been changed or not saved yet, the saving dialog box (Fig. 3-5-2) will show up to remind the 

user to save the project. 
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3.6 Menu Bar and Toolbar (Edit) 

 

  
 

3.6.1 Undo 

Undo the last action. Select this function by choosing Edit > Undo or clicking the Undo icon 

 from toolbar, or pressing Ctrl + Z. All actions are recorded in output window.  

 

3.6.2 Redo 

Redo the undo action. Select this function by choosing Edit > Redo or clicking the Redo icon 

 from toolbar, or pressing Ctrl + Y. All actions are recorded in output window.  

 

3.6.3 Cut 

Deletes the selected element and save it in clipboard to paste. Select this function by 

choosing Edit > Cut from menu bar, or clicking the Cut icon  from toolbar, or pressing 

Ctrl + X.  

 

 

 

3.6.4 Copy 
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Copy the selected element to the clipboard. Select this function by choosing Edit > Copy 

from menu bar or clicking the Copy icon  from toolbar, or pressing Ctrl + C.  

 

3.6.5 Paste 

Paste element from clipboard. Select this function by choosing Edit > Paste from menu bar or 

clicking the Paste icon  from toolbar, or pressing Ctrl + V. 

  

3.6.6 Delete 

Delete selected element. Select this function by choosing Edit > Delete from menu bar or 

pressing Del key.  

 

3.6.7 Select All 

This command selects all elements. When the user uses Select All, the element in the upper 

left corner will be filled with a blue and white border as a base element. Additional elements 

will be filled with a white and black border. The base element is used to align or resize.  

 

3.6.8 Find 

To find content that matches the find criteria, select Edit > Find, or click the , or press 

Ctrl + F. The user can find element text, read address, write address or memory address on 

the current screen, or all screens (Fig. 3-6-1). Once the content is located, the found content 

is displayed in the output window. To go to actual location of the found content, click in the 

output window and HMiSoft will move to the location of the found content. (Fig. 3-6-2).  
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Find 

Find What: This field is where the user enters the address, word, or phase that the user is 

looking for. 

 

Fig. 3-6-1 Find dialog box 

Options:  

Current Screen 

This causes HMiSoft to search the current screen only. The output window will 

display all matching words or phases. When the user double clicks the word or 

phase, HMiSoft will jump to that location of the matching word or phase.  

 

Fig. 3-6-2 
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All Screens 

This causes HMiSoft to search all screens and find the address, word, or phase 

that the user is looking for. The output window will display all matching words 

or phases. When the user double clicks the address, word or phase, HMiSoft will 

jump to that location of the matching word or phase. 

Type:  

Text 

To specify the data type as Text, click the Text button 

Read Address 

To specify the data type as Read Address, click the Read Address button. 

Write Address 

To specify the data type as Write Address, click the Write Address button. 

All Address 

To specify the search to look for all data types, click the All Address button. 

Check Box: 

By checking Match whole word only check box, the system finds only the 

address, words, or phrases that the user entered. If the user does not select this 

option, the system finds all contents that include the addresses, words, or 

phrases that the user entered.  

By checking Support Multi-Language Finding check box, the system finds all 

multi-language contents that include the words or phrases that the user 

entered. The user can use the Support Multi-Language Finding option when 

finding texts. 

  

3.6.9 Replace 

To replace the content that matches the replace criteria, select Edit > Replace or press Ctrl + 

R. The user can replace element text, read address, or write address on the current screen or 

all screens. The replacement data type can be Bit, Word or Double Word. The user can change 

the data type only for read addresses and write addresses. The replacement data may exists 

in Element, Macro, Control Block, Status Block, History Buffer, Alarm and Recipe. When read 

addresses and write addresses are selected, the user can choose where to find and replace 

the content that matches the replace criteria (the items for replacement). 
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Replace  

Find What: This field is where the user enters the address, word, or phase that the user is 

looking for. 

Replace With: This field is where the user enters the address, word, or phase that the user 

wants to replace with. 

 

Fig. 3-6-3 Replace dialog box 

Options:  

Current Screen 

This causes HMiSoft to navigate the current screen only. 

 

All Screen 

This causes HMiSoft to navigate all screens. 

Type:  

Text 

To specify the data type as Text, click the Text button 

Read Address 

To specify the data type as Read Address, click the Read Address button. 

Write Address 

To specify the data type as Write Address, click the Write Address button. 

 

 

 

Data Type:  
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Bit, WORD, DWORD 

If the Read Address or Write Address button is selected, the user must select a 

data type. 

Filter (Replace Criteria) 

Element, Macro, Control Block, Status Block, History Buffer, Alarm and Recipe  

If the Read Address or Write Address button is selected, the user must select 

replace criteria such as Element, Macro, Control Block, Status Block, History 

Buffer, Alarm and Recipe. 

Replace / Replace All 

If the user only wants to replace a single instance of the data, click the Replace 

button. 

If the user wants to replace all instances of the specified data automatically, 

click the Replace All button.  

For example, the user wants to replace the read address from $0 to $1234, 

enter $0 in Find What field, enter $1234 in Replace With field and press Replace 

button (Fig. 3-6-4). HMiSoft will find the matching criteria (Fig. 3-6-5) and 

perform the replacement.  

 

Fig. 3-6-4 Replace dialog box 
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Fig. 3-6-5 

 

3.6.10 Station Replace 

This function is used to replace the designated station number (PLC unit number).  

 

Fig. 3-6-6 

 

3.6.11 Group 

This command groups the selected elements. When the user groups two or more elements, 

they will become one unit. To group the elements, select Edit > Group from menu bar or 

clicking the Group icon  from toolbar. 

 

 

3.6.12 Ungroup 
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This command ungroups selected elements. To ungroup the elements, select Edit > 

Ungroup from menu bar or clicking the Ungroup icon  from toolbar.  
 

3.6.13 Order 

This command changes the stacking order (Z order) of the selected elements. To change the 

order, select Edit > Order, or select one of the specific order icons  from the 

toolbar.  

The Order icons include: 

 Bring to Top: Moves the selected element to the front. 

 Send to Bottom: Moves the selected element to the behind. 

 Bring Forward: Moves the selected element to the behind. 

 Send Backward: Moves the selected element one step to the behind. 
 

3.6.14 Align 

This command aligns the elements. The user can use this command only when more than one 

element is selected. The Screen Editor refers to the base element (first element selected) to 

align the elements. 

To align the elements, select Edit > Align, or click one of the Align icons on the toolbar  

: Align Left. Move an element to the left. 

: Align Right. Move an element to the right. 

: Align Top. Move an element to the top. 

: Align Bottom. Move an element to the bottom. 

: Align Center Vertically. Center an element vertically. 

: Align Center Horizontally. Center an element horizontally. 

: Across Space Evenly. Space selected elements evenly across the window. 

: Down Space Evenly. Space selected elements evenly from top to bottom. 

Align Left, Align Right, Align Top and Align Bottom commands are available when two or 

more elements are selected. That is because the element only can be left, right, top and 

bottom aligned relative to another element. Align Center Vertically and Align Center 

Horizontally commands are available when one or more elements are selected. Across Space 

Evenly and Down Space Evenly are available when three or more elements are selected.  

3.6.15 Make Same Size 
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This command makes to or more elements the same size. The users must select one element 

first as reference object, and then select other elements. To use this function, select Edit > 

Make Same Size or click the make same size icons in the toolbar. 

 

3.6.16 Text Process 

This command aligns the text. To use this function, select Edit > Text Process or click the 

text process icons in the toolbar. In the Import Text dialog box, the user can decide if use 

Text Bank Edit Font or not. If the user checks the box next to Text Bank Edit Font, the 

imported text will be display by adopting the fonts of Text Bank. For the settings of Text Bank, 

please refer to Options > Text Bank. 

 

3.6.17 Picture 

To use this function, select Edit > Picture or click the picture icons in the toolbar. The users 

can also use the functions of Bitmap Toolbar to perform Picture commands.  

 

3.6.18 Duplicate 

To copy one or more elements at the same time, select Edit > Duplicate. After the user has 

selected this command, the Duplicate dialog box is displayed (Fig. 3-6-7). The user can enter 

the number of columns and rows to get the total number of copies. The minimum  

If the user wants to copy only the rows, uncheck the box next to columns. If the user wants to 

copy only the columns, uncheck the box to rows. 

To set the spacing between every element, set the pixel count in the Spacing field. 

To place the copied element by ascending or descending address, click the Increase Address 

or Decrease Address button. The unit of the address can be Word or Bit. To place the copied 

element by the horizontal (X-direction) or vertical (Y-direction) direction, click the X-Direction 

or Y-Direction button (Please refer to the example 1 and 2 in Fig. 3-6-8 and Fig. 3-6-9). 
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Fig. 3-6-7 Duplicate dialog box 

 
Fig. 3-6-8 Duplicate Example 1 
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Fig. 3-6-9 Duplicate Example 2 
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3.7 Menu Bar and Toolbar (View) 

 

In View menu, the user can decide how toolbars and docking windows display. Once the user clicks 

on it, it will have icon  in front of it and will be displayed on screen. The user can also arrange 

these toolbars and docking windows by themselves. The description of each toolbar is introduced in 

the following sections. 

 

3.7.1 Tools 

Standard Toolbar 

 

Icon Function Description 

 New Create a new project 

 Open Open an old project 

 Save Save current edited project 

 Export Export an project to BMP format 

 Undo Undo an action (some actions cannot be undone) 

 Redo Redo an action 

 Cut Cut selected elements 

 Copy Copy selected elements 

 Paste Paste the element the user copy or cut 

 Find Find specific text, write address or read address 

 New Screen Create a new screen 
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Icon Function Description 

 Open Screen Open an old screen 

 Print Print current project 

 About Screen editor version 

Table 3-7-1 Standard Toolbar  

 

Status Bar 

Following is the status bar of Screen Editor (Fig. 3-7-1).  

 

 

 

 

 

 

 

 

 

 

 

 
Fig. 3-7-1 Status Bar  

 

 

Text Toolbar 

 

Icon Function Description 

 Font Size Display and change text size 

 Font Name Display and change text font 

 Align Txt to Left Align text to left 

 Text Center Horizontally 
The space at the right/left sides of text 

will be the same. 

 Align Text to Right Align text to right 

 Align Text to Top Align text to top 

Download 
Interface 

Mouse location 
 

Element Coordinate 
and Size 

Function HMi Model  CAP LOCK 

NUM LOCK 

SCROLL LOCK 
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Icon Function Description 

 Text Center Vertically 
The space at the top/bottom sides of 

text will be the same. 

 Align Text to Bottom Align text to bottom 

 Text Color Change text color 

 Bold Text bold 

 Italic Text Italic 

 Underline Add line under text 

Table 3-7-2 Text Toolbar 

Bitmap Toolbar 

 

Icon Function Description 

 Select Transparent 

Color 

Use the suction tool to remove the color of the picture and 

determine the transparent color of the picture  

 

Chang Mode for 

process all state 

pictures 

If this function is enabled (this icon is pressed), not only the 

current picture with current state but also all pictures with 

all states are stretched, resized or aligned  

 
Picture Stretch All 

Stretch the selected picture to the whole range of the 

element. 

 Picture Stretch 1: 1 Scale the picture relative to original picture size  

 Original Picture Resize the selected picture to the actual picture size 

 Picture Align Left Align the selected picture to left 

 Picture Center 

Horizontally 

The space at the right/left sides of the selected picture are 

the same 

 Picture Align Right Align the selected element to right 

 Picture Align Top Align the selected element to top 

 Picture Center 

Vertically 

The space at the top/bottom sides of the selected element 

are the same 

 Picture Align Bottom Align the selected element to bottom 

Table 3-7-3 Bitmap Toolbar 

 

Element Toolbar 
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Icon Function Description 

 Button 

 

 Meter 

 

 Bar 
 

 Pipe 

 

 Pie 
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Icon Function Description 

 Indicator 

 

 Display 

 

 Graphic 

 

 Input 

 

 Curve 

 

 Sampling 

 

 Alarm 

 

 Keypad 

 

Table 3-7-4 Element Toolbar 
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Drawing Toolbar 

 

 

Icon Function Description 

 Line Draw a line 

 Rectangle Draw a rectangle 

 Circle Draw a circle 

 Polygon Draw a polygon 

 Arc Draw an arc 

 Text Add paragraph text  

 Scale Draw a scale drawing 

 Table Create a table  

Table 3-7-5 Drawing Toolbar 

 
Layout Toolbar 1 

 

Icon Function Description 

 Current Element State State of selected element 

 View State OFF/0 Switch and view current state OFF/0 

 View State ON/1 Switch and view current state ON/1 

 
Display All Read/Write 

Address 

Display all read/write addresses of all 

elements 

 Previous screen Select previous screens 

 Next Screen Select the next screens 

 Compile Compile current project 
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Icon Function Description 

 
Download Screen and 

Recipe 
Download screen data and recipe 

 Download Screen Download screen data 

 On-line Simulation 
Test project on PC communicating 

with the controller 

 Off-line Simulation 
Test project on PC without 

communicating to the controller 

Table 3-7-6 Layout Toolbar 1 

Layout Toolbar 2 

 

Icon Function Description 

 Group Group the selected elements 

 Ungroup Ungroup the selected elements 

 Bring to Front 
Move the selected element to the front of 

all other elements 

 Send to Bottom 
Move the selected element behind all 

other elements 

 Bring Forward 
Move the selected element forward one 

position 

 Send Backward 
Move the selected element behind one 

position 

 Align Left Align the selected elements to left 

 Align Right Align the selected elements to right 

 Align Top Align the selected elements to top 

 Align Bottom Align the selected elements to bottom 

 
Align Center 

Vertically 

Set the element to be the vertical position 

of the work place 

 
Align Center 

Horizontally 

Set the element to be the horizontal 

position of the work place 

 Across Space Evenly 
Make all selected elements align  evenly 

vertical 
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Icon Function Description 

 Down Space Evenly 
Make all selected elements align  evenly 

horizontal 

 Make Same Width 
Make the selected elements the same 

width 

 Make Same Height 
Make the selected elements the same 

height 

 Make Same Size Make the selected elements the same size 

Table 3-7-7 Layout Toolbar 2 

Zoom Toolbar 

 

Icon Function Description 

 Display Level 
Lets the user set a zoom level, of25%, 

50%, 75%, 100%, 150%, 200%, or 300% 

 Zoom In 
Lets the user increase the magnification 

level 

 
Zoom Out 

Lets the user decrease the magnification 

level 

 
1:1 

Lets the user change the magnification 

level to actual size (100%). 

Table 3-7-8 Zoom Toolbar 
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3.7.2 Property Table 

The Property Table displays the element property settings for each element (Fig. 3-7-2). 

 

All elements on the current 

editing screen 

 

 

Element state selection 

 

 

 

 

Fig. 3-7-2 Property Table and Editing Screen Preview 
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3.7.3 Record and Output Window 

The Output Window displays all the editing actions and output messages when compile 

function is selected. When the HMi program is compiled, if error occurs, the error messages 

will be displayed in Output Window. To get to the error in the element window, click on the 

error message (Fig. 3-7-3, Fig. 3-7-4, Fig. 3-7-5, Fig. 3-7-6). 

         

Fig. 3-7-3 Record Window  Fig. 3-7-4 Output Window 

         

Fig. 3-7-5 Compile Result  Fig. 3-7-6 Error Message 
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3.7.4 Zoom In 

Zoom in to get a close look at the elements on HMiSoft work place (Fig. 3-7-7, Fig. 3-7-8). 

 
Fig. 3-7-7 Zoom level = 100% (Before Choosing Zoom In command) 
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Fig. 3-7-8 Zoom level = 125% (After Choosing Zoom In command) 

3.7.5 Zoom Out 

Zoom out to see more look of the elements on HMiSoft work place (Fig. 3-7-9). 

 
Fig. 3-7-9 Zoom level = 75% (After Choosing Zoom Out command) 

 

3.7.6 Actual Size 

Return to actual size (100%). This size is relative to the screen size of HMi. 

No matter zoom in or zoom out command, the zoom level could be 20%, 50%, 75%, 100%, 

150%, 200% or 300%. The user can also zoom in or out by clicking  or  or selecting 

the Zoom level (Fig. 3-7-10). 

 

Fig. 3-7-10 Zoom Level 
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3.7.7 Full Screen 

Refer to Fig. 3-7-11. Full screen provides maximum view and hides all toolbars and docking 

windows other than the HMiSoft work place itself. Fig. 3-7-11 full screen also shows the 

reference macro command.  

 

Fig. 3-7-11 Full Screen (Pressing Esc key or left-click the mouse can exit Full screen) 

3.7.8 I/O Screen 

Refer to Fig. 3-7-12. I/O screen also provides maximum view and, read and write addresses of 

the element and also shows the set macro commands. 

 
Fig. 3-7-12 I/O Screen (Pressing Esc key or left-click the mouse can exit Full screen) 
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3.7.9 Grid Setup 

Grid Setup is a function that can help the user to align and position the element. The distance 

(spacing) between the grid dots can be set by the user freely (Fig. 3-7-13 and Fig. 3-7-14). 

Show Grid: Show the grid dots on the screen. 

Snap to Grid: Make the elements snap to grid so that the elements can jump between grid 

lines when the user moves them.  

 
Fig. 3-7-13 Grid Setup dialog box 

 

Fig. 3-7-14 Show Grid screen 
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3.7.10 Cross Reference Table 

When creating and editing various kinds of elements, often the same address is reused. 

HMiSoft provides a cross reference table function for user’s convenience and quick reference. 

The user can view the read/write addresses of the selected element and see its relationship 

or connection with the addresses of other elements, macro commands or the system control 

area. The first row of the cross reference table displays the referred element that the user 

selected. The following rows display the elements which have the same write address. The 

user can double-click a specific row and HMi will switch to the corresponding screen of the 

referred address. In Fig. 3-7-15, we can see that alarm address and macro command use the 

same internal memory $16. 

 

Fig. 3-7-15 Cross Reference Table 

 

3.7.11 Element Part List 

When the Element Part List function is enabled, HMi sorts out and classifies all the elements 

on the current screen. The user can click the tab to switch to the classification that the user 

wants to view. The related addresses and corresponding properties are listed in each 

classification (Name, Describe, Write / Read address, Trigger address, Trigger type, Interlock 

and Level) in each tab. The user can double-click the column to let HMi select the element 

automatically and allow the user to edit the detailed property of the selected element in the 

property table.  
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Fig. 3-7-16 Element Part List dialog box 

 

3.7.12 Memory List  

There are four items in memory list: 

1. ROM: It is the location where recipe data and screen data are stored.  

2. SRAM: It is the location where non-volatile data such as history, alarms are stored.  

3. SDARM: It is the location where HMi executes the project. The project must be compiled 

before memory usage can be determined.  

4. External Storage: It indicates the external memory used. When the non-volatile data is 

stored in external memory, i.e. USB disk, the data stored in SRAM will be moved to 

external memory area. 

 

 

 

 

 

 

 

 

 

 

 

 

See below example. 
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(1). See the memory space after a picture is imported.  

(2). See the memory space after a history data is created.  

 

(1). Import a picture 

When importing a picture on HMi screen the memory space of ROM and SDRAM changes.  

When the user creates a new project, the initial calculated memory used by the system is 

shown:  

ROM=3.13% 

SDAM=0.71% 

 

After importing a picture on the screen, the memory space used changes as shown in the 

figure below. 

 

At this time, the memory space is changed as: 

ROM=7.29% 

SDAM=3.98% 

The occupied ROM space increases 256K (128K-384K) and the occupied SDRAM space 

increases 600K (0K-600K). 

 

 

 

 

 

 

 

(2). Create history data 
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In this case, the original occupied memory space used is:  

ROM=7.29% 

SDAM=3.98% 

SRAM=0% 

External Storage=0% 

 

After creating a two word history data as shown in the figure below, HMi with Retained 

check box checked. 

 

 

Each saved date and time record occupied (6Bytes) 

Each saved history data occupied 2word (4Bytes) 

SRAM=（6+4）x 10 +10 Bytes (for system use) =110 Bytes 

 

Memory space used is: 

ROM=7.29% 

SDAM=3.98% 

SRAM=0.03% 

External Storage=0% 
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If the history data is saved to USB Disk (External Storage), the occupied memory space used 

is as follows:  

ROM=7.29% 

SDAM=3.98% 

SRAM=0% 

External Storage=110Bytes 

 

 

For more details setting on alarm and history data, please refer to the section 3.11.3 in 

Chapter 3. 
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3.8 Menu Bar and Toolbar (Element) 

3.8.1 Create an Element 

 

There are four methods for choosing elements when editing the screens: 

1. Right-click the mouse in the work place, and a shortcut menu will display as in Fig. 3-8-1. 

The user can then choose the desired elements from the menu. 

2. Choose Element command from menu bar as Fig. 3-8-2.  

3. Choose Element icon from toolbar as Fig. 3-8-3. 

4. Choose Element icon from Object dialog box as Fig. 3-8-4 
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Fig. 3-8-1 Shortcut menu display 

 

Fig. 3-8-2 Choose Element command from menu bar 

 

Fig. 3-8-3 Choose Element icon from toolbar 
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Fig. 3-8-4 Choose Element icon from Object dialog box 

How to Create an Element 

To create an element on HMi screen, first select a desired element from menu bar or toolbar 

and then click the starting point on the screen. While holding down the mouse button, move 

the mouse diagonally to the ending point of the element, then release the mouse button. The 

element will appear on the screen. (Fig. 3-8-7, Fig. 3-8-8, Fig. 3-8-9, Fig. 3-8-10). 
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Fig. 3-8-7 Right-click the mouse for pop up menu to select a desired element  

 
Fig. 3-8-8 Or select a desired element from menu bar 
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Fig. 3-8-9 Left-click and drag the mouse on work place then release the mouse button 

 

Fig. 3-8-10 An element is created 

How to Move an Element 

The user can use the mouse to move an element. Mouse operation is the same as working in 
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Windows® operating system. When the mouse cursor changes to a four-arrow icon , the 

user can left-click the mouse and move the element freely (Fig. 3-8-11).  

 
Fig. 3-8-11 Move an Element 

How to Change Element Width 

The user can use the mouse to modify the width of an element. When the mouse cursor 

changes to a two-arrow icon , the user can left-click the mouse and modify the element 

width (Fig. 3-8-12). 
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Fig. 3-8-12 Change Element Width 

How to Change Element Height 

The user can use the mouse to modify the height of an element. When the mouse cursor 

changes to a two-arrow icon , the user can left-click the mouse and modify the element 

height (Fig. 3-8-13). 

 
Fig. 3-8-13 Change Element Height 
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How to Change Element Width and Height Simultaneously 

The user can use the mouse to modify the width and height of an element simultaneously. 

When the mouse cursor changes to a two-arrow icon  or , the user can left-click the 

mouse and modify the element width and height at the same time (Fig. 3-8-14). 

 
Fig. 3-8-14 Change Element Width and Height Simultaneously 
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How to Input Characters 

The user can input a string of characters anywhere in the properties box where the mouse 

cursor changes to an icon . When the user left clicks in the field, the cursor  will blink 
allowing the user to input characters (Fig. 3-8-15). 

 

Fig. 3-8-15 Input Characters 
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Right-click the Mouse 

Right-clicking the in different areas of the screen will result in availability of multiple menus 

(Fig. 3-8-16, Fig. 3-8-17, Fig. 3-8-18). 

 
Fig. 3-8-16 Right-click the mouse on Toolbar - Toolbars docking window 

 
Fig. 3-8-17 Right-click the mouse on Work Place - Element Selection  
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Fig. 3-8-18 Right-click the mouse on the element - Editing options (Layout Toolbar)  
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3.8.2 Button Elements 

 

Fig. 3-8-19 Button Elements 

 

Table 3-8-1 Button Elements 

Button Type Macro Read Write Function 

Set ON Y Y 

After pressing this button, the state of the bit addressed 

will be ON. If there is an ON Macro, it will be executed 

simultaneously.  

Reset OFF Y Y 

After pressing this button, the state of the bit addressed 

will be OFF. If there is an OFF Macro, it will be executed 

simultaneously.  

Maintained 
ON 

OFF 
Y Y 

After pressing this button, the state of the bit addressed 

will be ON. If there is an ON Macro, it will be executed 

simultaneously. When pressing the button a second 

time, the state of the bit addressed will be OFF. If there is 

an OFF Macro, it will be executed simultaneously. This is 

sometimes referred to as a toggle. 
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Button Type Macro Read Write Function 

Momentary 
ON 

OFF 
Y Y 

After pressing this button, the state of the bit addressed 

will be ON. If there is an ON Macro, it will be executed 

simultaneously. The state of the bit addressed will be 

OFF when releasing the button. If there is an OFF Macro, 

it will be executed simultaneously. 

Multistate N Y Y 

There are 255 (1~256) user-defined states that can be 

configured. The user can set the sequence to next state 

or previous state.  

Set Value N N Y 

After pressing this button, the “Numeric keypad” dialog 

box will pop up on HMi screen for the user to input the 

value directly. After inputting the value and pressing 

ENTER key, HMi will transmit the input value to the Write 

Address. 

Set Constant N N Y 
After pressing this button, HMi will write the specific 

value into the Write Address.  

Increment N Y Y 

After pressing this button, HMi will add the value 

contained within the Write Address and the Inc/Dec 

value, and store the addition result back into the Write 

Address.  

Decrement N Y Y 

After pressing this button, HMi will subtract the Inc/Dec 

value from the value contained within the Write Address, 

and store the subtraction result back to the Write 

Address.  

Goto Screen N N N 
After pressing this button, it will switch to the screen 

that the user designated. 

Previous Page N N N 

After pressing this button, it will go back to the previous 

screen. For example: If the user switches the screen 

from screen 1, to screen 2 then to screen 3 in order, 

pressing “previous page” button on screen 3, the HMi 

will switch to screen 2. Pressing “previous page” on 

screen 2 will then cause the HMi to switch to screen 3. 

System 

DateTime 
O N N 

After pressing this button, it will set the system date and 

time of HMi (year-month-day, hours:minutes:seconds). 

Password 

Table Setup 
O N N 

After pressing this button, the user can set all the 

passwords of user security. 

Enter 

Password 
O N N 

After pressing this button, the user can enter the 

password.  
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Button Type Macro Read Write Function 

Contrast 

Brightness 
O N N 

After pressing this button, the user can adjust the 

contrast and brightness of HMi.  

Low Security O N N 
Pressing this button will change the user security level to 

the lowest level (LEVEL 0). 

System Menu O N N Pressing this button will switch to the HMi system menu. 

Report List O N N 

After pressing this button, the screen data can be output 

to the designated location. The user can use this 

function to print out the screen data.  

Screen 

Capture 
O N N 

After pressing this button, the current screen image can 

be captured and saved to USB disk. If a USB disk is not 

connected, the captured data cannot be saved by HMi 

successfully.  

Remove 

Storage 
O N N 

The user can press this button to remove the USB disk 

safely. 

Import/Export 

Recipe 
O N N 

Press this button to import or export the recipe data in 

CSV Excel format from or into external memory. 

Calibration O N N 
The user can press this button to perform the calibration 

function.  

Language 

Changer 
O N N 

The user can press this button to change the display 

language. 

 

3.8.2.1 Set / Reset / Maintained / Momentary Buttons 

After pressing these buttons, HMi will transmit ON/OFF signal to PLC or the controller. 

There are four types of buttons: Set button, Reset button, Maintained and Momentary 

buttons. Please refer to the following table 3-8-2 for the property description of these 

four general buttons. 

Table 3-8-2 

Property Description of General Buttons 

Write Address 

Read Address 

The address can be internal memory, internal parameter or the 

controller address. If only the write address is set, HMi will read the 

value of the write address automatically. 

Pressing  button next to the “Write Address” or “Read Address” 

open the following “Input” dialog box allowing the user to select 

the write address or the read address respectively. 
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Property Description of General Buttons 

Write Address 

Read Address 
 

The link type can be Base Port (Controller), Internal Memory or 

Internal Parameter. If the project has multiple links, the new links 

will be added into the “Link” drop-down list. After selecting the Link 

option and Device Type, and correct address, press the Enter key. 

Device types are described as follows:  

$ Internal Memory RCP Recipe Register 

$M 
Non-volatile Internal 

Memory  
RCPNO Recipe Number Register 

*$ 
Indirect Address 

Memory 
RCPG 

Recipe Group Number 

Register 

  Other 

Other device name 

supported by other brands 

of controller. Please refer to 

HMi Series Connection 

Manual.  
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Property Description of General Buttons 

Edit On/Off Macro 

When the state of the button is ON the commands of ON Macro will 

be executed simultaneously. When the state of the button is 

changed to OFF the commands of OFF Macro will be executed 

simultaneously. However, if the button is changed via macro or 

external signal, not by pressing the button, ON and OFF macro will 

not be executed. For the Macro function, please refer to section 

3-1-14 for more details.  

The user can enter the text, and set the text size, font and text 

color provided by the Windows® operating system. When the user 

presses  button next to “Font”, the following “Font Detail 
Setting” dialog box will display. 

 

Text 

Text Size 

Font 

Text Color 

In “Font Detail Setting” dialog box, the user can select Font Name, 

Font Size and Ratio of the text and view the text format from the 

Preview window. If the multi-language function is used, the user 

can see different language tabs and edit different language font 

setting in “Font Detail Setting” dialog box. Please refer to the 

example figure above. 

Blink 
The user can select to have the element blink either on an ON or 

OFF state. The blinking color is the inverse color of the button’s 
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Property Description of General Buttons 

state. To switch between the ON or OFF state of the button, use the 

state menu. Highlighted in the figure shown below. 

 
 

Bank (Picture 

Bank) 

 

The user can select a picture on the element by clicking “Bank” 

(Picture Bank). When a “Bank” has been selected, the user can click 

“Picture Name” to choose the picture of the element.  

Picture Name 
In this dialog box, the user will see the name of the currently 

selected picture for the state of the element.  

Transparent  

Effect 

 

Transparent effect allows the user to select if the color chosen in 

the Transparent Color field is removed from the picture contained 

in the element 

Transparent 

 Color 

Transparent Color allows the user to select the color to be removed 

from the picture used within an element. Alternatively the dropper 

 on the toolbar can be used to pick the color used for the 

Transparent Effect. To use the dropper , select the element to 

apply transparent color to, and then left click on the dropper  

from the toolbar, next use the mouse pointer, that now looks like a 

dropper to select the Transparent Color and automatically set the 

Transparent Effect to Yes.  

Please ensure to check whether the color of the selected element 

matches the color supported by HMi. This function is invalid and 

the color may not be removed successfully if the user applies this 

function on a 65536 colors element in a 256 colors editing 

environment.  
The effect on the element before and after this action happens is 
shown in the figures below.  
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Property Description of General Buttons 

The effect before this action 

happens 

The effect after this action 

happens 

   

Style 

The user can specify the button style shown in figures below by 

using this option.  

Standard Raised Round Invisible 

     
 
 

Property Description of General Buttons 

Function 

This Function allows the user to select one of the other three types 

of similar buttons without the need to re-create the element. For 

example a Set button can be change to a Reset button, 

Momentary button or Maintained button.  

Push Time 

(second) 

This function allows the user to set a range of 0 ~ 10 seconds. This 

is the amount of time an operator will have to push the element 

before the element completes it intended function. Releasing the 

element before this time will result in no change to the Write 

Address.  

User Security Level 

Use this option to select the user Security Level for this element. 

Only a User Security Level that is equal to or higher than this 

setting can activate this element.  

Set Low Security 

Use this option to force the current Security level to be the lowest 

setting after the button is pressed. This will require an operator to 

log in again for any actions requiring a Security Level.  

InterLock Address 

 

When InterLock Address is set to be ON or OFF (this is determined 

by the property of “InterLock State”), this element can be enabled. 

InterLock State 
Determines the state of the “InterLock Address” needed to enable 

the Element. 

Before Execute 

Macro 

If this option is set, when the user presses the button, the system 

will execute the command of this macro first and then perform the 

operation of this button. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal); the 

command of this macro will not be executed. 
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Property Description of General Buttons 

After Execute 

Macro 

If this option is set, when the user presses the button, the system 

will perform the operation of this button first and then execute the 

command of this macro. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal); the 

command of this macro will not be executed. 

Enable the  

confirm window 

When this option is set, an Action Confirm dialog box will appear 

to prompt the user when the button is pressed.  

 

Invisible Address 
When the bit in the address is set to ON the element will be 

invisible. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

3.8.2.2 Multistate Button 

Property Description of Multistate Buttons 

The Multistate button Increments or Decrements the Value in the Write Address, and 

changes state to match the value in the Read Address. 

Multistate buttons accept three Data Length formats, WORD, LSB and Bit. There are 

255 (1-256) states if its Data Length is WORD, 16 states if its Data Length is LSB and 2 

states if its Data Length is Bit. If the Data Length is WORD or LSB, the unit of memory 

address will be WORD. If the Data Length is Bit, the unit of memory address will be Bit. 

The number of states available can be changed within the properties of the Multistate 

button. 

Write Address 

Read Address 

The address can be internal memory or a controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can enter the text, and set the text size, font and text 

color provided by the Windows® operating system. (Please refer 

to Table 3-8-2 Property Description of General Buttons.) 

Blink 

The user can select to have the element blink either on an ON or 

OFF state. (Please refer to Table 3-8-2 Property Description of 

General Buttons.) 

Bank (Picture Bank) (Please refer to Table 3-8-2 Property Description of General 
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Property Description of Multistate Buttons 

Picture Name Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Style 
(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

User Security Level 

Use this option to select the user Security Level for this element. 

Only a User Security Level that is equal to or higher than this 

setting can activate this element. 

Bit Multistate button can have two states. 

Word Multistate button can have 256 states. Data Length 

LSB Multistate button can have 16 states.  

Data Format 
Allows the user to select one of four formats BCD, Signed Decimal, 

Unsigned Decimal and Hex to define the read address content.  

Add/Remove  

State 

Used to set the number of states. There are 255 (1-256) states can 

be set if its Data Length is WORD, 16 states can be set if its Data 

Length is LSB and 2 states can be set if its Data Length is Bit.  

Sequence 
Used to switch the sequence of multistate state  

Previous state (Decrement)/Next state (Increment). 

 
 

Property Description of Multistate Buttons 

User Security Level 

Use this option to select the user Security Level for this element. 

Only a User Security Level that is equal to or higher than this 

setting can activate this element.  

Set Low Security 

Use this option to force the current Security level to be the lowest 

setting after the button is pressed. This will require an operator to 

log in again for any actions requiring a Security Level.  

InterLock Address 

 

When InterLock Address is set to be ON or OFF (this is determined 

by the property of “InterLock State”), this element can be enabled. 

InterLock State 
Determines the state of the “InterLock Address” needed to enable 

the Element. 

Before Execute 

Macro 

If this option is set, when the user presses the button, the system 

will execute the command of this macro first and then perform the 

operation of this button. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal); the 

command of this macro will not be executed. 

After Execute 

Macro 

If this option is set, when the user presses the button, the system 

will perform the operation of this button first and then execute the 
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Property Description of Multistate Buttons 

command of this macro. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal); the 

command of this macro will not be executed. 

Enable the  

confirm window 

When this option is set, an Action Confirm dialog box will appear 

to prompt the user when the button is pressed.  

 

Invisible Address 
When the bit in the address is set to ON the element will be 

invisible. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

Example of Multistate Buttons:  

When the data length is LSB (D100.0 ~ D100.3): 

 

    

S0=D100.0 ON S1=D100.1 ON S2=D100.2 ON S3=D100.3 ON 

 

 

 

 

 

 

3.8.2.3 Set Value Button 

Property Description of Set Value Buttons 

After pressing this button on the screen, a system built-in numeric keypad will pop up 

and the user can use it to input a value into the Write Address directly, when ENTER key 

is pressed. The maximum and minimum input values are all user-defined. The user 

can also specify the trigger mode to trigger the designated address before or after 

writing to the Write Address.  
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Property Description of Set Value Buttons 

Write Address 

The address can be internal memory or a controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can enter the text, and set the text size, font and text 

color provided by the Windows® operating system. (Please refer 

to Table 3-8-2 Property Description of General Buttons.) 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Style 
(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Trigger 

Trigger Type 

The user can use this setting to trigger (set) the designated 

address to be ON before or after writing the setting value. If the 

address needs to be triggered again, the user should set the 

address to be OFF manually. 

Range Setting 

 

Data Length: 

16bits Word or 32bits 

Double Word 

Minimum/Maximum:  

minimum and maximum of 

input value that can be 

written to the Write Address 

Specifies the data format that will be written to 

the Write address for different data length:  

Word Double Word 

Range Setting 

Memory 

(Data Format) 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

6. Binary 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

6. Binary 
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7. Floating 

Integral Digits 

Fractional Digits 

 

Determine the number of integer and 

fractional digits. This is only a display format. 

For example: If the read address contains the 

value 1234 and the Integer is set to 3 and the 

Fractional is set to 1 then the value will be 

displayed 123.4. The digit number will be a 

real decimal number only when the Floating 

point data format is selected. 

User Security Level 

Use this option to select the user Security Level for this element. 

Only a User Security Level that is equal to or higher than this 

setting can activate this element.  

Set Low Security 

Use this option to force the current Security level to be the lowest 

setting after the button is pressed. This will require an operator 

to log in again for any actions requiring a Security Level.  

InterLock Address 

 

When InterLock Address is set to be ON or OFF (this is determined 

by the property of “InterLock State”), this element can be enabled. 

InterLock State 
Determines the state of the “InterLock Address” needed to enable 

the Element. 

Before Execute 

Macro 

If this option is set, when the user presses the button, the system 

will execute the command of this macro first and then perform 

the operation of this button. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal); 

the command of this macro will not be executed. 

After Execute Macro 

If this option is set, when the user presses the button, the system 

will perform the operation of this button first and then execute 

the command of this macro. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal); 

the command of this macro will not be executed. 

Enable the  

confirm window 

When this option is set, an Action Confirm dialog box will appear 

to prompt the user when the button is pressed.  
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Info the overrange 

message 

When this option is set, an Error dialog box will appear to prompt 

the user the input value has exceeded the limit of the range 

setting. 

 

Invisible Address 
When the bit in the address is set to ON the element will be 

invisible. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

 

3.8.2.4 Set Constant Button 

Property Description of Set Constant Buttons 

After pressing this button on the screen, HMi will send the specified constant value to 

PLC corresponding register. It has the same function as Set Value button. The user can 

also specify the trigger mode to trigger the designated PLC address before or after 

writing the setting value. 

Write Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can enter the text, and set the text size, font and text 

color provided by the Windows® operating system. (Please refer to 

Table 3-8-2 Property Description of General Buttons.) 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Style 
(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 
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Trigger 

Trigger Type 

The user can use this setting to trigger (set) the designated 

address to be ON before or after writing the setting value. If the 

address needs to be triggered again, the user should set the 

address to be OFF manually.  

 

Data Length 16bits Word or 32bits Double Word 

Data Format 

The following data format are available: 

Word/Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

Detail Range 

Const Value Used to enter the value that the user wants to write. 

User Security Level 

Use this option to select the user Security Level for this element. 

Only a User Security Level that is equal to or higher than this 

setting can activate this element.  

Set Low Security 

Use this option to force the current Security level to be the lowest 

setting after the button is pressed. This will require an operator to 

log in again for any actions requiring a Security 

InterLock Address 

 

When InterLock Address is set to be ON or OFF (this is determined 

by the property of “InterLock State”), this element can be enabled. 

InterLock State 
Determines the state of the “InterLock Address” needed to enable 

the Element. 

Before Execute 

Macro 

If this option is set, when the user presses the button, the system 

will execute the command of this macro first and then perform the 

operation of this button. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal); the 

command of this macro will not be executed. 
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After Execute 

Macro 

If this option is set, when the user presses the button, the system 

will perform the operation of this button first and then execute the 

command of this macro. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal); the 

command of this macro will not be executed. 

Enable the  

confirm window 

When this option is set, an Action Confirm dialog box will appear 

to prompt the user every time when the button is pressed.  

Invisible Address 
When the bit in the address is set to ON the element will be 

invisible. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.2.5 Increment / Decrement 

Property Description of Increment / Decrement Buttons 

After pressing this button on the screen, HMi will read the value from Read Address 

and add or subtract the Inc/Dec value. Then, write the result into Write Address. If the 

addition or subtraction result exceeds the limit (minimum and maximum) set in HMi, 

HMi will save the limit value (minimum and maximum) into the Write address.  

Write Address 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can enter the text, and set the text size, font and text 

color provided by the Windows® operating system. (Please refer to 

Table 3-8-2 Property Description of General Buttons.) 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Foreground Color 

 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Function 

This Function allows the user to select one of the other types of 

similar buttons without the need to re-create the element. For 

example Increment button and Decrement button. 
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Trigger 

Trigger Type 

The user can use this setting to trigger (set) the designated 

address to be ON before or after writing the setting value. If the 

address needs to be triggered again, the user should set the 

address to be OFF manually.  

 

Data Length 16bits Word or 32bits Double Word 

Memory 

The following data format are available: 

Word/Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

Inc/Dec 
Used to set the increasing and decreasing value 

when pressing the Increment and Decrement. 

Range Setting 

Limit 
Used to set the limit of increment and decrement 

values. 

User Security Level 

Use this option to select the user Security Level for this element. 

Only a User Security Level that is equal to or higher than this 

setting can activate this element.  

Set Low Security 

Use this option to force the current Security level to be the lowest 

setting after the button is pressed. This will require an operator to 

log in again for any actions requiring a Security 

InterLock Address 

 

When InterLock Address is set to be ON or OFF (this is determined 

by the property of “InterLock State”), this element can be enabled. 

InterLock State 
Determines the state of the “InterLock Address” needed to enable 

the Element. 
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Before Execute 

Macro 

If this option is set, when the user presses the button, the system 

will execute the command of this macro first and then perform the 

operation of this button. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal); the 

command of this macro will not be executed. 

After Execute 

Macro 

If this option is set, when the user presses the button, the system 

will perform the operation of this button first and then execute the 

command of this macro. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal); the 

command of this macro will not be executed. 

Enable the  

confirm window 

When this option is set, an Action Confirm dialog box will appear 

to prompt the user every time when the button is pressed.  

Invisible Address 
When the bit in the address is set to ON the element will be 

invisible. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.2.6 Goto Screen / Previous Page 

Property Description of Goto Screen / Previous Page Buttons 

Select one of the following to switch screens: 

1. Press the Goto button to go the screen specified. 

2. Press the Previous Page button to return to the previous screen. 

Text 

Text Size 

Font 

Text Color 

The user can enter the text, and set the text size, font and text 

color provided by the Windows® operating system. (Please refer to 

Table 3-8-2 Property Description of General Buttons.) 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Style 
(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Function 

This Function allows the user to select one of the other types of 

similar buttons without the need to re-create the element. For 

example Goto button, Previous page and Previous view. 
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Trigger 

Trigger Type 

The user can use this setting to trigger (set) the designated 

address to be ON before or after writing the setting value. If the 

address needs to be triggered again, the user should set the 

address to be OFF manually. 

This dialog box will pop up only when the button function is “Goto 

screen”. 

 

Close Sub-Screen 

When this option is selected, it indicates 

that this Goto screen button is only valid 

in Sub-Screen. When pressing this 

button, the current (active) sub screen 

will be closed.  

Setting 

User’s security level will 

be set to Low Security 

after changing screen. 

When this option is selected, it will force 

the current user’s security level to be the 

lowest after the button is pressed.  

User Security Level 

Use this option to select the user Security Level for this element. 

Only a User Security Level that is equal to or higher than this 

setting can activate this element.  
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Goto Screen 

When clicking this option, the following dialog box will pop up: 

 

In this “Open Screen” dialog box, the user can select the desired 

screen from left side and the preview screen will display on the 

right side. After selecting the screen and pressing OK button,  

InterLock Address 

 

When InterLock Address is set to be ON or OFF (this is determined 

by the property of “InterLock State”), this element can be enabled. 

InterLock State 
Determines the state of the “InterLock Address” needed to enable 

the Element. 

Before Execute 

Macro 

If this option is set, when the user presses the button, the system 

will execute the command of this macro first and then perform the 

operation of this button. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal); the 

command of this macro will not be executed. 

After Execute 

Macro 

If this option is set, when the user presses the button, the system 

will perform the operation of this button first and then execute the 

command of this macro. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal); the 

command of this macro will not be executed. 

Enable the  

confirm window 

When this option is set, an Action Confirm dialog box will appear 

to prompt the user every time when the button is pressed.  

Invisible Address 
When the bit in the address is set to ON the element will be 

invisible. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 



HMi Chapter 3 Creating and Editing Screens 

   3-111 

 

3.8.2.7 System DateTime/Password Table Setup/Enter Password/Contrast 

Brightness/Low Security/System Menu/Report List/Screen Capture/Remove 

Storage/Import & export Recipe/Calibration/Language Changer 

Property Description of System Function Buttons 

Text 

Text Size 

Font 

Text Color 

The user can enter the text, and set the text size, font and text 

color provided by the Windows® operating system. (Please refer to 

Table 3-8-2 Property Description of General Buttons.) 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Style 
(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

System Date and 

Time 

Use this option to set the system date and time 

of HMi. This function can also be accessed in the 

by pressing SYS button on HMi panel.  

 

Function 

Password Table 

Setup 

Password table can be completed via hardware 

and software settings. 

1. Hardware Settings: (Creating this a button and 

activating on a running HMi) 

 

 

Property Description of System Function Buttons 
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Function 
Password Table 

Setup 

Even though the operator can open the Password 

Table, it only indicates that the operator can 

change the password that has levels lower than 

theirs’. The user still cannot change or view those 

passwords that are higher than the users’. Please 

refer to the figures below.  

  
Highest Priority 

 
Password Level 4  

2. Software Settings: (In HMiSoft) 

Select Options > Password Setting, the following 

dialog box will show up for the user to complete 

the password settings.  

 

 
 
 

Property Description of System Function Buttons 
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Enter Password 

This button provides HMi a 

password input interface. It 

will open the corresponding 

Security Level by the 

inputting the password. 

Please refer to the figure at 

right. 

 

Contrast 

Brightness 

This button allows the user 

to adjust HMi LCD contrast 

and brightness settings. 

After pressing this button, 

the user will get the 

following pop-up window to 

adjust HMi LCD contrast and 

brightness settings. If the 

user presses “Set for default 

Contrast” button, it will set 

HMi LCD to the default 

settings. 

 

Low Security 

Using this button can set the user priority to the 

lowest (Level 0). This option makes the security 

level become the lowest to protect control system 

parameters  

System Menu 

After pressing this button, HMi will open the 

system menu screen. The user can return to 

operation screen by activating “Run” function or 

by cycling power. 

Function 

Report List 

After pressing this button, the screen data can be 

output to the designated location. The user can 

use this function to print out the screen data. 

 
 

Property Description of System Function Buttons 
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Screen Capture 

After pressing this button, the current screen 

image can be captured and saved to USB disk (BMP 

files). If a USB disk is not connected, the captured 

data cannot be saved by HMi successfully. 

The output BMP files will be stored in a folder 

named with the current date, e.g. 20090101 

(indicating the download date of that file 2009 

January 1th). While downloading, the following 

window will display on HMi screen. 

 
When this window appears, it indicates that the 

downloading operation is processing and the 

screen data is being written onto USB disk.  

The BMP files will be saved in the folder in order. 

The first file will be named as 00001; the second 

file will be named as 00002 and so on.  

*Please note that only FAT32 formatted USB disk 

can be connected. Please refer to the description 

of section 2.1. 

Remove 

Storage 

The user can press this button to remove the USB 

disk to ensure that the data is saved completely in 

USB disk. 

* Please note that only FAT32 formatted USB disk 

can be connected. Please refer to the description 

of section 2.1. 

Import/Export 

Recipe 

Press this button is to import the recipe from 

external memory (USB disk) or export the data 

saved in HMi.  

* Please note that only FAT32 formatted USB disk 

can be connected. Please refer to the description 

of section 2.1. 

Function 

Calibration 

 

Press this button to perform calibration touch 

screen function.  

 

 
Property Description of System Function Buttons 
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Trigger 

Trigger Type 

The user can use this setting to trigger (set) the designated 

address to be ON before or after writing the setting value. If the 

address needs to be triggered again, the user should set the 

address to be OFF manually. 

This option is provided in Report List button only. When the user 

selects a Report List button, the user can set this option in the 

property table. 

 
The Report Device can be USB flash drive (USB disk), Printer and SD 

card.  

USB flash drive 
Output the history records and alarm data to USB 

disk. 

Printer 

HMi will check if Print Typesetting function is set 

or not first. If Print Typesetting function is set 

already, the screen data will be output to the 

printer directly. If HMi detects the Print 

Typesetting function is not set yet, the Hard Copy 

function will be enabled. 

Report Device 

SD 
Output the history records and alarm data to SD 

card. 

User Security Level 

Use this option to select the user Security Level for this element. 

Only a User Security Level that is equal to or higher than this 

setting can activate this element.  

InterLock Address 

 

When InterLock Address is set to be ON or OFF (this is determined 

by the property of “InterLock State”), this element can be enabled. 

InterLock State 
Determines the state of the “InterLock Address” needed to enable 

the Element. 
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Before Execute 

Macro 

If this option is set, when the user presses the button, the system 

will execute the command of this macro first and then perform the 

operation of this button. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal); the 

command of this macro will not be executed. 

After Execute 

Macro 

If this option is set, when the user presses the button, the system 

will perform the operation of this button first and then execute the 

command of this macro. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal); the 

command of this macro will not be executed. 

Enable the  

confirm window 

When this option is set, an Action Confirm dialog box will appear 

to prompt the user every time when the button is pressed.  

Invisible Address 
When the bit in the address is set to ON the element will be 

invisible. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.3 Meter Elements 

 
Fig. 3-8-20 Meter Elements 

Property Description of Meter Elements 

A meter displays the numeric value in analog form. The meter can be customized in 

appearance and display properties. The meter can also display targets, high and low 

regions to help the operator identify current operating status quickly. 

Read Address 
The address can be internal memory or the controller address. (Please 

refer to Table 3-8-2 Property Description of General Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can enter the text, and set the text size, font and text color 

provided by the Windows® operating system. (Please refer to Table 

3-8-2 Property Description of General Buttons.) 

Border Color Set the border color of the element 

Background Color Set the background color of the element 

Standard Raised Sunken 

Style 

   

 
 
 
 
 
 
 
 
 
 
 
 
 

Property Description of Meter Elements 

Setting  
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Data Length 16bits Word or 32bits Double Word 

Memory Format The following data format are available: 

Word/Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

Min. Value  

Max. Value 

Used to set the display minimum and maximum value. 

 
 
 
 
 

Property Description of Meter Elements 
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Target Value 

Color 

If this option is set, the target value and its color, set 

by the user will display just like the figure shown 

below: (Here the target value is 60 and its color is in 

blue.) 

 

Ranges (Enable 

range setting) 

Please refer to the description of Low & High Region 

Color.  

Variable 

target/range 

limits 

When the target value and low & high limit is a 

variable value, the low limit address is Read 

Address+1, the high limit address is Read Address+2 

and the address of target value is Read Address+3.  

Setting 

Integral Digits 

Fractional Digits 

Determine the number of integer and fractional digits. 

This is only a display format. For example: If the read 

address contains the value 1234 and the Integer is set 

to 3 and the Fractional is set to 1 then the value will be 

displayed 123.4. The digit number will be a real 

decimal number only when the Floating point data 

format is selected. 

Low Region Color 

High Region Color 

This option is available and displayed in the property table only when 

the “Ranges” option in the Detail Setup dialog box is selected. In the 

example below,  If the user sets the low limit value to 30 and the color 

of low limit region to green, and then set the high limit value to 70 and 

the color of high limit region to red, the meter element will be shown as 

the figure below: 

 

Stitch Color Set the stitch color of the meter element. 

Grid Color Set the grid color of the meter element. 

Scale 

Region 

Number 

It is used to set the scale region number of the meter element. The user 

can use the up or down buttons to increase or decrease the scale region 

number. The setting rang is within 1 ~ 10.  

Rule Color Set the rule color of the meter element. 

X Used to set X coordinate 
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Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.4 Bar Elements 

 
Fig. 3-8-21 Bar Elements 

3.8.4.1 Normal 

Property Description of Normal Bar Elements 

HMi reads the value of the corresponding Read Address and converts the value to 

normal bar element and then displays it on the screen.  

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can enter the text, and set the text size, font and text 

color provided by the Windows® operating system. (Please refer to 

Table 3-8-2 Property Description of General Buttons.) 

Border Color Set the border color of the element 

Foreground Color 

Background Color 

It is used to set the foreground and background color of the normal 

bar element. For example, the foreground color of the following 

example bar element is green and corresponds to the value in the 

Read Address, and its background color is yellow.  

 

Standard Raised Sunken 

Style 

   

Left 
The display progressing direction is from right to the 

left. 

Right 
The display progressing direction is from left to the 

right. 

Display Format 

Top The display progressing direction is from bottom to 
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the top. 

Bottom 
The display progressing direction is from top to the 

bottom. 

 
 
 
 

Property Description of Normal Bar Elements 

 

Data Length: 

16bits Word or 32bits Double 

Word 

 

Memory Format: 

here are following data format 

provided: 

Word/Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

 

Min. Value / Max. Value: 

Used to set the display 

minimum and maximum value. 

Target Value 

Color 

If this option is set, the target value and its 
color, set by the user will display just like the 
figure shown below: (Here we set the target 
value to 50 and its color to red. The 
maximum and minimum value is 100 and 0 
respectively.) 

 

 

Ranges (Enable range 

setting) 

Please refer to the description of Low & High 

Region Color.  
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Variable target/range 

limits 

When the target value and low & high limit is 

a variable value, the low limit address is Read 

Address+1, the high limit address is Read 

Address+2 and the address of target value is 

Read Address+3.  

Low Region 

Color 

High Region 

Color 

This option is available and displayed in the property table only when 

the “Ranges” option in the Detail Setup dialog box is selected. In the 

example below,  If the user sets the low limit value to 30 and the 

color of low limit region to green, and then set the high limit value to 

70 and the color of high limit region to red, the bar element will be 

shown as the figure below: (The min. & max. input value is 0 and 100 

respectively.): 

           

When the value is 20  When the value is 50  When the value is 80 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.4.2 Differential 

Property Description of Differential Bar Elements 

HMi reads the value of the corresponding Read Address and subtracts the standard 

value from this read value creating a differential value. The differential value is display 

on the screen. 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can enter the text, and set the text size, font and text color 

provided by the Windows® operating system. (Please refer to Table 

3-8-2 Property Description of General Buttons.) 

Border Color Set the border color of the element 
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Foreground Color 

Background 

Color 

It is used to set the foreground and background color of the normal 

bar element. For example, the foreground color of the following 

example bar element is green and corresponds to the value in the 

Read Address, and its background color is yellow.  

 

 
 

Property Description of Differential Bar Elements 

Standard Raised Sunken 

Style 

   

Display Format 
Horizontal: The differential value display horizontally. 

Vertical: The differential value display vertically. 

 

Data Length: 

16bits Word or 32bits Double Word 

 

Memory Format: 

here are following data format 

provided: 

Word/Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

Standard Value 
Used to set the standard value for calculating 

differential value 

Minimum Value 

Maximum Value 

The minimum and maximum value in the differential 

bar element. 

Setting  

Display 

Deviation Limit 

The differential value will display in the designated 

color set by the user. If this option is not selected, 

the differential value will be displayed in the 

foreground color directly on the screen. 
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Variable 

Standard 

Value/Deviation 

Limit 

 

When standard value and high limit of differential 

value is variable. The address of standard value is 

Read Address+1 and the address of differential limit 

value is Read Address+2.  

 
 
 

Property Description of Differential Bar Elements 

Setting 

For example, if the data length is set to Word, the data format is set to 

Unsigned Decimal, standard value is set to 50, minimum value is set 

to 0, maximum value is set to 100 and differential limit is set to 30, 

the differential bar element will be shown as the figures below:  

       

When the value is 10      When the value is 30 

      
When the value is 70      When the value is 90 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.5 Pipe Elements 

 

Fig. 3-8-22 Pipe Elements 

3.8.5.1 Pipe(1)/Pipe(2) 

Property Description of Pipe (1) / Pipe (2) Elements 

HMi reads the value of the corresponding Read Address. Then, displays the value as a 

tank level in Pipe (1) / Pipe (2) elements. 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can enter the text, and set the text size, font and text color 

provided by the Windows® operating system. (Please refer to Table 

3-8-2 Property Description of General Buttons.) 

WaterMark Color 

Inner Tube Color 

Used to set the watermark color and inside tube color  of Pipe (1) 

and Pipe (2) element 

                                
           Pipe (1)                          Pipe (2) 

The watermark color is in blue.    The watermark color is in red. 

The inside tube color is in black.   The inside tube color is in white. 

Standard Rotation 180 

Style 
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Property Description of Pipe (1) / Pipe (2) Elements 

 

Data Length: 

16bits Word or 32bits Double 

Word 

 

Memory Format: 

here are following data format 

provided: 

Word/Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

Minimum Value 

Maximum Value 

Used to set the minimum and maximum 

capacity of the pipe element. 

Target 

Value 

Color 

The user can decide if the target value is 

display or not by using this option. 

Ranges (Enable 

range setting)  

Please refer to the description of Low & High 

Region Color. 

Setting 

Variable 

target/range limits 

 

When the target value and low & high limit is a 

variable value, the low limit address is Read 

Address+1, the high limit address is Read 

Address+2 and the address of target value is 

Read Address+3.  

Low Region Color 

High Region 

Color 

If the user sets the low limit value is 20 and the color of low limit 

region is in green, and then set the high limit value is 80 and the 

color of high limit region is in red, the pipe element will be shown 

as the figures below: 

                   
  When the value is 20   When the value is 50  When the value is 80 

X Used to set X coordinate 
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Property Description of Pipe (1) / Pipe (2) Elements 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.5.2 Pipe(3) 

Property Description of Pipe (3) Element 

It is used to connect to water pipe element. Pipe (3) element is shown in the figure 

below:  

 

Pipe Gauge: 

Use this option to set the pipe gauge. The selectable range is from 1 ~ 5.  

X Used to set X coordinate 

Y Used to set Y coordinate 

 

 

 

 

 

 

 

 

 

3.8.5.3 Pipe(4) 

Property Description of Pipe (4) Element 

It is used to connect to water pipe element. Pipe (4) element is shown in the figure 

below: 

 

Pipe Gauge: 

Use this option to set the pipe gauge. The selectable range is from 1 ~ 5.  

Style:    

Standard Rotation 90 Rotation 180 Rotation 270 
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X Used to set X coordinate 

Y Used to set Y coordinate 

 

3.8.5.4 Pipe(5) 

Property Description of Pipe (5) Element 

It is used to connect to several pipes. Pipe (5) element is shown in the figure below: 

 

Pipe Gauge: 

Use this option to set the pipe gauge. The selectable range is from 1 ~ 5.  

Style:    

Standard Rotation 90 Rotation 180 Rotation 270 

    

X Used to set X coordinate 

Y Used to set Y coordinate 

 

3.8.5.5 Pipe(6)/Pipe(7) 

Property Description of Pipe (6) / Pipe (7) Element 

Horizontal and vertical pipes. It is used to display the direction of water flow. 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

If the read address is entered, the mobile cursor will display and 

move, depicting water flowing through the pipe. For example, 

suppose Read Address is $0, when $0 is 1, the direction of water 

flow is from right to the left; when $0 is 2, the direction of water 

flow is from left to the right. When $0 is set to other value than 1 

and 2, the water will not flow.  
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Mobile Cursor Color 

When the read address has a value of 1 or 2, the mobile cursor 

will display and move. The user can use this option to set the 

mobile cursor color.  

Pipe Gauge 
Use this option to set the pipe gauge. The selectable range is 

from 1 ~ 5. 

X Used to set X coordinate 

Y Used to set Y coordinate 

 

 

 

 

 

 

3.8.6 Pie Elements 

 

Fig. 3-8-23 Pie Elements 

Property Description of Pie Elements 

There are four kinds of Pie elements for the user to select. The user can use the element 

property table to set the minimum & maximum value, low & high limit and element color, 

etc. It can be used to display the size of the set address and quickly judge its quantity by 

the increment and decrement measure of area. If the value of the address is less than the 

lower limit or higher than the high limit, it can change its color to give a warning to the 

Operator. 

Read Address 
The address can be internal memory or the controller address. (Please 

refer to Table 3-8-2 Property Description of General Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can enter the text, and set the text size, font and text color 

provided by the Windows® operating system. (Please refer to Table 3-8-2 

Property Description of General Buttons.) 

Border Color 

Foreground 

Color 

It is used to set the border color, foreground and background color of the 

pie element. For example, the border color of the following example pie 

element is in blue, and the foreground color is set to green and its 
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Property Description of Pie Elements 

Background 

Color 

background color is in yellow. 

 

Standard Raised Sunken Transparent 

Style 

    

 

Data Length: 

16bits Word or 32bits Double Word 

 

Memory Format: 

here are following data format provided: 

Word/Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

 

Min. Value / Max. Value: 

Used to set the display minimum and 

maximum value.  

 

Target Value 

Color 

The user can decide if the target value display or not 

by using this option. If this option is set, the target 

value and its color set by the user will display on the 

screen. HMi will refer to the minimum and maximum 

value and draw the proper reference line on the bar 

element just like the figure shown below: (Here we 

set the target value is 80 and its color is in yellow.) 

 

Ranges (Enable 

range setting)  

Please refer to the description of Low & High Region 

Color. 

Setting  

Variable target When the target value and low & high limit is a 
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Property Description of Pie Elements 

/range limits variable value, the low limit address is Read 

Address+1, the high limit address is Read Address+2 

and the address of target value is Read Address+3.  

Low Region 

Color 

High Region 

Color 

This option is available and displayed in the property table only when the 

“Ranges” option in the Detail Setup dialog box is selected. If the user sets 

the low limit value to 20 and the color of low limit region to green, and 

then set the high limit value to 80 and the color of high limit region to red, 

the pie element will be shown as the figures below (The min. & max. input 

value is 0 and 100 respectively.): 

             

  When the value is 20    When the value is 50   When the value is 80 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.7 Indicator Elements 

 
Fig. 3-8-24 Indicator Elements 

3.8.7.1 Multistate Indicator 

Property Description of Multistate Indicator Element 

Multistate Indicator provides a method to indicate the state of a Read Address. This 

allows the user to change states (color, text, and or image) base on the value of a Bit or 

a word. 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

The Multistate Indicator will change states (color, text, and or 

image) base on the value of a Bit or a word. For example, the user 

can set that when the value is 1, the indicator will display the text 

“Start” and when the value is 0, the indicator will display the text 

“Stop”. The user also can add a picture into each state of the 

multistate indicator and then the corresponding picture will show 

when each state is activated. 

Text 

Text Size 

Font 

Text Color 

The user can enter the text, and set the text size, font and text 

color provided by the Windows® operating system. (Please refer to 

Table 3-8-2 Property Description of General Buttons.) 

Blink 
Any or all states of the states can be set to blink. (Please refer to 

Table 3-8-2 Property Description of General Buttons.) 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Style 
(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

 
 

Property Description of Multistate Indicator Element 

Bit Indicator element can have two states. 

Word Indicator element can have 256 states. Data Length 

LSB Indicator element can have 16 states.  
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Data Format 
Allows the user to select one of four formats BCD, Signed Decimal, 

Unsigned Decimal and Hex to define the read address content 

Add/Remove State 

Used to set the number of states. There are 255 (1-256) states can 

be set if its Data Length is WORD, 16 states can be set if its Data 

Length is LSB and 2 states can be set if its Data Length is Bit.  

Invisible Address 
When the bit in the address is set to ON the element will be 

invisible. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.7.2 Range Indicator 

Property Description of Range Indicator Element 

Range Indicator provides a method to indicate the state of a Read Address.  HMi reads 

the value of the corresponding Read Address and determines what “Range” or band 

the value falls within. The element will then show the Corresponding Text, color, and 

or Picture on the HMi screen. 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

The user also can add a picture into each state of the range 

indicator and then the corresponding picture will show when each 

state is activated. 

Text 

Text Size 

Font 

Text Color 

The user can enter the text, and set the text size, font and text 

color provided by the Windows® operating system. (Please refer to 

Table 3-8-2 Property Description of General Buttons.) 

Blink 
Any or all states of the states can be set to blink. (Please refer to 

Table 3-8-2 Property Description of General Buttons.) 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

 
Property Description of Range Indicator Element 

Style 
(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Add/Remove Used to set the number of states. There are 255 (1-256) states can 
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 State be set. 

 

Data Length: 

16bits Word or 32bits Double 

Word 

 

Memory Format: 

here are following data format 

provided: 

Word/Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

 

If there is n numbers of states, it indicates that 

there is Range n-1 for the user to use. For this 

example and By default 5 states will be in the 

range. The user can specify the foreground 

color of state 0, 1, 2, 3, and 4 as red, green, 

blue, yellow and purple respectively.  

Constant 

Limits 

Range 0 Range 1 Range 2 Range 3 

100 50 33 1  

 

When the value of read address is higher than 

100, the range indicator will display in red. 

When the value of the read address is higher 

than 50, the range indicator will display in 

green, and so on. 

Detail  

Range  

Variable 

Limits 

When this option is selected, there is Range n-1 

for the user to use. n represents the total state 

numbers and n-1 represents the total range 

numbers. For example, if the read address is 

$0, and the total number of states of the 

element is 5, it indicates that there is Range 0~4 

for the user to use. Then, the lower limit value 

of Range 0 is $1, the lower limit value of Range 

1 is $2 and so on.  

Property Description of Range Indicator Element 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 
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Height Used to set the element height 

 

3.8.7.3 Simple Indicator 

Property Description of Simple Indicator Element 

Simple indicator provides two states (ON/OFF) to let the user change the XOR color of 

the base picture quickly.  

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can enter the text, and set the text size, font and text 

color provided by the Windows® operating system. (Please refer to 

Table 3-8-2 Property Description of General Buttons.) 

XOR Color Used to set XOR color of base picture. 

Redraw 

When this function is enabled, this simple indicator element can be 

overlapped and placed on the other dynamic elements to read and 

display the data of the dynamic element. When this function is 

disabled, the data of the dynamic element can not be read and 

displayed.  

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.8 Data Display Elements 

 

Fig. 3-8-25 Data Display Elements 

3.8.8.1 Numeric Display 

Property Description of Numeric Display Element 

This element will read the value of the Read Address and display the read value 

immediately in the format set by the user. 

Read Address 
The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General Buttons.) 

Text Size 

Text Color 

The user can set the text size (8~64) and text color that available to 

the HMi.  

Border Color 

Background 

Color 

Border Color option can be set only when the style of the numeric 

display element is selected as Raised and Sunken. The style of the 

element below is selected as “Sunken”. Its background color is set to 

green and its border color is set to red. 

 

(If the style of the element is set to Transparent, the Border Color 

and Background Color these two options are disabled.) 

Standard Raised Sunken Transparent 

Style 

    

Leading Zero 

The following figures show the difference if the user selects the 

Leading Zero option. (Please note that the integral digit is set to 4 

digits.) 

  (If YES is selected) 

  (If NO is selected) 
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Property Description of Numeric Display Element 

 

Date Length 16bits Word or 32bits Double Word 

Data Format 

The following data format are available: 

Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

6. Binary 

 

Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

6. Binary 

7. Floating  

Integral Digits 

Fractional Digits 

Determine the number of integer and fractional 

digits. This is only a display format. For example: 

If the read address contains the value 1234 and 

the Integer is set to 3 and the Fractional is set to 

1 then the value will be displayed 123.4. The 

digit number will be a real decimal number only 

when the Floating point data format is selected. 

Setting  

Gain (a) 

Offset (b) 

Round off 

The user can use y = (a) x (read address value) + 

(b) this equation to determine the display 

numeric value (y). For example, if Gain value (a) 

is 2 and Offset value (b) is 3, when the read 

address value is 3, then the display numeric 

value will be equal to (2) x 3 + (3) = 9. 

If Gain and Offset value is a decimal, please set 

the data format as “Floating”. 

If Round off option is selected, after the 

operation of the equation above, all numeric 

values can be rounded off and display on the 

screen. 



Chapter 3 Creating and Editing Screens HMi 

3-138  

Property Description of Numeric Display Element 

Fast Refresh 

If this option is selected, the element can be displayed immediately 

when switching the screen. Please note that this function is designed 

to provide fast value refresh speed for the element which performs 

communication frequently. Therefore, only 4 elements (including 

display element and input element) can be fast refreshed on one 

screen. If the user uses this function on too many elements, it may 

affect the normal speed of HMi operation. So, we recommend using 

this option sparingly. The user can set the Fast Refresh Rate by 

clicking Screen > Screen Properties command. There are three 

levels, High, Medium and Low for the Fast Refresh Rate. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.8.2 Character Display 

Property Description of Character Display Element 

The Character display is used to read the value of the Read addresses, convert them to text 

or character and display them on the screen. The read value must be in ASCII format. (The 

max. string length is 28words.) 

Read 

Address 

The address can be internal memory or the controller address. (Please refer to 

Table 3-8-2 Property Description of General Buttons.) 

Text Size 

Text Color 

The user can set the text size and text color provided by HMi to determine the 

text display on the element. HMi provides 8~64 kinds of default text font for the 

user to use. 

Style (Please refer to Table 3.8.2 Property Description of Numeric Display Element.) 

Border 

Color 

Background 

Color 

(Please refer to Table 3.8.2 Property Description of Numeric Display Element.) 
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Property Description of Character Display Element 

String 

Length 

The range is with 1 ~ 28 words. 

Example: Set the read address as Internal Memory $0, set the string length to 6, 

and creates three Numeric Entry elements. Then, set the data format of these 

three Numeric Entry elements as hexadecimal and enter the value as follows: 

$0 = 4241(Hex) 
$1 = 4443(Hex) 
$2 = 4645(Hex) 

 

Please note that character display element reads the Byte value, and the data 

length of the internal memory $ address is Word, which is composed of two 

Bytes. Therefore, one Word can represent two Bytes. However, as the high byte 

and low byte of the value that read by the character display element will be 

exchanged, when reading the Internal Memory $0 (=4241 (Hex)), the real display 

character will become “AB” and so on. Please refer to the following table. 

ASCII Code / Hex Cross 
Reference 

ASCII Hex 

A 41 
B 42 
C 43 
D 44 
E 45 
F 46  

Fast 

Refresh 

If this option is selected, the element can be displayed immediately when 

switching the screen. Please note that this function is designed to provide fast 

value refresh speed for the element which performs communication frequently. 

Therefore, only 4 elements (including display element and input element) can be 

fast refreshed on one screen. If the user uses this function on too many 

elements, it may affect the normal speed of HMi operation. So, we recommend 

using this option sparingly. The user can set the Fast Refresh Rate by clicking 

Screen > Screen Properties command. There are three levels, High, Medium 

and Low for the Fast Refresh Rate. 

X Used to set X coordinate 
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Property Description of Character Display Element 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.8.3 Date Display 

Property Description of Date Display Element 

Display HMi system date. There are several date formats selectable for the user to use. 

Text Size 

Text Color 

The user can set the text size and text color that are provided by 

HMi to determine the text display on the element.  

Border Color 

Background Color 

(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

Style 
(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

Date Format Three formats: MM/DD/YY, DD/MM/YY, DD.MM.YY 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.8.4 Time Display 

Property Description of Time Display Element 

Display HMi system time. There are several time formats selectable for the user to use. 

Text Size 

Text Color 

The user can set the text size and text color that provided by HMi to 

determine the text display on the element. 

Border Color 

Background Color 

(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

Style 
(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

Time Format Two Formats: HH:MM:SS, HH:MM  

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.8.5 Day-of-week Display 

Property Description of Day-of-week Display Element 
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Display the day (Sunday ~ Monday) of the week. The state default setting of the 

Day-of-week display element is set to 7. It indicates that there are 7 states for this 

element. The user can define the display text, font and color for each day directly in 

the property table. 

Text  

Text Size 

Font 

 Text Color 

The user can enter the text, and set the text size, font and text 

color provided by the Windows® operating system. (Please refer to 

Table 3-8-2 Property Description of General Buttons.) 

Border Color 

Background Color 

(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

Style 
(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.8.6 Prestored Message 

Property Description of Prestored Message Element 

Display the state content of PLC corresponding contact or register directly. The user 

can set state number and text for each state. 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can enter the text, and set the text size, font and text 

color provided by the Windows® operating system. (Please refer to 

Table 3-8-2 Property Description of General Buttons.) 

Border Color 

Background Color 

(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

Style 
(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

Bit It can have two states. 

Word It can have 256 states. Data Length 

LSB It can have 16 states.  

Data Format 
Allows the user to select one of four formats BCD, Signed Decimal, 

Unsigned Decimal and Hex to define the read address content 

Add/Remove 

State 

Used to set the number of states. There are 255 (1-256) states can 

be set if its Data Length is WORD, 16 states can be set if its Data 
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Length is LSB and 2 states can be set if its Data Length is Bit.  

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

 

3.8.8.7 Moving Sign 

Property Description of Moving Sign Element 

Moving sign is a sign that uses movement, color, and or text to depict and display the 

state corresponding to the value in the Read Address. The user can customize the 

moving sign by the settings the direction, moving points, and the interval (ms) in the 

property table. 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text 

Text Size 

Font 

Text Color 

The user can enter the text, and set the text size, font and text 

color provided by the Windows® operating system. (Please refer to 

Table 3-8-2 Property Description of General Buttons.) 

Border Color 

Background Color 

(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

Style 
(Please refer to Table 3.8.2 Property Description of Numeric Display 

Element.) 

 
Property Description of Moving Sign Element 

Bit It can have two states. 

Word It can have 256 states. Data Length 

LSB It can have 16 states.  

Data Format 
Allows the user to select one of four formats BCD, Signed Decimal, 

Unsigned Decimal and Hex to define the read address content 

Add/Remove 

State 

Used to set the number of states. There are 255 (1-256) states can 

be set if its Data Length is WORD, 16 states can be set if its Data 

Length is LSB and 2 states can be set if its Data Length is Bit. 

Left The display progressing direction is from right to the 

left. 
Direction 

Right The display progressing direction is from left to the 

right. 
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Property Description of Moving Sign Element 

Top The display progressing direction is from bottom to the 

top. 

Bottom The display progressing direction is from top to the 

bottom. 

Moving Points 
It is used to set the movement of the moving sign. The unit is Pixel 

with a range of 1 ~ 50. 

Interval(ms) 
It is used to set the interval time between movements. The unit is 

ms with a range of 50 ~ 3000 ms. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.9 Graph Display Elements 

 

Fig. 3-8-26 Graph Display Elements 

3.8.9.1 State Graphic 

Property Description of Static Graphic Element 

The user can create static graphic elements to read the value of several Read 

Addresses. The values will determine the state display on the HMi screen. 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Foreground Color (Please refer to Table 3.2.2 Property Description of Numeric 

Display Elements.) 

Bit It can have two states. 

Word It can have 256 states. Data Length 

LSB It can have 16 states.  

Data Format 
Allows the user to select one of four formats BCD, Signed Decimal, 

Unsigned Decimal and Hex to define the read address content 

Add/Remove State 

Used to set the number of states. There are 255 (1-256) states can 

be set if its Data Length is WORD, 16 states can be set if its Data 

Length is LSB and 2 states can be set if its Data Length is Bit. 

 
 
 
 
 
 
 

Property Description of Static Graphic Element 
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Property Description of Static Graphic Element 

No 

When this option is selected, the value of the read 

address will be regarded as the state number. For 

example, if the value of the read address $0 is 0, it will 

switch to 0th state; if the value of the read address $0 is 

5, it will switch to 5th state.  

Yes 

When this option is selected and the value of the read 

address is a non-zero value, the static graphic element 

will change automatically. For example, if the value of 

the read address $0 is 1 and higher (a non-zero value), 

the element will change the picture automatically 

according to the change time that the user set. When 

the value of the read address $0 is set to 0, the static 

graphic element will be back to the initial state and will 

not change the picture automatically.  

Auto Change  

Variation 

When this option is selected, the Static Graphic will have 

both user control and Auto change control of the state 

displayed. For example: If $0 is Read address of the 

element and $1(Read Address+1) is set to enable 

Auto change, when the value of the read address $1is 0, 

the value in $0 will select the state of the static graphic 

element. When $1 is 1 and higher (a non-zero value), 

the static graphic element will change the state 

automatically, like when “Yes” option is selected. 

 
 
 
 
 
 
 
 
 

Property Description of Static Graphic Element 

Transparent 

If Yes is selected, it indicates that this element will be transparent. 

It is usually used with the transparent color setting of the element. 

Please refer to the following example elements: 
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The transparent 

color has not been 

set yet. 

The element 

transparent color 

has been set. 

The transparent 

color of the whole 

drawing has been 

set. 

Please note that if Yes option is selected (set to Transparent), the 

foreground color option is disabled. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

Example of Static Graphic element: 

The designated read address = D100. The internal memory value and each state 

should be as follows: 

     
D100=0 D100=1 D100=2 D100=3 D100=4 

 

3.8.9.2 Animated Graphic 

Property Description of Animated Graphic Element 

The user can create animated graphic elements to read the value of several Read 

Addresses. The Read Addresses determine the state, location, and movement on the 

Animated Graphic on the HMi screen. 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3.2.2 Property Description of General 

Buttons.) 

Read Address 
Use the value of Read Address to switch the 

state of animated graphic element.  

Read Address+1 

Use the value of Read Address+1 as the 

horizontal axis position of the animated 

graphic element. 

Read Address 

Read Address+2 Use the value of Read Address+2 as the 
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vertical axis position of the animated graphic 

element. 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Clear Picture 
Use this option to clear previous animated graphic element when 

moving the element or changing the state of the element. 

Word It can have 256 states. 
Data Length 

LSB It can have 16 states.  

Data Format 
Allows the user to select one of four formats BCD, Signed Decimal, 

Unsigned Decimal and Hex to define the read address content 

Add/Remove State 

Used to set the number of states. There are 255 (1-256) states can 

be set if its Data Length is WORD, 16 states can be set if its Data 

Length is LSB and 2 states can be set if its Data Length is Bit. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

                

 

 

 

3.8.9.3 Dynamic Line 

Property Description of Dynamic Line Element 

The dynamic line element can be changed and moved depending on the value of the 

Read Addresses. 

The address can be internal memory or the controller address. 

(Please refer to Table 3.2.2 Property Description of General 

Buttons.) 

Read Address 

The value of the Read Address can be used 

only when Variable Position option is set to 

Yes. It is used to represent the left-top 

horizontal position (Left) of the element, i.e. 

the first X coordinate on the screen (X
1
).  

Read Address 

Read Address +1 

The value of the Read Address+1 can be used 

only when Variable Position option is set to 

Yes. It is used to represent the left-top vertical 

Y-axis control register D102 
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position (Top) of the element, i.e. the first Y 

coordinate on the screen (Y
1
). 

Read Address +2 

The value of the Read Address+2 can be used 

only when Variable Position option is set to 

Yes. It is used to represent the right-bottom 

horizontal position (Right) of the element, i.e. 

the second X coordinate on the screen (X
2
). 

Read Address +3 

The value of the Read Address+3 can be used 

only when Variable Position option is set to 

Yes. It is used to represent the right-bottom 

vertical position (Bottom) of the element, i.e. 

the second Y coordinate on the screen (Y
2
).. 

Read Address +4 

The value of the Read Address+4 can be used 

only when Variable Color option is set to Yes. 

It is used to represent the line color. The 

range is different depending on selected HMi. 

The range for 16 shades of gray model is 

within 0 ~ 15, the range for 256 colors model 

is within 0 ~ 255 and the range for 65536 

colors is within 0 ~ 65536. 

Read Address +5 

The value of the Read Address+5 can be used 

only when Blink option is set to Yes. When the 

value is higher than 1, the dynamic line 

element will blink. If the value is 0, it will not 

blink.  

Property Description of Dynamic Line Element 

Line Color Used to set the display color of the dynamic line element. 

Blink 
The element can blink. (Please refer to Table 3-8-2 Property 

Description of General Buttons.) 

Line Size The unit is Pixel with a range of 1 ~ 8. 

Data Format 
Allows the user to select one of four formats BCD, Signed Decimal, 

Unsigned Decimal and Hex to define the read address content 

Line Style 

The following line styles can be selected. 

 
Variable Position (Please refer to the description of Read Address above) 

Variable Color (Please refer to the description of Read Address above) 
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X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.9.4 Dynamic Rectangle 

Property Description of Dynamic Rectangle Element 

The dynamic rectangle element, including element size and color can be changed and 

moved depending on the value of the corresponding Read Addresses.  

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Read Address 

The value of the Read Address can be used 

only when Variable Position option is set to 

Yes. It is used to represent the left-top 

horizontal position (Left) of the element, i.e. 

the first X coordinate on the screen (X
1
).  

Read Address 

Read Address +1 

The value of the Read Address+1 can be used 

only when Variable Position option is set to 

Yes. It is used to represent the left-top vertical 

position (Top) of the element, i.e. the first Y 

coordinate on the screen (Y
1
)..  

 
 

Property Description of Dynamic Rectangle Element 

Read Address +2 

The value of the Read Address+2 can be used 

only when Variable Size option is set to Yes. It 

is used to represent the right-bottom 

horizontal position (Right) of the element, i.e. 

the width.  

Read Address +3 

The value of the Read Address+3 can be used 

only when Variable Size option is set to Yes. It 

is used to represent the right-bottom vertical 

position (Bottom) of the element, i.e. the 

height.  

Read Address 

Read Address +4 

The value of the Read Address+4 can be used 

only when Variable Color option is set to Yes. 

It is used to represent the line color. The 

range is different depending on selected HMi. 
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The range for 16 shades of gray model is 

within 0 ~ 15, the range for 256 colors model 

is within 0 ~ 255 and the range for 65536 

colors is within 0 ~ 65535. 

Read Address +5 

The value of the Read Address+5 can be used 

only when Blink option is set to Yes. When the 

value is higher than 1, the dynamic line 

element will blink. If the value is 0, it will not 

blink.  

Please note that when Variable Position option is set to No, the 

Read Address will represent the right-bottom horizontal position 

(Right) of the element. Read Address+1 will represent the 

right-bottom vertical position (Bottom) of the element. Read 

Address+2 will represent the foreground color of the element.  

Blink 
The element can blink. (Please refer to Table 3-8-2 Property 

Description of General Buttons.) 

Foreground Color 
Used to set the foreground color of the dynamic rectangle 

element. 

Line Size The unit is Pixel with a range of 1 ~ 8. 

Data Format 
Allows the user to select one of four formats BCD, Signed Decimal, 

Unsigned Decimal and Hex to define the read address content 

Transparent 

When this option is selected, the element will display only with the 

border and there is no color in the element. The Foreground Color 

option will be disabled also.  

Round Radius 

0~38 pixels round radius are provided for selection. 

 

Variable Position (Please refer to the description of Read Address above) 

Variable Size (Please refer to the description of Read Address above) 

Variable Color (Please refer to the description of Read Address above) 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.9.5 Dynamic Ellipse 

Property Description of Dynamic Ellipse Element 

The dynamic ellipse element, including element size and color can be changed and 

moved depending on the value of the corresponding contact or register. 

The address can be internal memory or the controller address. 

(Please refer to Table 3.2.2 Property Description of General 

Buttons.) 

Read Address 

The value of the Read Address can be used 

only when Variable Central Point option is set 

to Yes. It is used to represent the horizontal 

position of the element center point, i.e. the 

first X coordinate on the screen (X
1
).  

Read Address +1 

The value of the Read Address+1 can be used 

only when Variable Central Point option is set 

to Yes. It is used to represent the vertical 

position of the element center point, i.e. the 

first Y coordinate on the screen (Y
1
). 

Read Address 

Read Address +2 

The value of the Read Address+2 can be used 

only when Variable Radius option is set to Yes. 

It is used to represent the horizontal radius of 

the element, i.e. the width.  

 
Property Description of Dynamic Ellipse Element 

Read Address +3 

The value of the Read Address+3 can be used 

only when Variable Radius option is set to Yes. 

It is used to represent the vertical radius of 

the element, i.e. the height. 

Read Address +4 

The value of the Read Address+4 can be used 

only when Variable Color option is set to Yes. 

It is used to represent the line color. The 

range is different depending on selected HMi. 

The range for 16 shades of gray model is 

within 0 ~ 15, the range for 256 colors model 

is within 0 ~ 255 and the range for 65536 

colors is within 0 ~ 65536. 

Read Address 

Read Address +5 

The value of the Read Address+5 can be used 

only when Blink option is set to Yes. When the 

value is higher than 1, the dynamic line 

element will blink. If the value is 0, it will not 
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blink.  

Please note that when Variable Central Point option is set to No, 

the Read Address will represent the horizontal radius of the 

element. Read Address+1 will represent the vertical radius of the 

element. Read Address+2 will represent the foreground color of 

the element. 

Line Color Used to set the display color of the dynamic ellipse element. 

Blink 
The element can blink. (Please refer to Table 3-8-2 Property 

Description of General Buttons.) 

Foreground Color Used to set the foreground color of the dynamic ellipse element. 

Line Size The unit is Pixel with a range of 1 ~ 8. 

Data Format Allows the user to select one of four formats BCD, Signed Decimal, 

Unsigned Decimal and Hex to define the read address content 

Transparent When this option is selected, the element will display only with the 

border and there is no color in the element. The Foreground Color 

option will be disabled also.  

Variable Central 

Point 
(Please refer to the description of Read Address above) 

Variable Radius (Please refer to the description of Read Address above) 

Variable Color (Please refer to the description of Read Address above) 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.9.6 Real Image 

Property Description of Real Image Element 

1. This element provides a Dll Library which allows the user to transmit the 

user-defined image to HMi by using external programs through serial 

communication interface.  

2. Only one screen can have a real image element.  

Foreground Color Used to set the foreground color of the real image element. 

Interface Used to set the communication protocol, RS232/RS-485。 

COM 
Used to set the HMi communication port. Please note that this COM 

port cannot be used for PLC communication at the same time.  
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X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

Example 

1. Load ImgTrans.dll (the file is saved in Utility folder under the 

location of the installation destination directory. (under 

destination directory \Utility) 
 
2. Data Structure: 

typedef struct _COMM_INFO 

{ 

 char  szCOM[8]; 

 } COMM_INFO; 

，szCOM is a string of characters and the sent values aire COM1, 

COM2, COM3, …。 

 
3. List of Commands: 

(1) int hmOpen(const COMM_INFO* pCommInfo); 

(2) int hmSendImageFromFile(LPCTSTR szFileName); 

(3) HANDLE hmAsyncSendImageFromFile(LPCTSTR 

szFileName); 

(4) int hmSendImage(HBITMAP hbmp); 

(5) HANDLE hmAsyncSendImage(HBITMAP hbmp); 
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Example 

(6) int hmAbortAction(); 

(7) int hmClose(); 

4. Brief Explanation of the commands 

(1) Command: int hmOpen(const COMM_INFO* pCommInfo);  

Input Value: COMM_INFO structure 

Return Value: 1: Succeeded , 0: Failed 

Explanation: Enable HMi communication. Input the name 

of COM Port, such as COM1, COM2 etc. 

(2) Command: int SendImageFromFile(LPCTSTR szFileName); 

Input Value: File name of the image 

Return Value: 1: Succeeded , 0: Failed 

Explanation: After converting the input image format into 

the width and height of the element, and Bit value, the 

system will start to transmit the image to HMi. This 

command is a synchronous command. After the data 

transmission to HMi is completed, this command will 

return.  

(3) Command: HANDLE hmAsyncSendImageFromFile(LPCTSTR 

 szFileName); 

Input Value: File name of the image 

Return Value: 0: Failed, none zero value: Thread Handle 

Explanation: After converting the input image format into 

the width and height of the element, and Bit value, the 

system will start to transmit the image to HMi. This 

command is an asynchronous command. The user can 

perform relevant operation by using Thread Handle data. 

(4) Command: int hmSendImage(HBITMAP hbmp); 

Input Value: HBITMAP Handle in Window 

Return Value: 1: Succeeded , 0: Failed 

Explanation: After converting the input image format into 

the width and height of the element, and Bit value, the 

system will start to transmit the image to HMi. This 

command is a synchronous command. After the data 

transmission to HMi is completed, this command will 

return. 

(5) Command: HANDLE hmAsyncSendImage(HBITMAP hbmp); 

Input Value: HBITMAP Handle in Window 

Return Value: 0: Failed, none zero value: Thread Handle 
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Explanation: After converting the input image format into 

the width and height of the element, and Bit value, the 

system will start to transmit the image to HMi. This 

command is an asynchronous command. The user can 

perform relevant operation by using Thread Handle data. 

(6) Command: int hmAbortAction(); 

Input value: None 

Return Value: 0: Succeeded , 1: Failed 

Explanation: This command is used to terminate the image 

transmission via asynchronous command.  

(7) Command:int hmClose();  

Input value: None 

Return Value: 1: Succeeded , 0: Failed 

Explanation: This command is used to terminate the 

communication of HMi (When DLL ends up, this command 

will be activated automatically.)  
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3.8.10 Input Elements 

 
Fig. 3-8-27 Input Elements 

3.8.10.1 Numeric Entry 

Property Description of Numeric Entry Elements 

After pressing this numeric entry element on the screen, a system built-in numeric 

keypad will pop up and the operator can use it to input the value directly. When ENTER 

key is pressed, HMi will send the input setting value to the Write Register. The 

maximum and minimum input setting values are all user-defined. The user can also 

specify the trigger mode to trigger the designated address before or after writing the 

setting value. 

Write Address 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text Size 

Text Color 

The user can set the text size (8~64) and text color that available to 

the HMi. 

Border Color 

Background 

Color 

Border Color option can be set only when the style of the numeric 

entry element is selected as Raised and Sunken. The style of the 

element below is selected as “Raised”. Its background color is set to 

blue and its border color is set to red. 

 
(If the style of the element is set to Transparent, the Border Color 

and Background Color these two options are disabled.) 

Standard Raised Sunken Transparent 

Style 

    

Leading Zero 

The following figures show the difference if the user selects the 

Leading Zero option. (Please note that the integral digits are set to 

4.) 

   (If Yes is selected) 

   (If NO is selected) 

Trigger The user can use this setting to trigger (set) the designated address 
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Trigger Type to be ON before or after writing the setting value. If the address 

needs to be triggered again, the user should set the address to be 

OFF manually. 

 

Date 

Length 

16bits Word or 32bits Double Word 

The following data format are available: 

Data 

Format 

Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

6. Binary 

Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

6. Binary 

7. Floating 

Setting 

Edit System 

Keypad 

When the input mode is Touch Popup, the user can 

define the style of the keypad, including title, font, font 

size, font color and keypad color. 

 
 

Property Description of Numeric Entry Elements 

Setting 
Edit System 

Keypad 

 Adjust the system keypad 

size 
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 Set the height of the title bar 

 Set the font size 

Set the font 

 Set the font color 

 Set the background color 

 Return to the default setting  
Minimum 

Maximum 

The user can set the minimum and maximum of input 

value.  

Integral 

Digits 

Fractional 

Digits 

Determine the number of integer and fractional digits. 

This is only a display format. For example: If the read 

address contains the value 1234 and the Integer is set 

to 3 and the Fractional is set to 1 then the value will be 

displayed 123.4. The digit number will be a real decimal 

number only when the Floating point data format is 

selected. 

When Variable Minimum/Maximum Value option is selected, it 

indicates that the minimum value is determined by Read Address+1 

and the maximum value is determined by Read Address+2. 

Gain(a) 

Offset(b) 

Round off 

 

The user can use y = (a) x (read address value) + (b) 

this equation to determine the display numeric value (y). 

For example, if Gain value (a) is 2 and Offset value (b) is 

3, when the read address value is 3, then the display 

numeric value will be equal to (2) x 3 + (3) = 9. 

If Gain and Offset value is a decimal, please set the data 

format as “Floating”. 

If Round off option is selected, after the operation of the 

equation above, all numeric values can be rounded off 

and display on the screen. 

Input Mode 

There three input modes, Touch Popup, Active Non-Popup and 

Touch Non-Popup. The default setting is Touch Popup. For the 

description of Active Non-Popup and Touch Non-Popup mode, 

please refer to section 3.8.14 Keypad Elements.  

User Security 

Level 

Use this option to select the user Security Level for this element. 

Only a User Security Level that is equal to or higher than this setting 

can activate this element.  
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Display Asterisk 

(*) 

If YES is selected, the Entry and the keypad will display (*). 

 

Fast Refresh 

If this option is selected, the element can be displayed immediately 

when switching the screen. Please note that this function is 

designed to provide fast value refresh speed for the element which 

performs communication frequently. Therefore, only 4 elements 

(including display element and input element) can be fast refreshed 

on one screen. If the user uses this function on too many elements, 

it may affect the normal speed of HMi operation. So, we recommend 

using this option sparingly. The user can set the Fast Refresh Rate 

by clicking Screen > Screen Properties command. There are three 

levels, High, Medium and Low for the Fast Refresh Rate. 

Set Low Security 

Use this option to force the current Security level to be the lowest 

setting after the button is pressed. This will require an operator to 

log in again for any actions requiring a Security 

InterLock 

Address 

InterLock Level 

When InterLock Address is set to be ON or OFF (this is determined 

by the property of “InterLock State”), this element can be enabled. 

Before Execute 

Macro 

If this option is set, when the user presses the button, the system 

will execute the command of this macro first and then perform the 

operation of this button. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 
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After Execute 

Macro 

If this option is set, when the user presses the button, the system 

will perform the operation of this button first and then execute the 

command of this macro. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 

Info the 

overrange 

message 

When this option is set, an Error dialog box will appear to prompt 

the user the input value has exceeded the limit of the range setting. 

Invisible Address When the bit in the address is set to ON the element will be invisible. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.10.2 Character Entry 

Property Description of Character Entry Elements 

The user can set write and read address to input the data of the specific address by 

text or character and display them on the screen. The input and display text or 

character must be in ASCII format. Write and read address can be the same or 

different. (The max. string length is 28words.) 

Write Address 

Read Address 

The address can be internal memory or the controller address. 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Text Size 

Text Color 

The user can set the text size (8~64) and text color that available to 

the HMi. 

Border Color 

Background 

Color 

Border Color option can be set only when the style of the character 

entry element is selected as Raised and Sunken. The style of the 

element below is selected as “Raised”. Its background color is set to 

blue and its border color is set to gray. 

 

(If the style of the element is set to Transparent, the Border Color 

and Background Color these two options are disabled.) 

Standard Raised Sunken Transparent 

Style 

    

Character Length The range is with 1 ~ 28 words. The default setting is 4words. 
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Trigger 

Trigger Type 

The user can use this setting to trigger (set) the designated address 

to be ON before or after writing the setting value. If the address 

needs to be triggered again, the user should set the address to be 

OFF manually. 

When the input mode is Touch Popup, the user can define the style 

of the keypad, including title, font, font size, font color and keypad 

color. The position that the system keypad cannot display will be 

placed in the center of the screen.  

 

Edit System 

Keypad 

 Adjust the system keypad size 

 Set the height of the title bar 

 Set the font size 

 Set the font 

 Set the font color 

 Set the background color 

 Return to the default setting  

Input Mode 

There are Touch Popup, Active Non-Popup and Touch Non-Popup 

three options. The default setting is Touch Popup. For the 

description of Active Non-Popup and Touch Non-Popup mode, 

please refer to section 3.8.14 Keypad Elements.  

User Security 

Level 

Use this option to select the user Security Level for this element. 

Only a User Security Level that is equal to or higher than this setting 

can activate this element.  

 
 
 

Property Description of Character Entry Elements 

Display Asterisk If YES is selected, the Entry and the keypad will display (*). 



Chapter 3 Creating and Editing Screens HMi 

3-162  

Property Description of Character Entry Elements 

(*) 

 

Fast Refresh 

If this option is selected, the element can be displayed immediately 

when switching the screen. Please note that this function is 

designed to provide fast value refresh speed for the element which 

performs communication frequently. Therefore, only 4 elements 

(including display element and input element) can be fast refreshed 

on one screen. If the user uses this function on too many elements, 

it may affect the normal speed of HMi operation. So, we recommend 

using this option sparingly. The user can set the Fast Refresh Rate 

by clicking Screen > Screen Properties command. There are three 

levels, High, Medium and Low for the Fast Refresh Rate. 

Set Low Security 

Use this option to force the current Security level to be the lowest 

setting after the button is pressed. This will require an operator to 

log in again for any actions requiring a Security 

InterLock 

Address 

InterLock Level 

When InterLock Address is set to be ON or OFF (this is determined 

by the property of “InterLock State”), this element can be enabled. 

Before Execute 

Macro 

If this option is set, when the user presses the button, the system 

will execute the command of this macro first and then perform the 

operation of this button. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 
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After Execute 

Macro 

If this option is set, when the user presses the button, the system 

will perform the operation of this button first and then execute the 

command of this macro. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 

Invisible Address When the bit in the address is set to ON the element will be invisible. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.10.3 Barcode Input 

Property Description of Character Barcode Input Elements 

The user can set write and read addresses to input the data by text or character and 

display them on the screen. The input and display text or character must be in ASCII 

format. Write and read addresses can be the same or different. (The max. string length 

is 127words.)  

Write Address 

Read Address 

The address can be internal memory or the controller address. If 

only write address is set, HMi will read the value of write address 

automatically. (Please refer to Table 3-8-2 Property Description of 

General Buttons.) 

Text Size 

Text Color 

The user can set the text size (8~64) and text color that available to 

the HMi. 

Border Color 

Background 

Color 

Border Color option can be set only when the style of the character 

entry element is selected as Raised and Sunken. The style of the 

element below is selected as “Raised”. Its background color is set to 

blue and its border color is set to gray.  

 

(If the style of the element is set to Transparent, the Border Color 

and Background Color these two options are disabled.) 

Standard Raised Sunken Transparent 

Style 

    

Character Length The range is with 1 ~ 127 words. The default setting is 4words. 

 
Property Description of Character Barcode Input Elements 
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Trigger 

Trigger Type 

The user can use this setting to trigger (set) the designated address 

to be ON before or after writing the setting value. If the address 

needs to be triggered again, the user should set the address to be 

OFF manually.  

When the input mode is Touch Popup, the user can define the style 

of the keypad, including title, font, font size, font color and keypad 

color.  

 
 

Edit System 

Keypad 

 Adjust the system keypad size 

 Set the height of the title bar 

 Set the font size 

 Set the font 

 Set the font color 

 Set the background color 

 Return to the default setting  

Input Mode 

There are Touch Popup, Active Non-Popup and Touch Non-Popup 

three options. The default setting is Touch Popup. For the 

description of Active Non-Popup and Touch Non-Popup mode, 

please refer to section 3.8.14 Keypad Elements.  

User Security 

Level 

Use this option to select the user Security Level for this element. 

Only a User Security Level that is equal to or higher than this setting 

can activate this element.  
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Property Description of Character Barcode Input Elements 

Display Asterisk 

(*) 

If YES is selected, the screen will show as the following figure when 

inputting the setting value. 

 

 

Fast Refresh 

If this option is selected, the element can be displayed immediately 

when switching the screen. Please note that this function is designed 

to provide fast value refresh speed for the element which performs 

communication frequently. Therefore, only 4 elements (including 

display element and input element) can be fast refreshed on one 

screen. If the user uses this function on too many elements, it may 

affect the normal speed of HMi operation. So, we recommend the 

user not to activate this function if not necessary. The user can set 

the Fast Refresh Rate by clicking Screen > Screen Properties 

command. There are three levels of the Fast Refresh Rate and they 

are High, Medium and Low. 

Set Low Security 

Use this option to force the current Security level to be the lowest 

setting after the button is pressed. This will require an operator to 

log in again for any actions requiring a Security 

InterLock 

Address 

InterLock Level 

When InterLock Address is set to be ON or OFF (this is determined by 

the property of “InterLock State”), this element can be enabled. 

Before Execute 

Macro 

If this option is set, when the user presses the button, the system 

will execute the command of this macro first and then perform the 

operation of this button. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 
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Property Description of Character Barcode Input Elements 

After Execute 

Macro 

If this option is set, when the user presses the button, the system 

will perform the operation of this button first and then execute the 

command of this macro. But, if the state of the button is not 

triggered by pressing the button (via macro or external signal), the 

command of this macro will not be executed. 

Invisible Address When the bit in the address is set to ON the element will be invisible. 

Popup Bit When this bit is turned to ON, the user can edit it manually. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.11 Curve Elements 

 

Fig. 3-8-28 Curve Elements 

3.8.11.1 Trend Graph 

Property Description of Trend Graph Elements 

The first step for setting up a trend graph is to set the curve number in “Curve Field 

Total” (range is 1~4) in property table. Then, setting the read address, read format, 

curve width and color in “Detail Setup” option to complete the setup. 

The trend graph will read a contiguous group of addresses starting with Read Address 

and ending with the Read Address + “Sample Number”, and display the read data onto 

the trend graph on HMi screen.  

This function is used to read the values of the internal memory addresses and display 

on HMi screen statically. The user will need to set the specific address of the control 

block to trigger the drawing and clear operation of the trend graph. For the settings of 

the control block, please refer to Chapter 5. 

Border Color 

Background 

Color 

Border Color option can be set only when the style of the trend graph 

element is selected as Raised and Sunken. The style of the element 

below is selected as “Raised”. Its background color is set to black and 

its border color is set to gray.  

 

Standard Raised Sunken 

Style 

   
Curve Field 

Total 

1~4 curves can be set and displayed. 
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Property Description of Trend Graph Elements 

 

Setting 

Sample Number 

Max. Sample 

Number 

Sample Number can be set to a constant or a 

variable value. 

When Sample Number is a constant:  

The sample number represents a curve which is 

composed of the data of several addresses 

(registers). When the sample number exceeds the 

width range that the element can draw, the 

following warning dialog box will display.  

  

For example if the maximum number of samples is 

10 based on the width of the Trend Graph, if the 

sample number was set to a number greater than 

10 the error would show. To fix this issue lower the 

number of samples or widen the Trend Graph. 
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Property Description of Trend Graph Elements 

Sample Number 

Max. Sample 

Number 

Please note that when the sample number is a 

constant, the Max. Sample Number option is 

disabled.  

When Sample Number is a variable value: 

When the sample number is set to the address 

(register), The Max. Sample Number option must be 

set. If the read value is more than the set Max. 

Sample Number, the system will take the set Max. 

Sample Number as the actual maximum sample 

number. 

Data Format 

Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

Read Address 

The address can be internal memory or the 

controller address. (Please refer to Table 3.2.2 

Property Description of General Buttons.) 

The trend graph will read a contiguous group of 

addresses starting with Read Address and ending 

with the Read Address + “Sample Number”, and 

display the read data onto the trend graph on HMi 

screen.  

Sample Flag 

It is used to set trigger (load the trend) and clear 

flag (clear the trend). When sample flag is triggered, 

it will start to read data and draw the graph. This 

sample flag is located within the control block. 

Please refer to section 3.4 in Chapter 3 for the 

settings of the control block.  

Setting 

Minimum 

Maximum 

Minimum and maximum value of Y-axis: If the read 

value is more the maximum or less than the 

minimum, the system will display the minimum and 

maximum value. 

 
Property Description of Trend Graph Elements 

Setting 
Line Size 

Used to the display line width. The range is within 1 
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Property Description of Trend Graph Elements 

~ 8 and the unit is pixel. 

Line Color Used to set the display line color 

Grid Line Color 

Grid Number in 

Horiz. 

Please refer to the figure below. The grid color is set to red and the 

grid number in horizontal direction is set to 3. 

 
X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.11.2 X-YChart 

Property Description of X-Y Chart Elements 

The first step for setting up an X-Y Chart is to set the curve number in “Curve Field 

Total” (range is 1~4) in property table. Then, setting the read address, read format, 

curve width and color in “Detail Setup” option to complete the setup. 

The X-Y Chart will read a contiguous group of addresses starting with Read Address 

and ending with the Read Address + “Sample Number”, and display the read data onto 

the X-Y Chart on HMi screen.  

This function is used to read the values of the internal memory addresses and display 

on HMi screen statically. The user will need to set the specific address of the control 

block to trigger the drawing and clear operation of the X-Y Chart. For the settings of 

the control block, please refer to Chapter 5. 

Border Color 

Background 

Color 

Border Color option can be set only when the style of the X-Y chart 

element is selected as Raised and Sunken. The style of the element 

below is selected as “Raised”. Its background color is set to yellow and 

its border color is set to gray. 

 

Standard Raised Sunken 

Style 
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Property Description of X-Y Chart Elements 

Connect Two 

Points 

If Yes option is selected, the space between two points on the X-Y 

chart will be connected by lines. 

Curve Field 

Total 

1~4 curves can be set and displayed. 

 

Setting 

Sample Number 

Max. Sample 

Number 

Sample Number can be set to a constant or a variable 

value. 

When Sample Number is a constant:  

The sample number represents a curve which is 

composed of the data of several addresses 

(registers). When the sample number exceeds the 

width range that the element can draw, the following 

warning dialog box will display.  

  

For example if the maximum number of samples is 
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Property Description of X-Y Chart Elements 

10 based on the width of the Trend Graph, if the 

sample number was set to a number greater than 10 

the error would show. To fix this issue lower the 

number of samples or widen the Trend Graph. 

 

 
 

Property Description of X-Y Chart Elements 

Sample Number 

Max. Sample 

Number 

 

Please note that when the sample number is a 

constant, the Max. Sample Number option is 

disabled.  

When Sample Number is a variable value: 

When the sample number is set to the address 

(register), The Max. Sample Number option must be 

set. If the read value is more than the set Max. 

Sample Number, the system will take the set Max. 

Sample Number as the actual maximum sample 

number. 

Data Format 

Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

Setting 

Horiz. Read 

Address 

The address can be internal memory or the 

controller address. (Please refer to Table 3.2.2 

Property Description of General Buttons.) 

The X-Y chart will read a contiguous group of 

addresses starting with horizontal Read 

Address and ending with the horizontal Read 

Address + “Sample Number”, and display the 

read data to the points of X-axis and display on HMi 

screen. 
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Property Description of X-Y Chart Elements 

Vert. Read 

Address 

The address can be internal memory or the 

controller address. (Please refer to Table 3.2.2 

Property Description of General Buttons.) 

The X-Y chart will read a contiguous group of 

addresses starting with vertical Read Address 

and ending with the vertical Read Address + 

“Sample Number”, and display the read data 

to the points of Y-axis and display on HMi 

screen. 

Sample Flag 

It is used to set trigger (load the trend) and clear flag 

(clear the trend). When the sample flag is triggered, 

it will start to read data and draw the X-Y chart. This 

sample flag is located within the control block 2. 

Please refer to Chapter 5 for the settings of the 

control block. 

Horiz. Minimum 

Horiz. Maximum 

It is used to set the minimum and maximum value of 

the horizontal display data, i.e. the minimum and 

maximum value of X-axis. If the read value is more 

the maximum or less than the minimum, the system 

will display the minimum and maximum value still.  

Vert. Minimum 

Vert. Maximum 

It is used to set the minimum and maximum value of 

the vertical display data, i.e. the minimum and 

maximum value of Y-axis. If the read value is more 

the maximum or less than the minimum, the system 

will display the minimum and maximum value still. 

Line Size 
Used to the display line width. The range is within 1 

~ 8 and the unit is pixel. 

Setting 

Line Color Used to set the display line color 



Chapter 3 Creating and Editing Screens HMi 

3-174  

Property Description of X-Y Chart Elements 

Grid Line Color 

Horiz. Line 

Number 

Vert. Line 

Number 

Please refer to the figure below. The grid color is set to red and the 

grid numbers in horizontal and vertical direction are both set to 2.  

 
X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.11.3 X-Y Distribution 

Property Description of X-Y Distribution Elements 

HMi will read consecutive or non- consecutive data from Write Address and display 

that data to an X-Y distribution graph on the screen.  

Border Color 

Background 

Color 

The background color of the element below is set to green and its 

border color is set to gray.  

 
Standard Raised Sunken 

Style 

 

 

  
Sample 1~4 X-Y distribution point display can be set. 
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Property Description of X-Y Distribution Elements 

Setting 

 
 
 
 
 

Property Description of X-Y Distribution Elements 

Control 

The address can be internal memory or the 

controller address. (Please refer to Table 3.2.2 

Property Description of General Buttons.) 

When BIT 0 is turned ON (OFF to ON), a sample will 

be taken and place on the HMi X-Y Distribution 

Element. Each consecutive time a sample is taken a 

new point will be placed on the chart. 

When BIT 1 is turned ON (OFF to ON), the HMi will 

clear the X-Y Distribution Element. 

These bits must be reset (ON to OFF) before 

another sample can be taken, or the graph cleared 

again, unless Auto Clear is enabled. 

Setting 

Auto Clear 

When this option is selected, HMi will reset control 

BIT 0 or BIT 1(ON to OFF) after reading the 

sampling points, or clearing the graph respectively 
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Property Description of X-Y Distribution Elements 

Continuous 

Address 

When this option is selected, the system will regard 

read address X as the starting address and 

designate the next 3 consecutive read addresses 

automatically. This also has the added benefit of 

maximizing communications efficiency.  

For example, when read address X is set to 

1@D301, HMi will take 1@D302 as read address Y, 

1@D303 as color address, 1@D304 as conjunction 

address. 

Read Address X 

The address can be internal memory or the 

controller address. (Please refer to Table 3.2.2 

Property Description of General Buttons.) 

When the data is read, it will designate the X-axis 

for the sample.  

Read Address Y 

The address can be internal memory or the 

controller address. (Please refer to Table 3.2.2 

Property Description of General Buttons.) 

When the data is read, it will designate the Y-axis 

for the sample. 

Color 

Used to determine the color of the sampling points 

(distribution points). It can be an internal memory, 

PLC address or constant. The range is from 

0~65535. 

 
 
 

Property Description of X-Y Distribution Elements 

Conjunction 

Used to determine if a line is drawn between the 

distribution points, after each consecutive sample. 

It can be an internal memory, PLC address or 

constant.  

0: Without a line; 1: With a line 

Setting 

X Min. 

X Max. 

Used to set the minimum and maximum value of 

X-axis. If the read value is more the maximum or 

less than the minimum, the system will display the 

minimum and maximum value still. 
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Property Description of X-Y Distribution Elements 

Y Min. 

Y Max. 

Used to set the minimum and maximum value of 

Y-axis. If the read value is more the maximum or 

less than the minimum, the system will display the 

minimum and maximum value still. 

Grid Line Color 

Horiz. Line 

Number 

Vert. Line 

Number 

Please refer to the figure below. The grid color is set to red and the 

grid numbers in horizontal and vertical direction are both set to 2. 

 
X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.12 Sampling Elements 

 
Fig. 3-8-29 Sampling Elements 

 

3.8.12.1 Historical Trend Graph 

Property Description of Historical Trend Graph Elements 

Property Description of Historical Trend Graph Element 

Border Color 

Background 

Color 

The below element background color is set to black and its border 
color 

 
Curve Field Total 1~8 curves (Pens) can be set and displayed. 

  

Setting 

Buffer ID 

Use this option to choose the history buffer (No.1 ~ 

No.12). The History buffer determines the Read 

Addresses, which will be used for the graph. The user 

can press the History Buffer Setup button or click 

Option > History Setup (Choosing History Setup 

command from menu bar) to set the Read Address.  
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Property Description of Historical Trend Graph Elements 

Data 

Format 

Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

6. Floating 

Please note that if the data format is selected as 

Floating, the Data Length option in the History Setup 

dialog box must be greater than or equal to 2words 

or the following warning message dialog box will 

display on the screen. 

 

Integral 

Digits 

Fractional 

Digits 

Determine the number of integer and fractional digits. 

This is only a display format. For example: If the read 

address contains the value 1234 and the Integer is set 

to 3 and the Fractional is set to 1 then the value will be 

displayed 123.4. The digit number will be a real decimal 

number only when the Floating point data format is 

selected. 

Global 

Range 

When this option is selected, it indicates that the user 

can set the minimum and maximum value for all curves 

in this graph. If this option is not selected, each curve 

will need its own minimum and maximum value.  

Minimum 

Maximum 

Is the minimum and maximum value of the Y-axis. If the 

read value is more the maximum or less than the 

minimum, the system will display the minimum and 

maximum value. 

Time/Date 

Time 

Format 

Available formats are HH:MM:SS, HH:MM. 

Date 

Format 

Available formats are MM/DD/YY, DD/MM/YY, 

DD.MM.YY, YY.MM.DD, YY/MM/DD, MM.DD, and 

MM/DD. 

Setting 

Color Is the color for the Time and Date Display. 
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Property Description of Historical Trend Graph Elements 

Enable 
If this option is selected, the curve is enabled and can be 

set. 

Data No. 

It is used to choose the Reading Word data.  For 

example, if the Data Length option in the History Setup 

dialog box is set to 3 words, the user will have the 

option of 0 ~ 2 allowing the choice of data.  

Please note that if the data format is set to 

“Floating”, and the Data Length option in the History 

Setup dialog box is an odd numbers of words, ensure 

the Data No. is set to an even number. 

Line Size 
Used to the display line width. The range of 1 ~ 8 pixels 

is available. 

Line Color Used to the display line color. 

Setting 

Min. Value 

Max. Value 

Each display line (curve) can have its min. and max. 

values. If there are 8 lines in the history data, there will 

be 8 groups of min. and max. values, unless global 

range is selected. 

Grid Line Color 

Grid Number in 

Horiz. 

Please refer to the figure below. The grid color is set to red and the 

grid number in horizontal direction is set to 3. 

 
X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.12.2 Historical Data Table 

Property Description of Historical Data Table Elements 

Displays history data as numeric data on HMi screen within a data table. The Read 

Address in the History Setup dialog box needs to be set up with a data length of 1 ~ 8 

words.  

Border Color 

Background 

Color 

The below element background color is set to green and its border 

color is set to gray. 

 
Data Field 

Number 

1~8 data fields can be set. 

Setting 

 

Setting Buffer ID 

Use this option to choose the history buffer (No.1 ~ 

No.12). The History buffer determines the Read 

Addresses, which will be used for the table. The user 

can press the History Buffer Setup button or click 

Option > History Setup (Choosing History Setup 

command from menu bar) to set the Read Address. 

Property Description of Historical Data Table Elements 
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Time/Date 

Time 

Format 

Available formats are HH:MM:SS, HH:MM. 

Date 

Format 

Available formats are MM/DD/YY, DD/MM/YY, 

DD.MM.YY, YY.MM.DD, YY/MM/DD, MM.DD, and 

MM/DD. 

Color The color of the time and or date if enabled. 

Date 

Length 

16bits Word or 32bits Double Word 

The following data format are available: 

Data 

Format 

Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

6. Binary 

Double Word 

1. BCD 

2. Signed BCD 

3. Signed Decimal 

4. Unsigned Decimal 

5. Hex 

6. Binary 

7. Floating 

Data No. 

It is used to choose the Reading Word data.  For 

example, if the Data Length option in the History Setup 

dialog box is set to 3 words, the user will have the 

option of 0 ~ 2 allowing the choice of data.  

Please note that if the data format is set to 

“Floating”, and the Data Length option in the History 

Setup dialog box is an odd numbers of words, ensure 

the Data No. is set to an even number. 

Color It is the display color of the data.  

Setting 

Integral 

Digits 

Fractional 

Digits 

Determine the number of integer and fractional digits. 

This is only a display format. For example: If the read 

address contains the value 1234 and the Integer is set 

to 3 and the Fractional is set to 1 then the value will be 

displayed 123.4. The digit number will be a real decimal 

number only when the Floating point data format is 

selected. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

3.8.12.3 Historical Event Table 
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Property Description of Historical Event Table Elements 

Property Description of Historical Event Table Element 

Text 

Text Size 

Font 

Text Color 

The user can enter the text, and set the text size, font and text color 

provided by the Windows® operating system. (Please refer to Table 

3-8-2 Property Description of General Buttons.)  

It will show the input history message of every state. HMi system will 

list all input history messages in the event table. If there is no input 

history message, “?” will display. 

Border Color 

Background 

Color 

The below element background color is set to light yellow and its 

border color is set to black. 

 

Word It can have 256 states. 
Data Length 

LSB It can have 16 states.  

Data Format 

This option can be set only when the data length is selected as Word. 

Allows the user to select one of four formats BCD, Signed Decimal, 

Unsigned Decimal and Hex to define the read address content 

Add/Remove 

State 

Used to set the number of states. There are 255 (1-256) states can 

be set if its Data Length is WORD, 16 states can be set if its Data 

Length is LSB and 2 states can be set if its Data Length is Bit. 

Setting 

 

 
 
 

Property Description of Historical Event Table Elements 

Setting 
Buffer ID 

Use this option to set the number of history buffer for 
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reading the data of Read Address. The user can press 

the History Buffer Setup button or click Option > 

History Setup (Choosing History Setup command 

from menu bar) to set the Read Address. 

Data No. 

It is used to choose the Reading Word data.  For 

example, if the Data Length option in the History Setup 

dialog box is set to 3 words, the user will have the 

option of 0 ~ 2 allowing the choice of data.  

 

Time/Date 

Time Format Available formats are HH:MM:SS, HH:MM. 

Date Format 

Available formats are  MM/DD/YY, DD/MM/YY, 

DD.MM.YY, YY.MM.DD, YY/MM/DD, MM.DD, and 

MM/DD. 

Color The color of the time and or date if enabled. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.13 Alarm Elements 

 

Fig. 3-8-30 Alarm Elements 

3.8.13.1 Alarm History Table 

Property Description of Alarm History Table Elements 

HMi will monitor and read the read address at a fixed Scan time automatically. If the 

monitor bits change to the alarm state, an alarm message will be displayed on the 

Alarm History Table element on the screen. This message will stay until the Clear 

Alarm Buffer is set. 

Background 

Color 

The background color of the following two elements is set to white and 

blackish green respectively. 

 The background color is set to white. 

 The background color is set to blackish green. 

 

Time Format 
Available formats are HH:MM:SS, HH:MM two kinds of 

formats. 

Setting 

Date Format 
Available formats are MM/DD/YY, DD/MM/YY, 

DD.MM.YY, YY.MM.DD, YY/MM/DD, MM.DD, MM/DD. 
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Property Description of Alarm History Table Elements 

If this option is selected, when the alarm occurs, the alarm number 

that is designated in Alarm Setup dialog box will also be shown in 

front of the alarm message. Please refer to the figures below:  

 

Alarm 

Number 

 

Setting 

Color The color of the time and or date if enabled. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.13.2 Active Alarm List 

Property Description of Active Alarm List Elements 

HMi will display only the current alarm messages within the Active Alarm List element. 

Background 

Color 

The background color of the following two elements is set to white and 

yellow respectively.  

 The background color is set to white. 

 The background color is set to yellow. 
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Property Description of Active Alarm List Elements 

 
Time Format Available formats are HH:MM:SS, HH:MM . 

Date Format 
Available formats are MM/DD/YY, DD/MM/YY, 

DD.MM.YY, YY.MM.DD, YY/MM/DD, MM.DD, MM/DD. 

Alarm 

Number 

If this option is selected, when the alarm occurs, the 

alarm number for the alarm message will always be 

shown ahead. Please refer to the figures below: 

  

Setting 

Color The color of the time and or date if enabled. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.13.3 Alarm Frequency Table 

Property Description of Alarm Frequency Table Elements 

HMi will count the number of times (Frequency) any alarm has been activated. The number 

as well as the alarm message will be displayed in the Alarm Frequency Table Element. 

Background 

Color 

The background color of the following two elements is set to white and yellow 

respectively. 

  The background color is set to white. 

 The background color is set to yellow. 

 

Time 

Format 

Available formats are HH:MM:SS, HH:MM two kinds of formats. 

Date 

Format 

Available formats are MM/DD/YY, DD/MM/YY and DD.MM.YY. 

Alarm 

Number 

The alarm occurred will also be shown in front of the alarm message. 

 

Display 

for 

Counting 

Zero 

Use this option to decide to show the Alarm messages when the count 

is zero for that alarm. 

Setting 

Color The color of the time and or date if enabled. 

Property Description of Alarm Frequency Table Elements 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 

3.8.13.4 Alarm Moving Sign 
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Property Description of Alarm Moving Sign Elements 

HMi will monitor and read the read address at a fixed Scan time automatically. If the 

monitor bits change to the alarm state, an alarm message will be displayed on the screen 

via Alarm Moving Sign element. 

Border 

Color 

Background 

Color 

The background color of the element below is set to blue green and its 

border color is set to red. 

 

Standard Raised Sunken Transparent 

Style 

    

Moving 

Points 

It is used to set the movement of the moving sign. The unit is Pixel with a 

range of 1 ~ 50. 

Interval(ms) 
It is used to set the interval time between movements. The unit is ms with a 

range of 50 ~ 3000 ms. 

 

Time Format Available formats are HH:MM:SS, HH:MM. 

Setting 

Date Format 
Available formats are MM/DD/YY, DD/MM/YY and 

DD.MM.YY. 

 
 
 
 
 

Property Description of Alarm Moving Sign Elements 

Alarm 

Number 

If this option is selected, when the alarm occurs, the alarm number that is 

designated in Alarm Setup dialog box will also be shown in front of the 

alarm message. Please refer to the figures below: 

 

Setting 

Color The color of the time and or date if enabled. 

X Used to set X coordinate 
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Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.14 Keypad Elements 

 
Fig. 3-8-31 Keypad Elements 

 

Property Description of Keypad (1) / (2) / (3) Elements 

The user can select decimal, hexadecimal or character keypad according to application 

requirement. 

                  

        Keypad (1) Decimal Keypad            Keypad (2) Hexadecimal Keypad  

 

Keypad (3) Character Keypad 

The user can redefine the display text of each button shown on the keypad. including 

<ESC> (Escape),  <ENT> (Enter), <CLR> (Clear), <DEL> (Delete) and <ASCII> (Input 

Character) Please refer to the following figure below: 

 

 
Property Description of Keypad (1) / (2) / (3) Elements 

When the “Text” option is inputted as number “1”, the display text on the button will be 
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Property Description of Keypad (1) / (2) / (3) Elements 

“1”. If the user refines it as number “2”, the display text will be changed to “2”. If it is 

refined as character “A”, the display text will be changed to “A”. If it is changed to 

character “%“, the display text will be changed to “%” and so on. 

 

The keypad is displayed in a “Group” on the screen. The user can use “Ungroup” 

command from “Edit” menu bar to ungroup all the buttons. Then, the user can move 

and change the button size freely. At this time, the user can redefine the display text 

shown on the button in the property table.  

 

The keypad element is used with the Numeric / Character Entry elements. To use these 

keypads the elements Input Mode must be set as “Active Non-Popup” or “Touch 

Non-Popup” and in conjunction with the InterLock Address. Please refer to section 

3.8.8.1 and 3.8.8.2 for the property description of Numeric / Character Entry 

elements.  

“Active Non-Popup” will blink if the interlock is true letting the operator know that and 

entry must be made. 

“Touch Non-Popup” will blink once an operator has touched the input element. This 

allows the operator to know what input is active for use with the keypad. 

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided 

by Windows® to determine the text display on the element. 

The user can set the text, text size, font and text color that 

provided by Windows® to determine the text display on the 

element. When the user press  button next to Font, the 

following Font Detail Setting dialog box will display.  

 

In Font Detail Setting dialog box, the user can select Font Name, 

Font Size and Ratio of the text and view the text format from the 

Preview window in advance. If the multi-language function is 

used, the user can see different language tabs and edit different 

language font setting in Font Detail Setting dialog box. Please 

refer to the example figure above. 
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Property Description of Keypad (1) / (2) / (3) Elements 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Foreground Color 

Style 

There are Standard and Raised these two options. 

 
(When the style is selected as Standard and the foreground color 

is set to green.) 

 
(When the style is selected as Raised and the foreground color is 

set to red.) 

The user can redefine the buttons of the keypad. 

 

Setting 

Display: Display text or character 

Mode: 

The are following modes provided:: 

1. <ESC> Escape/Cancel (If the keypad is put on the sub 

window, this key can be used to close the sub window. 

2. <ENT>  Enter 

3. <CLR>  Clear 

4. <DEL>  Delete 

5. <ASCII> Character 
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3.8.15 Drawing Elements 

 
Fig. 3-8-32 Drawing Elements 

3.8.15.1 Line 

Property Description of Line Drawing Elements 

After selecting the Line Element, Left-click the mouse to draw and edit the line graphic 

element. Then, release the mouse to finish.. When selecting this line graphic element, 

the user can see a rectangle range for the line. This is designed for the user to move 

and adjust the line more quickly and conveniently. The user can set line color, size and 

style in property table freely. The range out of the line graphic element itself will be 

displayed in transparent color. 

           

 Line Direction            Line Size (from 1 to 8) 

Curve Color The display color of the line element. 

Line Size The range is 1 ~ 8 Pixels. 

Line Style 

There are following line styles can be selected. 

 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.15.2 Rectangle 

Property Description of Rectangle Drawing Element 

After selecting the Rectangle Element, Left-click the mouse to draw and edit the 

rectangle graphic element. Then, release the mouse to finish. The user can import the 

picture into the rectangle from picture bank and set rectangle color, size and style in 

property table. 

Curve Color The display color of the rectangle element. 

Bank (Picture Bank) 

Picture Name 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Transparent Effect 

Transparent Color 

(Please refer to Table 3-8-2 Property Description of General 

Buttons.) 

Foreground Color The display color of the rectangle graphic element. 

Line Size The range is 1 ~ 8 Pixels. 

Transparent 

When this option is selected, the element will display only with 

the border and no color in the element. The Foreground Color 

option will be disabled also. 

Round Radius 

0~38 pixels round radius are provided for selection.  

 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.15.3 Circle 

Property Description of Circle Drawing Element 

After selecting the Circle Element, Left-click the mouse to draw and edit the Circle 

graphic element. Then, release the mouse to finish. When selecting this circle graphic 

element, the user can see a rectangle range and this is designed for the user to move 

and adjust the circle more quickly and conveniently. Changing the size of the 

rectangle range will change the size of circle graphic element directly.  

  Multiple ellipses that have the “Transparent” setting set to 
“No” 

 

  Multiple circles that have the “Transparent” setting set to 
“No”. 

 

  Multiple circles that have the “Transparent” setting set to 
“Yes”. 

 
 

  Multiple ellipses that have the “Transparent” setting set to 
“Yes”. 

 

Curve Color Sets the line color of the circle graphic element.  

Foreground Color Sets the display color of the circle graphic element. 

Line Size The range is 1 ~ 8 Pixels. 
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Property Description of Circle Drawing Element 

Transparent 

When this option is selected, the element will display only with 

the border and no color in the element. The Foreground Color 

option will be disabled also. 
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3.8.15.4 Polygon 

Property Description of Polygon Drawing Element 

After selecting the Polygon Element, Left-click the mouse to mark each node of the 

polygon graphic element. Then, right-click the mouse to finish. When selecting this 

polygon graphic element, the user can see a rectangle range and this is designed for 

the user to move and adjust the polygon more quickly and conveniently. Changing the 

size of the rectangle range is changing the size of Polygon graphic element directly.  

Curve Color Sets the line color of the polygon graphic element. 

Foreground Color 

Sets the display color of the polygon graphic element. Please 

refer to the figures below: 

   The foreground color is set to blue. 

   The foreground color is set to turquoise. 

Line Size The unit is Pixel with a range of 1 ~ 8. 

Transparent 

When this option is selected, the element will display only with 

the border and no color in the element. The Foreground Color 

option will be disabled also. Please refer to the figures below: 

 A polygon that has the “Transparent” setting 
in the property table is set to “No”. 

 A polygon that has the “Transparent” setting 
in the property table is set to “Yes”. 

 

3.8.15.5  Arc 

Property Description of Arc Drawing Element 

After selecting the Arc Element Left-click the mouse to draw and edit the arc graphic 

element. Then, release the mouse to finish the arc. When selecting this arc graphic 

element, the user can see a rectangle range and this is designed for the user to move 

and adjust the arc more quickly and conveniently. Changing the size of the rectangle 

range is changing the size of arc graphic element directly.  
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Property Description of Arc Drawing Element 

               

When “Transparent” is set to “No”          When “Transparent” is set to “Yes”. 

Curve Color Set the line color of the arc graphic element.  

Foreground Color Set the display color of the arc graphic element. 

Line Size The range is 1 ~ 8 Pixels. 

Transparent 

When this option is selected, the element will display only with 

the border and no color in the element. The Foreground Color 

option will be disabled also. 
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3.8.15.6 Text 

Property Description of Text Drawing Element 

This text graphic element is used to create a text frame, which text can be added to. 

Left-click the mouse to draw and edit the Text element, release the mouse to finish. 

Then, add and edit the text in the text frame.  

Text 

Text Size 

Font 

Text Color 

The user can set the text, text size, font and text color provided 

by Windows® to determine the text display on the element. 

The user can set the text, text size, font and text color that 

provided by Windows® to determine the text display on the 

element. When the user press  button next to Font, the 

following Font Detail Setting dialog box will display.  

 

In Font Detail Setting dialog box, the user can select Font Name, 

Font Size and Ratio of the text and view the text format from the 

Preview window in advance. If the multi-language function is 

used, the user can see different language tabs and edit different 

language font setting in Font Detail Setting dialog box. Please 

refer to the example figure above. 

Foreground Color 

It is used to set the text frame color. Please refer to the figure 

below. The foreground color of this text graphic element is set to 

blue. 

 

Transparent 

When this option is selected, the element will display only with 

the border and no color in the element. The Foreground Color 

option will be disabled also. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.8.15.7  Scale 

Property Description of Scale Drawing Element 

The user can change the scale direction, main and sub scale number, and grid color in 

the property table to create a special and unique scale graphic element. The “Display 

Mark” option can be used to determine if the scale value display next to the scale or 

not. The minimum and maximum of the scale value can be set in “Detail Setup” option. 

Text Size 

Text Color 

The user can set the text size (8~64) and text color that available to 

the HMi. 

Standard Rotation 90 Rotation 180 Rotation 270 

Style 

    

Main Scale 

Please refer to the figures below:： 

   When main scale number is set to 2 

 

   When main scale number is set to 3 

 

Setting 

Date Length 16bits Word or 32bits Double Word 
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Property Description of Scale Drawing Element 

Data Format 

The following data format are available: 

Word/Double Word 

1. BCD 

2. Signed Decimal 

3. Unsigned Decimal 

Minimum 

Maximum 

The user can set the minimum and maximum of input 

setting value to determine the range of input setting 

value.  
Setting 

Integral 

Digits 

Fractional 

Digits 

 

Determine the number of integer and fractional digits. 

This is only a display format. For example: If the read 

address contains the value 1234 and the Integer is set 

to 3 and the Fractional is set to 1 then the value will be 

displayed 123.4. The digit number will be a real 

decimal number only when the Floating point data 

format is selected. 

SubScale 

Number 

When the main scale number is set to 3 and the subscale number is 

also used, the scale graphic element will display as the figures below: 

   When subscale number is set to 1 

   When main scale number is set to 2 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 

 



HMi Chapter 3 Creating and Editing Screens 

   3-203 

3.8.15.8  Table 

Property Description of Table Drawing Element 

The user can change the cell numbers of the table, appearance and color in the 

property table to create a special and unique table graphic element.  

Background 

Color 

Sets the display color of the table scale element.  

 

Row Header 

The user can enable or disable the color of the first 

row of the table by checking the check box next to 

“Row Header”. 

Column Header 

The user can enable or disable the color of the first 

column of the table by checking the check box 

next to “Column Header”. 

Rows 

The user can enable or disable the color of the first 

column of the table by checking the check box 

next to “Rows”. 

Columns 

The user can enable or disable the color of the 

interlacing rows of the table by checking the check 

box next to “Rows”. 

Setting 

Row Header 

The user can enable or disable the color of the 

interlacing rows of the table by checking the check 

box next to “Row Header”. 

 
 
 

Property Description of Table Drawing Element 

Setting 
Columns Header 

The user can enable or disable the color of the 
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Property Description of Table Drawing Element 

interlacing rows of the table by checking the check 

box next to “Columns Header”. 

Sep. Rows Evenly It is used to distribute rows of the table evenly. 

Sep. Col Evenly It is used to distribute columns of the table evenly. 

Border Color Sets the border color of the table.  

Grid Line Color Sets the grid color of the table.  

Number of 

Rows 
The range is 1 ~ 99. 

Number of 

Columns 
The range is 1 ~ 99. 

X Used to set X coordinate 

Y Used to set Y coordinate 

Width Used to set the element width 

Height Used to set the element height 
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3.9 Menu Bar and Toolbar (Screen) 

 
In Screen options, HMiSoft provides some screen editing functions. 

3.9.1 New Screen 

The user can choose Screen > New Screen or click the New Screen icon , or press Shift + 

N to open a new editing screen. The new screen can be named and numbered by the user. 

The setting dialog box is shown as Fig. 3-9-1.  

 
Fig. 3-9-1 New Screen dialog box 

 

3.9.2 Open Screen 

The user can choose Screen > Open Screen or click the Open Screen icon , or press Shift 

+ O. When choosing open screen, the user can preview each screen in Open Screen dialog 

box (Fig. 3-9-2).  
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Fig. 3-9-2 Open Screen dialog box 

 

3.9.3 Screen Management 

When Screen Management function is enabled (Fig. 3-9-3), the user can duplicate, cut and 

paste the screen using the mouse. In Screen Management dialog box, the user can right 

click the mouse to manage all of the screens (Fig. 3-9-4). Please note that the user cannot 

undo the action of cutting a screen. (Fig. 3-9-5).  

To enable the screen saver Right-click the mouse and select the Edit Save Screen function, 

then drag the screen to be used as the screen saver to the bottom of the window. (Fig. 3-9-6). 

To set the parameters of screen saver, please click Options > Configuration > Other. 
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Fig. 3-9-3 Screen Management dialog box 

 

Fig. 3-9-4 Right-click the mouse 
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Fig. 3-9-5 Warning message after screen is cut 

 

Fig. 3-9-6 Drag the screen to determine the screen saver display 

 

3.9.4 Cut Screen 

Cut screen to clipboard, the user can execute this function by choosing Screen > Cut Screen, 

or pressing Shift + T. 

Please note that the user cannot undo the action of cut screen, however the screen can 

still be pasted back into the project. (Fig.3-9-7). 

 
Fig. 3-9-7 Cut Screen message 

3.9.5 Copy Screen 
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The user can execute this function by clicking Screen > Copy Screen or use keyboard 

shortcuts by pressing Shift + C. 
 

3.9.6 Paste Screen 

The user can paste a screen by clicking Screen > Paste Screen or pressing Shift + P. The 

screen settings are the same as the original screen, except for the new screen name that the  

Screen Editor gives the screen automatically. 
 

3.9.7 Delete Screen 

The user can delete a screen by clicking Screen > Delete Screen or pressing Shift + D.  

Please note that it is not possible to undo the delete operation. After selecting the 

Delete command, the user will see the dialog box below.  

 

Fig. 3-9-8 Delete Screen Message 

 

3.9.8 Export 

Export a screen to a BMP formatted file. The user can execute this function by clicking Screen 

> Export or clicking the Export icon  , or pressing Shift + E.  
 

3.9.9 Import 

This command imports a picture to be the background of the screen. The file types of 

imported pictures can be BMP, JPG and GIF, etc. The user can execute this function by clicking 

Screen > Import or pressing Shift + I. 

 

3.9.10 Clear Import Data 

This command clears the imported picture or background of the screen. Execute this 

function by clicking Screen > Clear Import Data.  

 

3.9.11 Screen Open Macro 

When Screen Open Macro function is selected, the Macro will be executed automatically 
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once the screen opens. The user also can click the Screen Open Macro, Screen Close Macro 

and Screen Cycle Macro options from the Property Table of the screen. (Fig. 3-9-9). For 

details on how to use and edit macro commands, refer to section 3.1.14.  

 

Fig. 3-9-9 Screen Open Macro dialog box 

 

3.9.12 Screen Close Macro 

When Screen Close Macro function is selected, the Macro will be executed automatically 

once the screen is closed. For details on how to use and edit macro commands, refer to 

section 3.1.14. 

The user also can click the Screen Open Macro, Screen Close Macro and Screen Cycle 

Macro options from the Property Table to enter intro Screen Open Marco editing environment 

(Fig. 3-9-9).  

 

3.9.13 Screen Cycle Macro 

When Screen Cycle Macro function is selected, the Macro will execute continuously while the 

screen is displayed. For details on how to use and edit macro commands, refer to section 

3.1.14. 

The user also can click the Screen Open Macro, Screen Close Macro and Screen Cycle 

Macro options from the Property Table to enter intro Screen Open Marco editing environment 
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(Fig. 3-9-9).  

 

3.9.14 Screen Properties 

This function sets the properties of the current screen. The user can view and choose the 

properties of the current screen by selecting Screen > Screen Properties or choosing Screen 

Properties from docking windows (Fig. 3-9-10, 3-9-11）. 

 

Fig. 3-9-10 Choosing Screen Properties 
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Fig. 3-9-11 Screen Properties dialog box 

Function Description 

Screen Number 
The range is between 1 and 65535. Each screen number must 

be unique.  

Screen 

Application 

General View 

Screen 

Regarded as general view screen.  
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Function Description 

Apply Print 

Screen 

1. The printer can print the scream created by the user after a 

compile operation. This option is only available in HMi 

series which supports printer function.  

2. When Apply Print Screen function is selected, the editing 

range will be scaled to the actual paper size of the printer. 

The user can only print the elements within the range of 

the paper size. This option is usually used for print 

typesetting (print layout management function).  

For the setting of print function, please click Options > 

Configuration > Printer Setup.  

 

Sub-screen 
Sub-screen 

setting 

The check box next to “This screen is a sub-screen” can be 

checked only when General View Screen option is selected. 

This allows the screen to serve as a popup screen within the 

project. 
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Function Description 

Screen Width Set the width of sub-screen in Pixels. 

Screen Height Set the height of sub-screen in Pixels. 

Sub-screen 

Position 

This option can show the sub-screen on the center of the HMi 
screen or on a position specified. 
To specify the position: 

• input the coordinate value directly (X and Y axis) or 

• press the  icon to drag the sub-screen.  

 

Sub-screen 

Title Bar The user can select this option to display the title bar on the 

screen. 

Cycle Macro Delay Time 
Sets Macro Cycle Delay time any time this screen is open. The 

range of the macro cycle delay time is between 100ms to 5s.  

Fast Refresh Rate 

If this option is selected, the element can be displayed 

immediately when switching the screen. Please note that this 

function is designed to provide fast value refresh speed for the 

element which performs communication frequently. Therefore, 

only 4 elements (including display element and input element) 

can be fast refreshed on one screen. If the user uses this 

function on too many elements, it may affect the normal speed 

of HMi operation. So, we recommend using this option 

sparingly.  
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Function Description 

Setting 

The user can find this function only on HMi models which 

supports printer function. If the user wants to enable this 

function, setting the printer in advance is necessary. Please go 

to Option > Configuration > Printer Setup and select the 

printer first. When this function is enabled, if one report list 

button is created and its assigned output device is a printer, 

when the user presses the report list button, the HMi will refer 

to the setting in Hard Copy Region option and execute the 

screen-printing.  

Top-Left 

Hard Copy 

Region 

Right-Bottom 

Set the region, in pixels, of HMi printing area (also called Hard 

Copy Region).  

Need Base 

Screen 
Setting 

Every screen can specify any one of the other screens as a base 

screen. When the check box next to Need Base Screen is 

checked, the base screen will be moved to the back (behind all 

other elements) as a background picture. HMi will execute all of 

the elements on the base screen correctly when in run mode.  
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3.10 Menu Bar and Toolbar (Tools) 

 

 

3.10.1 Compile 

A compile is necessary to produce a runtime project. During compiling, all of the component 

compiling messages, including any errors, will be written to output field. If no error during 

the compiling process, a runtime project file will be produced.  

To compile the project, select Tools > Compile or click icon  directly or press Ctrl + F7. If 
this project is a new project, it will remind the user of saving before compiling. If this project 

has been saved or it is an old project, it will compile directly without prompt. After compile 

operation is finished, HMiSoft will save the file again automatically. 

 

Debug Compiling Error during Compiling Process 

1. Create a new project. 

2. Create a button element and a numeric entry element on HMI screen and do not 

change the elements default property as the figure below. 
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3. Press the  icon to execute compile operation. An error message dialog box will 
pop up to warn the user of any compiling errors. In the following figure, we can see 

that two errors occurred and are displayed in the output window.  
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4. The user can click the error message and HMiSoft will switch to the element window 

with the error automatically.  

 

3.10.2 Download Screen & Recipe 

The user can download screen data and recipe to HMI by clicking Tools > Download Screen 

& Recipe or clicking  icon directly or pressing Ctrl + F8.  

If PC cannot connect to HMI, the error messages will be displayed (Fig. 3-10-1, Fig. 3-10-2, Fig. 

3-10-3 and Fig. 3-10-4). The user can choose download interface by using the following 

methods: 

1. Clicking Options > Configuration or  

2. Clicking Options > Environment. The download interface can be USB or RS-232.  

 

Fig. 3-10-1 Start download  

     

Fig. 3-10-2 USB open error message is a Software or Operating system issue. To fix try the 
following 3 remedies: 
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1. Close and reopen HMiSoft 

2. Uninstall and Reinstall USB driver from Options >Environment 

 

3. Reboot the PC 

 

Fig. 3-10-3 USB disconnect error message is a hardware issue. To fix try the following 
remedies 

1. Verify the HMi has power and the USB cable it plugged into both the HMi and the PC 

2. Cycle power to HMi  

3. Go to the System menu and change the USB comm. mode (Please refer to chapter 
five for more detail) 

 

Fig. 3-10-4 Incorrect model name error message is a project error. The project has been 
compiled for the wrong unit. Go to Options > Configuration > General tab and select the 

correct unit from the HMI Type. 

 

3.10.3 Upload Screen & Recipe 

After clicking File > Upload Screen & Recipe, the password dialog box will show up first (Fig. 

3-10-5), the user needs to input password (the password is the highest priority saved in HMI, 
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which is set by clicking Options > Configuration > General > Security). When entering the 

correct password, the user can get save as dialog box (Fig. 3-10-6). After inputting project file 

name, the uploading will start (Fig. 3-10-7). When progress bar reaches100%, the uploading 

is complete. The user can press Stop button to exit the dialog box. If the user wants to upload 

with the projects pictures also, they can do so by select the Include Picture Data when 

uploading in Environment dialog box by clicking Options > Environment. 

 

Fig. 3-10-5 Password dialog box 

 

Fig. 3-10-6 Save as dialog box 
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Fig. 3-10-7 Upload screen and recipe data 
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Fig. 3-10-8 Environment dialog box 

 

3.10.4 Download Screen 

To download project to HMI, select Tools > Download Screen or click icon directly or 
press Ctrl + F9. The download Screen process will not download recipe data. To download 

recipe data choose Download Screen & Recipe or Download Recipe.  

 

3.10.5 Upload Recipe 

To upload the recipe data only, select Tools > Upload Recipe. Then, the password dialog box 

is displayed. The user must enter a password to access the HMI (the password is the highest 

priority saved in HMI, which is set by clicking Options > Configuration > General > Security). 

Enter the name of the recipe to start the upload. When the progress reaches 100%, the upload 

is complete.  

 

3.10.6 Download Recipe 
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To download the recipe data only, select Tools > Download Recipe. The file extension name 

of a recipe file is .rcp for 16 bit recipes or .csv for 32 bit recipes (Fig. 3-10-9). 

 
Fig. 3-10-9 Download the designated recipe data 

 

3.10.7 On Line Simulation 

This command simulates the running HMi project on a computer, communicating with a 

controller through the PC’s communication ports. Therefore, the user cannot execute the 

function of On Line Simulation without connecting a controller. On Line Simulation function 

can be execute by clicking Tools > On Line Simulation or clicking icon  directly or 
pressing Ctrl + F4. Before executing On Line Simulation, the system will ask the user to select 

the communication port for connecting to controller first (Fig. 3-10-10). For On Line 

Simulation Screen, the user can refer to Fig. 3-10-11.  

 
Fig. 3-10-10 COM Settings 
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Fig, 3-10-11 On Line / Off Line Simulation Screen 

 

3.10.8 Off Line Simulation 

To test the screen functionality like the read/write addresses, macro command, and page 

changes to see if they are correct, the user can run an off-line simulation. To enable the off 

line simulation, select Tools > Off Line Simulation or click  icon directly or press Ctrl + 

F5 (Fig. 3-10-11).  

 

3.10.9 Upgrade Firmware 

This option is for upgrading HMI firmware or adding function for HMI. Ensure that the 

software version of HMiSoft matches the firmware version. The user can get the firmware 

information by clicking Tools > Get Firmware Information (Fig. 3-10-12). The user can find 

the HMiSoft version by clicking Help > Help (Fig. 3-10-13). For an example of upgrading the 

firmware please refer to Fig. 3-10-14. 
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Fig. 3-10-12 Get Firmware Information 

 
Fig. 3-10-13 About HMiSoft 
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Fig. 3-10-14 Upgrade Firmware 

 

3.10.10 Get Firmware Information 

Connects to the HMI over the USB connection or via the communication (COM port) and will 

provide the current firmware version. 

 

Fig. 3-10-15 Get Firmware Information screen 
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3.11 Menu Bar and Toolbar (Options) 

 

3.11.1 Configuration 

To access the configuration options, select Options > Configuration. This dialog box is 

divided into six tabs: General, Control Block, COM Port, Printer Setup, Default and Other. 

These tabs are covered in detail in the following sections. 

General tab in Configuration option 
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General tab in Configuration option 

Project Name Enter the name of the file for the project. 

HMI Type 

Select HMi series HMi type for 

different functions and 

requirements  
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Non-volatile data 

location 

The backup memory data (non-volatile data) can be saved in HMi 

and USB disk. The user can select one of them from the Location 

drop-down list. However, USB disk selection is available in some 

HMI types. The setting of non-volatile data location is shown in the 

figure below. After pressing Setting button, Retained Area dialog 

box will pop up and the user can set the storage location of alarm, 

recipe and history data in this dialog.  

 

Password 

Used to set the highest priority password. There are 8 levels for 

the password. Meanwhile, this password is also the protection 

password for the file (project). Please note that the password 

format is hexadecimal (0 ~ F). 

Starting Level 
Used to set start-up priority. The highest level is 7 and the lowest 

level is 0. 

Insufficient password 

level reminder 

When this check box is checked, if the current security level is not 

equal to or higher then the security level of the element, the 

operator will see  on the display.  

Buzzer ON When this check box is checked, the function of Buzzer is enabled. 

General tab in Configuration option 

Upload/Download 
The user can select USB, PC communication port (i.e. RS-232) or 

Ethernet to upload and download.  

Startup Delay Time 
Use to set delay time to wait for a controller (i.e. PLC). The range is 

between 0 ~ 255 seconds. 

Clock Macro Delay Time 
Use to set interval time when executing clock macro. The range is 

100 – 65535 ms. 

Clock Macro Priority Used to set the priority when executing clock macro. 

Background macro 

update cycle 

Used to set the number of lines executing background macro 

during one cycle. The range is 1~512 lines. 
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Show disk access error 

message 

When this option is selected, if an error occurred when accessing 

the alarm, history, and recipe data via USB disk, an error message 

will pop up on the screen.  

 

Control Block tab in Configuration option 

 
Control Address Use to set the starting address of system control block. 

Length 

The length of control block will be different depending on 

different function. (For example, the length should be at least 8 

Words when using multi-language function.)  

For more detailed information of system control block, refer to 

section 3.4.  

Please note that the when the control block size is set to 0, the 

control block function is disabled.  

Auto Reset Flag 

If the Auto Reset Flag box is checked, the register in the control 

block is cleared to 0 when any operation is finished in the control 

block.  

Status Address 

Use to set the starting address of system status block. The length 

is 8 words. Each word indicates the different status value of HMi 

system. For more detailed information of system status block, 

refer to section 3.4.  
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COM Port tab in Configuration option 

 

Add/ 

Delete/ 

Modify 

Add 

Press the “Add” button to determine the connecting device name and 

the controller. Please refer to the figure below: 

 

Available controller drivers will be different depending on HMi type. 

(HMi series can support up to three different drivers 

simultaneously.) 

Delete 
Delete the existing driver (an application needs at least one driver 

configured). 

Add/ 

Delete/ 

Modify Modify Modify the driver or change the controller name. 

COM Port Set the HMi COM port that communicates with the controller 

PLC 

Station 

Chooses controller station number for the HMi to communicate 

with. The range is between 0 ~ 255. 

Controller 

Settings 

Password 
Passwords are necessary for some controllers for communication to 

be established. 



HMi Chapter 3 Creating and Editing Screens 

   3-231 

COM Port tab in Configuration option 

Comm. 

Delay 

Time 

Sets delay time to wait for the startup of the controller (i.e. PLC). The 

range is between 0 ~ 255 ms.  

Timeout 
Set communication time out time when communicating with the 

controller. The range is between 10 ~ 65535ms. .  

Retry 

Count 

HMi will try to resend a communication command to the controller 

repeatedly if the controller does not respond to request. This option 

is used to set the max number of retries, before displaying a 

communication error dialog box. The range is between 0 ~ 255 

times. 

Optimize 

If optimization function is enabled, all read addresses of all related 

elements will be optimized (using block read and writes when 

possible).  

When Communication Interrupt X times then ignore box is checked, the HMI will stop 

communicating with the PLCs after the communication interrupt times is reached. The 

purpose of this function is to avoid the communication error dialog box always showing on 

the HMi screen when a communication error occurs. The range is between 1 ~ 255 times. 

When the count is reached Bit 0 of control block word one will be set ON. (This bit can be 

used to set communications alarm so the operator knows communications have failed) To 

attempt to reestablish communications between HMi and controllers again, Bit 0 of the 

control block word one must be reset. 

HMi 

Station 

Set HMi station number. The range is between 0 ~ 255. 

Interface 
Set communication interface. There are three options RS232, RS422 

and RS485. 

Data Bits There are two options 7 Bits and 8 Bits. 

Comm. 

Parameter 

Stop Bits There are two options 1 Bits and 2 Bits. 

 
COM Port tab in Configuration option 

Baud Rate 

Communication baud rate. There are 4800, 9600, 19200, 38400, 

57600 and 115200 these options. The users can enter the value 

directly, but the maximum setting can not exceed 187500. 

Comm. 

Parameter 

Parity There are three options: None, Odd and Even. 
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HMI 
 

1. Choose Ethernet and the user can set the Ethernet setting. 

2. If Overwrite IP function is enabled, HMi will update the Ethernet 

setting after the screen data is download. 

3. If Obtain IP address automatically box is checked, HMi will get the 

IP address automatically. But before enabling this function, 

ensure that DHCP server is connected. 

4. If Obtain IP address automatically box is not checked, the user 

must set Ethernet setting, i.e. HMi IP address, Subnet Mask, 

Gateway IP, etc. manually. 

Ethernet 

Setting 

PLC 

 
Click the node under Etherent option and the communication 

parameter setting will display. Each controller, i.e. PLC has its own 

communication parameter setting. 

Printer Setup tab in Configuration option 
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HMi provides two print options; one is Hard Copy function, which can print the current 

screen one page at a time. The other is Print Typesetting function. If Print Typesetting 

function is selected, screen data and all history data can be output to the printer. For more 

description of print setting method, please refer to the introduction of Print Typesetting 

function. 

Printer 
The users can use the drop-down list to specify the printer. The 

printers in the list are sorted by manufacturer. 

Paper 

The users can use the Paper drop-down list to select the paper size. 

The only predefined paper sizes in the list are A4, Letter and 

Custom. 

Standard 

Quality Only 72 DPI option is provided. 

Margin 
The users can determine the blank space (margins). Users can specify the top, 

bottom, left and right margins and the unit is mm. 

Print Size 
When Custom is selected, Print Size option is enabled and the user can 

determine the paper size manually. 

Interface 
The users can specify the communication port of the printer as either COM 

Port or USB. 

Auto Next 

Page 

When the “Auto Next Page” option is selected, the printer will print the next 

page automatically. If the checkbox next to “Auto Next Page” is not checked, 

the printer will print continuously without breaking for different pages. 



Chapter 3 Creating and Editing Screens HMi 

3-234  

Direction 
Direction is used to set printing orientation. There are two options: Vertical 

(Portrait) and Horizontal (Landscape). 

Default tab in Configuration option 

 

Start up Screen 
Set the first display screen when HMi is powered on and 

started up.  

Default Format Sets the default value format when creating elements. 

Default Screen 
When a new screen is created, the users can use this 

option to set the default screen background color. 

System Error 

Display Time 

Sets the display time of system error message dialog 

box. The range is 0 ~ 5 seconds. 

Please note that if the value is set to 0, the system 

error message dialog box will not display on the 

screen.  

System 

Default 

Value 

System Key Use 

Mode 

Set the system key action when the users press the key. 

There are three options: Disable, Check Password and 

Unchecked Password.  

Element Font Size 
Specify the default element font size when creating an 

element. 

Element 

Default 

Value 
Element Font Name 

Specify the default element font name when creating an 

element. 
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Element Font Color 
Specify the default element font color when creating an 

element. 

 
 
 

Default tab in Configuration option 

Blink Time 
Specify the default element blink rate when creating an 

element. The range is between 0 ~ 5000ms. 
Element 

Default 

Value 
Scroll Size  

 

This option is available for the element that has scroll 

function, e.g. Alarm History Table, etc. There are 20 

pixels, 30 pixels and 40 pixels options. The default 

setting is 20 pixels. 

 

Other tab in Configuration option 

 

Enable touch cursor
When this option is enabled, the HMi mouse function is 

activated. When touching HMi screen, a mouse will 

display on the screen for the operator to use.  

It will display initial 

screen at start 

When this option is enabled, the default startup screen 

will display when HMi is powered on and started up. 
General 
Setting 

Blue Led mode 

This option determines when the blue LED indicator will 

be lit. There are three options: none (not be lit), COM 

(during communication), Access data (when 

accessing data) and Ethernet (communicating via 
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Other tab in Configuration option 

Ethernet). This option is not available on all models 

 
 
 

Other tab in Configuration option 

In Screen Management option (Screen > Screen Management), there is a more 

detailed description for introducing how to drag the mouse to determine the 

screen saver display. 

Enable Screen 
Saver 

This option should be selected when the users want to use 

Edit Save Screen function in Screen Management option. If 

this option is not selected the screen saver will not function. 

1. The users can use this option to enable the screen saver. 

When the value is 0, it indicates that the screen saver 

function is disabled. If the setting value is a non-zero value, 

it indicates that the screen saver is on. When the operator 

touches the screen, the Screen Saver will turn off. 

2. If this option is not selected, the screen saver will be 

enabled automatically when the Screen Saver Time set in 

HMI is reached. If the screen saver is on, the users can touch 

the screen to turn it off. 

Screen 
Saver 

Read Controller 
Address 

  

Screen 
Saver Transition Time 

Set the interval time between two screen savers. 

The range is between 1 – 255 seconds. 
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Other tab in Configuration option 

After screen saver 

program ends 

1. Return to Original: Return to the original screen at that 

time when the screen saver is enabled 

2. Choose screen: Specify the screen after the screen saver 

program ends. 

Insert 

Press the Insert button to add a language option. 

 
As shown as the figure above, the users have to enter the 

language name and setting value. The setting value will be 

referred by the system when setting multi-language. The 

range of the setting value is between 0 ~ 255. The user can 

press  button to change the flag color on the language 

name tab. 

Enable/Disable 

The HMi allows the user to edit multi-language screen. The 

user can use this option to determine which languages are 

supported (enabled) or not supported (disabled) when 

downloading data to HMi. 

Delete 
Delete the existing language. HMi requires at least one 

language for one project. 

Modify Modify the existing language name and setting value. 

Default Sets to the default language setting.  

Multi- 
Language 

Enable Edit 

Multi-Language 

User Interface 

Use this option to enable multi-language user interface. The 

user can view the multi-language display in the property 

table. The editing interface is displayed in the figure below: 
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3.11.2 Alarm Setup 

The user can set alarm by clicking Options > Alarm Setup. The alarm setup works with the 

alarm elements (Alarms History Table, Active Alarm List, Alarm Frequency Table, and Alarm 

moving sign). Once the alarm table has been completed, for example like in this dialog box 

(Fig. 3-11-1), the alarm messages will be ready for use. 

 

Fig. 3-11-1 Alarm Setup dialog box 

 
Alarm Setup Dialog Box 

Address 

Use this option to set the alarm starting address. It provides 

512 alarms, 32 Words. Please note that the unit of this 

address is Word. If use and ELC and using register type M or 

S (bits instead of words), the address must be 0 a multiple 

of 16, i.e. M0 and M16. If the address is M1, system will 

determine it is an invalid address.  

Alarm Setting 

Scan Time 

(second) 

Sets how long it takes for the HMi to scan the alarm 

registers. The unit is seconds. 



HMi Chapter 3 Creating and Editing Screens 

   3-239 

Alarm Setup Dialog Box 

Max. Records 

Use this option to retain a specific number of records. 

(Alarms stored) This record is setup for FIFO (First In First 

Out) In this case when the 101st alarm happens the record 

for Alarm 1 will be erased. 

Hold 

(Non-volatile) 

Using this option saves alarms in SRAM when the power is 

turned off. The capacity for saving alarm data of 4Kbytes. 

The battery of the SRAM provides power when the power is 

turned off. (In some HMi models, the user can save data in 

USB disk or CF card.)  

CSV Format Using this option saves data in CSV format.  

Alarm Setting 

Alarm Property 

Setup 

The user can double click a row of the alarm message 

contents table to edit the alarm property or highlight the 

row and press the Modify button to change it.  

(Please note that the multi-language function is also 

supported in the alarms) 

  

 
 
 

Alarm Setup Dialog Box 
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Alarm Setup Dialog Box 
After selecting an alarm and clicking modify the following 

dialog box will display. 

 
Message Display message when the alarm occurs. 

Color 
Display message color when the alarm 

occurs. 

Alarm Property 

Setup 

Use this option to determine if the Bit is 

On or Off when an alarm occurs. 

Alarm Property 

Setup 

Goto Screen Display screen when an alarm occurs.  

Delete Delete the alarm message contents. 

Modify 
Modify the alarm message contents. The user also can 

double click the mouse to perform this function. 

Import 

Import the Alarm File into the alarm message contents 

table. This is an easy way to reuse the alarms from another 

project. 

Export 

Export the alarm message contents from HMI and convert 

them to be Alarm Describe File. This is an easy way to reuse 

the alarms from another project. 

Alarm Setting 

OK End the editing of alarm message contents. 
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Alarm Setup Dialog Box 
 

The calculation method of the size of the alarm history file is as follows: 

[ ]{ } BytesdBytescNbBytesaBytes   Size File Actual626 =+×+ )()()()(  
 
a Time and Date Data 

b Alarm Data 

c Sampling Points  

d Data File Symbol 
 
Example: 

If Max. Records is set to 100, and the time and date is recorded, the 

required capacity for saving alarm data is: 

[(6 Bytes + 2 Bytes) × 100] + 6 Bytes= 806 Bytes 

If Max. Records is set to 100, and the time and date is not recorded, the 

required capacity for saving alarm data is: 

(2 Bytes × 100) + 6 Bytes = 206 Bytes 

 

Alarm Setting 

The calculation method of the size of the alarm frequency table is as 

follows: 

BytesbNaBytes  Size File Actual2 =× )()(  
 
a Alarm Frequency Data 

b Alarm Type 
 
Example: 

If there are five alarm types, the required capacity for saving alarm data is: 

2 Bytes × 5 = 10 Bytes 

When Alarm Moving Sign is enabled, if an alarm message is detected by 

HMI, an alarm moving sign will show and run on the HMI. 

Enable Enable the alarm moving sign. 

Position 
Determine the display position of alarm moving sign.  

It can be Top or Bottom. 

Left 
Alarm message will move from right to left 

(Move to left). 

Right 
Alarm message will move from left to right 

(Move to right). 

Up 
Alarm message will move from bottom to top 

(Move to Up). 

Alarm Moving 

Sign 

Direction 

Down 
Alarm message will move from top to bottom 

(Move to Down). 
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Alarm Setup Dialog Box 

Moving Points 
It is used to set the movement of the moving sign. The unit 

is Pixel with a range of 1 ~ 50. 

Interval (ms) 
It is used to set the interval time between movements. The 

unit is ms with a range of 50 ~ 3000 ms. 

Background 

Color 

Sets the background color of the alarm moving sign. 
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3.11.3 History Buffer Setup 

History Buffer Setup Dialog Box 

The History Buffer purpose is to designate the Read Address that history is required for. 
The History Buffer setting allow the user to choose options like, how many addresses to 
read, Cycle (sample rate), number of samples to store, as well as time and date. This 

buffer is used in conjunction with the sampling elements (Historical Trend Graph, 
Historical Data Table, and Historical Event Table) in order to display Historical data on 

the HMi 
 

 

Add 

Pressing the Add button will add history data buffer. A maximum of 12 history 

data buffers can be added. After an internal memory address is entered, the 

following Buffer Properties dialog box is displayed.  

  

Read Address Sets the starting address for sampling the history data. 
Buffer 

Properties 
Data Length 

(Word) 

Set the length in Words the user wants to sample. The range is 

between 1 ~ 13 continuous words. 
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History Buffer Setup Dialog Box 

Sample Cycle 

(ms) 

Set the sampling cycle time for reading the address (sample 

scan time). If the Trigger option is PLC, this option will be 

unavailable. The range of the sampling cycle time is 0 – 

86400000 ms. 

Sample 

Number 

This option is used with the Auto Stop option. If the Auto Stop 

option is selected, HMi stops recording the data after the 

numbers of records have reached the value of Sample Number. 

If the Auto Stop option is not selected, when the number of 

records of data exceeds the value of Sample Number option; it 

will delete the oldest record and insert the new record (FIFO).  

For example, if the setting value is set to 100 and the number of 

records in history exceeds 100, the oldest record will be deleted 

and the second oldest record will become the oldest record, the 

third oldest record will become the second oldest record…and 

the 100th record will become the 99th record. Therefore, the 

new record (101st record) will become the 100th record.  

The record data will be name as “History.dat” and the user can 

use the software, to open this file. FlashTransfer will sort and 

list the history data by recorded time automatically.   

Stamp Time 

and Date 

When this option is enabled, the time and date are also recorded 

during sampling operation. 

Auto Stop 
When this option is enabled, HMi stops recording when the 

maximum number of recorded data is reached.  

Buffer 

Properties 

Retained 

(Non-Volatile) 

Using this option enables HMi to save sampling data in SRAM. 

The capacity for saving history data on the HMi is 240 Kbytes. 

The battery of the SRAM provides power when the power is 

turned off. (In some HMi series models, the user can save data 

in USB disk or CF.) In addition, the file name can also be 

user-defined. 

 
 
 
 
 
 

History Buffer Setup Dialog Box 
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History Buffer Setup Dialog Box 

Retained 

(Non-Volatile) 

 

Buffer 

Properties 

Export CSV File 

The data can be exported to Windows Excel CSV files. The 

system allows the user to read a max 65536 rows and 256 

columns of data in the Windows Excel environment. If the 

sample number of the sampling data exceeds 65536, when the 

user opens Windows Excel CSV file, an error message will 

display.  

 
This option is used with the Auto Stop option. If the Auto Stop 

option is selected, HMi stops recording the data after the 

numbers of records have reached the value of Sample Number 

option. If the Auto Stop option is not selected, when recorded 

data exceeds the value of Sample Number option; it will delete 

the first record and insert the new record into the last address. 

Then, the exported Windows Excel CSV may need to be sorted 

by the user in order to see the sampled data by time. 
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History Buffer Setup Dialog Box 

Export CSV File 

The column name, i.e. Time, Date, Value 1 ~13 can be 

user-defined. Please refer to the following figure:  

 

Trigger 

There are two options: Timer and PLC. The sampling action is 

controlled by the Timer of the HMi or the external controller, i.e. 

PLC. When PLC option is selected, it indicates that the trigger bit 

for sampling is designated by the forth word in the Control 

Block. Please refer to section 3.4. For more on the Control Block. 

Buffer 

Properties 

OK / Cancel 
Press OK button to save the data and exit. Press Cancel to exit 

without saving data. 

Delete Press Delete button to delete the history data. 

Modify Press Modify button to modify the history data. 

History 

Buffer 

Setup 

The calculation method of the size of the history data file is as follows: 

1. dat file 

Each history data will be saved as Hxxxx.dat. xxxx indicates that it is the xxxxth 

history data. 

[ ]{ }
MBytescNbBytesaBytes

 Size File Actual 
10241024

26
=

×
×+ )()()(  

 

a Time and Date Data 

b History Data Length 

c Sampling Points 
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History Buffer Setup Dialog Box 

History 

Buffer 

Setup 

  
Extra history data will occupy the data file symbol. 
 
[ ]{ } BytesbNaBytes  Size File Actual8 =× )()(  

 

a Data File Symbol 

b Sampling Points 

 
Example:  

Suppose that the user adds two history data buffers. The data length of the first 

history data is set to 1 and the sample number of the first history data is set to 

10000. The data length of the second history data is set to 2 and the sample 

number of the second history data is set to 20000. Both buffers are recording 

time and date, so the required dat file capacity for these two history data are:  

The file capacity of the first history data = [(6Bytes + 2Bytes) × 10000] = 

80000Bytes. 

The file capacity of the second history data = [(6Bytes + 2 × 2Bytes) × 20000] = 

200000Bytes. 

The capacity of Data File Symbol = 8Bytes × 2 = 16 Bytes 

Total require: 80000Bytes + 200000Bytes + 16Bytes = 280016Bytes = Approx. 

0.268Mbytes. 
 
2. csv file 

MBytesBytesaN
 Size File Actual 

10241024

240
=

×
×)(

 

 

a Sampling Points 

 
Example:  

Suppose that the user adds two history data buffers. The data length of the fist 

history data is set to 1 and the sample number of the first history data is set to 

10000. The data length of the second history data is set to 2 and the sample 

number of the second history data is set to 20000. Both buffers are recording 

time and date, so the required csv file capacity for these two history data are:  

The file capacity of the first history data = 10000 × 240Bytes = 2400000Bytes. 

The file capacity of the second history data = 20000 × 240Bytes = 

4800000Bytes. 

Total require: 2400000Bytes + 4800000Bytes = 7200000Bytes = Approx. 

6.8Mbytes. 

3.11.4 Password Setting 

This function sets the password table and determines the security access level that can 
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change user’s passwords. There are 1 ~ 7 password security levels: 

Level 0: No security. No protection. Everyone can use this element. 

Level 1: Low security level. The user whose security level is equal to and higher than Level 1 

can use this element.  

Level 4: Medium security level. The user whose security level is equal to and higher than Level 

4 can use this element. 

Level 7: High security level. The user whose security level is equal to and higher than Level 7 

can use this element. 

The user’s highest security level, i.e. the password protection for the file (project) can not be 

set here. To set the highest priority password, click Options > Configuration > General > 

Security option. 

The password setting table can also be defined by using HMi Soft software program. The user 

can create a keypad element to edit and modify the password table. 

 

       
The password can be an 8-digit password that contains 0 ~ F (HEX). 
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3.11.5 Tag Table 

Tag table is used to replace the specific address with the user-defined words or characters. 

For example, if the user wants to replace PLC address 1@Y0 with the word “Run”.  

Tag Table Dialog Box 

 
Open Click  to open a Tag file and import it into HMi. 

Save 
Click  to save the settings and changes made in Tag Table dialog box as Tag 

file. 

Add 

Select the Tag type first, Internal Memory and Base Port (If the user has three or 

more communication ports, the user will see Link2, Link3 …and so on). Then, 

click Add icon  to add and define Tag data. 

Delete 
The user can use the mouse to select one row of the Tag table, and then click 

Delete icon  button to delete it.  

OK Press OK button to save the settings and exit. 
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3.11.6 Print Typesetting 

This function provides more efficient print layout management function. Please refer to the 

descriptions and examples on the following pages. 

  

Print Function 

 Printer setup 

1. HMi series supports the printer function via USB interface. 

2. Select the connected printer.  

The user can click File > New to get into the New Project dialog box and select 

the printer using the Printer drop-down list in New Project dialog box. Or click 

Options > Configuration > Printer Setup to select a printer.  

 

3. Printer Setup Configuration 

Select Options > Configuration > Printer Setup to open the Printer Setup tab. 

Use Printer Setup tab to configure the settings of printer, paper, quality and 

margin, etc. 
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Print Typesetting Function 

The user can print many pages at a time and arrange the layout of the print screen by using 

Print Typesetting function. The history data also can be printed at the same time. Please pay 

particular attention to the following notes when using Print Typesetting function. 

1. Print typesetting screen cannot be designated to print typesetting screen and be 

displayed on the HMi screen. 

2. Print typesetting screen cannot be the default HMi screen. 

3. Print typesetting screen cannot be the base screen. 

4. Print typesetting screen cannot be the screen saver. 

5. Print typesetting screen cannot be the sub-screen.  
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 Create a Printed Report 

Step 1. Create a new screen by selecting Screen > New Screen and set Apply Print 

Screen in Screen Properties tab (Screen > Screen Properties). Then, click 

Options > Print Typesetting and drag and drop the screens which need to be 

printed. The selected screens will become the print screen automatically. 

    

Step 2. Create the element to print. For example, if the user wants to print a Historical 

Trend Graph and a X-Y Chart, the user needs to create a Historical Trend Graph 

(Element > Sampling > Historical Trend Graph) and a X-Y Chart (Element > 

Curve > X-Y Chart) first and then set their properties in the Property table. The 

Property table provides the element property setting for each element. For 

information about each element property settings, refer to section 3.8. 

 

Step 3. Choose Yes or No using the Print Successive Data drop-down list to 

determine whether the Print Successive Data function is selected or not. When 

Yes is selected, it indicates that Print Successive Data function is enabled, and 

all the sampling records and data for the element will be printed.  
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 Print Screen Layout and Output 

Step 1. Select Options > Print Typesetting. Drag the Screens to decide which screen 

needs to be typeset and printed. The screens on the top are all available 

screens and the screens on the bottom are the selected screens. If a General 

View Screen is dragged to the bottom, it will become Apply Print Screen 

(Screen Properties) automatically.  
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Step 2. Right click the mouse or use the function key to create a Report List button on 

a General View Screen. Use this Report List button to enable the print 

function. 

Step 3. Set the properties of the Report List option. The Report Device can be USB disk 

or Printer. If the user select USB disk, the data will not be printed out, but the 

data will be saved in USB disk. 

 

Step 4. Connect HMI to the printer and press Report List button, and the data will be 

printed out. 

 

 



HMi Chapter 3 Creating and Editing Screens 

   3-255 

Hard Copy Function 

This function is available only when the screen is a General View Screen. If HMI 

detects the Print Typesetting function is already set for the editing screen, the Hard 

Copy function will not be available. 

Step 1. Set the Hard Copy Region in Screen Properties dialog box. 

 

Step 2. Enable Print Function 

Create a Report List button on a General View Screen. Use this Report List 

button to enable the print function. 

Step 3. Connect HMi to the printer and press Report List button, and the printer will 

start to print data out.  
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3.11.7 Recipe 

The Recipe function provides the controller a convenient parameter input method. The 

user can transmit the designated parameter to the controller by using HMi recipe. Bread 

making is an example. When making different types of bread, baking time is very 

important. The user can use Recipe function to meet the different time requirements for 

making different types bread. The purpose of this function is to reduce the loading of the 

controller and use less register (Memory) of the controller. 

When completing the recipe editing, the user needs to use the recipe register in control 

block (word 5 and 6) and the designated corresponding parameters (values) can be 

transmitted into the internal memory addresses of the controller. 

The recipe can be set and modified through the recipe dialog box and can be saved and 

used independently without the project.  In addition, the recipes can be saved in Windows 

Excel CSV file for the user to edit recipes more quickly. Before using a recipe, the user 

should enable the recipe function first by selecting Options > Recipe. 

 

Fig. 3-11-2 Recipe Setup dialog box 

Recipe Setup dialog box 

Enable 

Recipe 

When the check box next to Enable Recipe is checked, the recipe function 

is enabled.  

Recipe Setup dialog box 

Recipe 

Retained 

(Non-volatile) 

The user can select the location for the Recipe data to be stored. Recipe 

data can be stored in SRAM, or on a USB disk or SD if available on the HMi 

model.   
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The address can be internal memory, or the controller address. The user 

also can click  button to get the following address input dialog box to 

input the starting address. 

Address 

 

Length 

Set the recipe length. The unit is Word and it should be set to more than 0. 

Otherwise, the following dialog box will display on the screen. The length is 

the number of words or values the Recipe will need retain 

 

Group 

Set group number of recipe. The group number should be set to more than 

0. Otherwise, the following dialog box shown as Fig. 2.8.14 will display on 

the screen. The Group number is the number of recipes available. 

 

 
Recipe Setup dialog box 
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After setting length and group number of recipe, the user can click Input button to 

edit the recipe data. The memory size for recipe is limited to 64K SRAM in the HMi. 

(The number of Length x Groups should be less than 65536). If the total recipe size 

exceeds the limit, the user will see a warning message displayed on the screen. 

 

Input 

Some HMi models, support USB host function, allowing the user to use more recipe 

data via this USB host interface. The user can connect a USB disk via this USB host 

interface to HMi and input more recipe data. However, there is still a limit for the 

input value of recipe length and groups. When Recipe Retained (non-volatile area) 

is selected as USB disk, the length x groups should be less than 4096K (The 

number of Length x Groups should be less than 4194304). The user can change the 

non-volatile data location by clicking Options > Configuration > General.  

Open 

The user can load recipe data by clicking Open button. The loaded recipes do not 

contain the starting address of recipes. Therefore, regardless of which brand of the 

controller connected to HMi, they all can use the same recipe file. There are two 

recipe file types provided HMiSoft, one is 16bits recipe file (*.rcp) or (*.csv) and the 

other is 32bits recipe file (*.csv) that can be opened in Windows® Excel 

environment. The 16 bit and 32 bit recipe file are not interchangeable, meaning the 

user can not save a 16 bit (*.csv) and then open it as a 32bit (*.csv). Please note 

when opening a (*.csv), no other program i.e. Excel can be have the file open 

already, or an error will occur. 

Save 

When Save button is pressed, HMi will save the editing recipe data as a file, the 

starting address will not be saved. This lets the user use the same recipe file in the 

different PLC brand. The user can save the recipe file as Windows Excel CSV file. 

Reset 

When Reset button is pressed, all related recipe settings and input recipe data are 

deleted. There is no other method to retrieve the recipe except for using Import 

function to import the saved recipe data again. 

Recipe Setup dialog box 
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Clear 

When Clear button is pressed, all input recipe is cleared to 0 (zero).  

 

Print 
When Print button is pressed, all recipe data on the current screen will be printed 

out. 

OK  

After inputting the recipe data, the users can click OK button to save the recipe 

data for transmitting or modifying. At the same time, HMi will check the validity of 

all input recipe data. If there is invalid input recipe data value, the OK function will 

not execute successfully. For example, in the figure below, HMi found an error and 

a warning message dialog box displays on the screen due to a lack of an input 

address.  

 

Cancel 
When Cancel button is pressed, HMi will exit the Recipe Setup dialog box without 

saving. 
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3.11.8 32 bits Recipe 

32 bits recipe function provides the user the ability to save 32 bit data recipes. The data 

format includes Signed Decimal, Unsigned Decimal and Floating (The total of Integral and 

fractional digits cannot exceed 7 digits). To enable this function, the user can click 

Options > 32 bits recipe.  

 

Fig. 3-11-3 32 bits recipe dialog box 

 

32 bits recipe dialog box 

 

New: Create a new 32 bits floating recipe file 

Press  to create a new 32 bits floating recipe. After clicking , a 32 bits 

recipe setup dialog box will display and the user can use it to set the 

settings of a 32 bits recipe. The user can determine the recipe storage 

address, the length and group number of the recipe, the memory format, 

and the integer & fractional digit number of the recipe data. There are three 

kinds of memory format provided, including Unsigned Decimal, Signed 

Decimal and Floating. Integer and fractional digit number cannot be 

selected when the memory format is set to Unsigned Decimal and Signed 

Decimal. These two options are only available when the memory format is 

set to Floating. But the total of the Integer and fractional digit number 

cannot exceed 7 digits.  
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32 bits recipe dialog box 

   

 

 

Open: Open a 32 bits recipe file 

Press  to open a 32 bits recipe file. The file format can be Recipe 32 bits 

File (*.rcp) and Windows Excel CSV File (*.csv). The 16 bit and 32 bit recipe 

file are not interchangeable, meaning the user can not save a 16 bit (*.csv) 

and then open it as a 32bit (*.csv). Please note when opening a (*.csv), no 

other program i.e. Excel can be have the file open already, or an error will 

occur. 
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32 bits recipe dialog box 

 

 

 

Save: Save a 32 bits recipe file 

Press  to save a 32 bits recipe file. The default file format of a 32 bits 

recipe file is a Windows Excel CSV file (*.csv). 

 

 

Delete: Delete a 32 bits recipe 

Press  to delete unnecessary 32 bits recipe. 

 
Recipe Controller Address :  

Display the Controller address of a 32 bits recipe. 

 Setup: 32 bits recipe setup 
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32 bits recipe dialog box 

When clicking , a 32 bits recipe setup dialog box will display and the 

user can use it to change the settings of a 32 bits recipe. 

 
32 bits recipe dialog box 

Enable: Enables 32 bits recipe function  

The non-volatile area location is the same as the location of 16 bits recipes. 
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3.11.9 Picture Bank 

The user can use this function to import pictures into the screens. Click Options > Picture 

Bank to execute this function.  

Picture Bank dialog box 

 

Click the Picture Bank option to browse all pictures saved in Picture Bank. When one picture 

is selected, the user can see the picture in the preview window. Double left-clicking the 

mouse on the selected picture will display the picture in an actual size view.  

New  

Create a new picture bank. After clicking New icon, the New 

Picture Bank dialog box is displayed on the screen. 

 

Install  

Open a picture bank file (*.pib file). 

Uninstall  

Uninstall the selected picture bank. The uninstalled picture bank 

will be moved to Recycle Bin. 

Import  

Import pictures into the designated picture bank. The formats of 

the pictures in the picture bank can be BMP, JPG, GIF and ICON 

pictures. Please note that if the imported GIF file is an animation 

file, the imported animation files will be divided into several 

segments. When selecting this function, the dialog box shown 

will be displayed.  
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Picture Bank dialog box 

Import  

The users can then convert the picture color in advance to speed the 

compile time or choose No changed option to retain the original color. 

 

Update  

After editing the picture (execute Inverse, Grayscale, etc. functions), 

the user needs to click Update button so that the status of the picture 

can be changed and updated.  

Export  
Export pictures in BMP format from the picture bank. 

Delete  
Deletes the picture from the picture bank 

 

Inverse  
Inverse the picture color - negative effect 

 

Grayscale  

Convert the color picture to 256 color 

grayscale 
256

 
Horizontal Mirror 

 

Horizontal mirror effect  

Vertical Mirror 

 

Vertical mirror effect  
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Picture Bank dialog box 

Shortcut Menu 

The users can right-click the mouse on any picture in the picture bank 

to display a shortcut menu shown on the figure below. This shortcut 

menu shows a list of commands relevant to the picture bank option. 

This allows the users to manage the pictures in the picture bank more 

quickly and efficiently.  
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3.11.10 Text Bank 

Input common or frequently used text and terms into Text Bank. The user can select the 

text from the Text Bank and enter them on the element more efficiently.  

Text Bank dialog box 

 

Add 

Press the Add button to add the text into the Text Bank. The 

multi-language editing is supported in the Text Bank option. The user 

can input the text or terms in different language and save them in the 

Text Bank.  

The multi-language font can also be set at the same time.  

Delete Press Delete button to remove the input text or terms in Text Bank.  

Open 
Press Open button to open and import the text or terms into Text 

Bank.  

Save Press Save button to save and export the text file.  

Close Press Close button to close and exit the text bank dialog box. 
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3.11.11 Submacro 

Use this option to edit sub-macro’s to be called by other Macros. For the Macro function, 

please refer to section 3.14. 

 

3.11.12 Initial Macro 

Use this option to edit initial macro. The initial macro will be executed once automatically 

after the power is applied to HMi (power on). For the Macro function, please refer to section 

3.14. 

 

3.11.13 Background Macro 

Use this option to edit background macro. This macro will run continually while the HMi is 

running the application. For the Macro function, please refer to section 3.14. 

 

3.11.14 Clock Macro 

Use this option to edit clock macro. After the HMi is turned on this macro will run on a set 

Clock.  For the Macro function, please refer to section 3.14.  
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3.11.15 Environment 

Use this option to complete the environment settings of HMiSoft. 

Environment Dialog Box 

 

System 

Path 

Set the location where HMi saves the system files, including some system 

reference data and dynamic link library (*.dll) files. To avoid a system error and 

failure to find the file, we recommend the users not change this setting if it is not 

necessary. (This option is disabled by default.)  

Output 

Path 

Set the location where HMi saves the output file after compile operation. Some 

functions, such as on-line simulation, off-line simulation, file download and 

upload all refer to the files in this location. To avoid a system error and failure to 

find the file, we recommend the users not change this setting if it is not necessary. 

Toolbars / 

Windows 

Set the option to display or not display toolbars or docking 

windows. 

Language 

Choose English, Turkish, Traditional Chinese or Simplified 

Chinese from the Language drop-down list. This is the 

language of the editor not the application. 

Options 

Upload / Download 
Determines the communication interface for upload and 

download. It can be USB, Ethernet or PC COM Port.  
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Environment Dialog Box 

Auto Saving… Time 

Interval 

When this option is selected, HMi will automatically save the 

file every specified number of minutes. The unit is M (minute) 

and the setting range is between 0M ~ 120M. 

Auto open last file 

when starting 

HMiSoft 

When this option is selected, HMi will automatically open the 

last saved file every time when the user starts HMI. 

Center Drawing 

Area 

When this option is selected, the editing screen will be placed 

in the center position.  

 

Include picture data 

for uploading 

If this option is selected, all pictures are also uploaded when 

the HMi uploads a function. All uploaded pictures are saved 

in a file named as _LocalTemp01.pib. When uploading is 

executed the next time, the last two numbers at the end of 

the file name will increase progressively _LocalTemp02.pib, 

_LocalTemp03.pib, and so on. 

Auto convert input 

address to tag name 

For example, if the user wants to replace PLC address 1@Y0 

with the word “Running”, defined in the Tag Table option in 

advance. When this option is selected, HMi will automatically 

convert input address 1@Y0 to the word “Running”. 

Options 

Auto reboot after 

firmware upgrading 

When this option is selected, HMi will automatically restart 

(power off and then on) after the firmware upgrading is 

completed. 

Driver 
Reinstall HMi USB Drive: Press it to reinstall the HMi USB driver 

Uninstall HMi USB Drive: Press it to uninstall the HMi USB driver  

OK 
Press OK button to save the modified settings and exit the Environment dialog 

box. 

Cancel Press Cancel button to exit the Environment dialog box without saving. 
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3.12 Menu Bar and Toolbar (Window) 

 

 

3.12.1 Close Window 

Close Window is used to hide the current window, NOT exit the current window. The users 

can execute this function by clicking Window > Close Window. If the user wants to display 

the unopened screen, click Screen > Open Screen to open an existing screen.  

 

3.12.2 Close All Windows 

Close All Windows is used to hide all windows, NOT exit all windows. The user can execute 

this function by clicking Window > Close All Windows. If the user wants to display the 

unopened screen, click Screen > Open Screen to open an existing screen. 

 

3.12.3 Next Window 

Close Next Window is used to switch the current window to the next window. If the current 

window is the last window, the current window will not be changed.  

 

3.12.4 Previous Window 

Previous Window is used to switch the current window to the previous window. If the current 

window is the first window, the current window will not be changed.  
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3.12.5 Cascade 

Cascade display is used to display all editing windows by overlapping. The title bar of each 

window is visible but only the top window is fully visible. The user can execute this function 

by clicking Window > Cascade. The opened windows are displayed in an overlapped pattern 

as shown as Fig. 3-12-1.  

 

Fig. 3-12-1 Screen display after choosing Cascade command 
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3.12.6 Title Horizontal 

Title Horizontal is used to display all editing windows from top to bottom. The user can 

execute this function by clicking Window > Title Horizontal. The opened windows are 

displayed horizontally as shown as Fig. 3-12-2.  

 
Fig. 3-12-2 Screen display after choosing Title Horizontal command 
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3.12.7 Title Vertical 

Title Vertical is used to display all editing windows from left to right. The user can execute 

this function by clicking Window > Title Vertical. The opened windows are displayed 

vertically as shown as Fig. 3-12-3.  

 
Fig. 3-12-3 Screen display after choosing Title Vertical command 
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3.12.8 Window Summary 

HMiSoft displays a list of all opened screens at the bottom of “Window” pull-down menu for 

quick access. Just click the file name to open the file and view the screen directly (Fig. 3-12-4). 

 

Fig. 3-12-4 Window Summary 
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3.13 Menu Bar and Toolbar (Help) 

 

3.13.1 Help 

Display the version information of HMi Soft and the firmware information of HMi (Fig. 3-13-5). 

 

Fig. 3-13-1 HMi Soft Version 
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3.14 Macro Function 

Eaton HMi series provides various kinds of macro commands, including Arithmetic, Logical, 

Data transfer, Data conversion, Comparison, Flow control, Bit setting, Communication (COM 

port) and drawing, etc. for user’s selection (Fig. 3.14.1).  

 
Fig. 3-14-1 Macro Commands 

 

There are many advantages of using macro commands, such as: 

1. Optimizing the screen data  

2. Reducing the PLC program. 

3. Allow new functionality not directly available though standard editor 

Therefore, the macro function is a very convenient feature for the HMi user to use. After editing 

a Macro, you can test the Macro validity via either an on-line or off-line simulation on the PC 

before downloading to HMi.  

 

3.14.1 Macro Type 

There are eleven kinds of macro commands and they are divided into four categories. 

Please refer to the following: 

1. On / Off Macro: It is provided for each Bit element that can be an input, such as button 

element, i.e. Maintained and Momentary button. 

2. Before / After Execute Macro: It is provided for all elements, such as numeric / character 

entry element and all button elements (including system button). 

3. Screen Open / Screen Close / Screen Cycle Macro: It is provided to run a Macro when the 

screen 0pens, closes, or while the screen is open. 

4. Initial / Background / Clock / Sub Macro: It is provided to run a Macro when the project is 

First run, in the background while running, on a set clock, or when called by another 

macro. 
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Table 3-14-1 Macro Command Table 

Macro Name Descriptions 

On Macro 

The user can use the On Macro for each specific button element (Bit). 

It is called the On Macro because the Macro is executed once upon 

the button element (Bit) changing from OFF to ON.  

Off Macro 

The user can use the Off Macro for each specific button element 

(Bit). It is called the Off Macro because the Macro is executed once 

upon the button element (Bit) changing from ON to OFF. 

Before Execute 

Macro 

The user can use the Before Execute Macro for all button elements 

and numeric / character entry element. It is called the Before Execute 

Macro because the Macro is executed before any other action the 

element does takes place. 

After Execute Macro 

The user can use the After Execute Macro for all button elements 

and numeric / character entry element. It is called the After Execute 

Macro because the Macro is executed after any other action the 

element does takes place. 

Screen Open Macro 

The Screen Open Macro will be executed only ONCE when the user 

opens a screen (or switches to a new screen) and the screen 

elements will not be displayed until after the Screen Open Macro has 

completed execution. Therefore, it is important that the user pay 

close attention when designing the Screen Open Macro to avoid 

infinite loops (programs that cannot be ended) as it may cause a 

system delay or even prevent executing the screen’s elements. 

Writing long macros is not recommended and should be avoided if at 

all possible. Pay close attention on using loops and make sure to test 

the Macro with on-line/off-line simulation before downloading to 

HMi to ensure expected performance and operation.  

Screen Close Macro 

The Screen Close Macro will be executed only ONCE when the user 

closes the screen and no other macros will be executed until the 

Screen Close Macro is completed. Therefore, it is important that the 

user pay close attention when designing the Screen Close Macro to 

avoid infinite loops (programs that cannot be ended) as it may cause 

a system delay.  

Screen Cycle Macro 

The macro will be executed continuously when the screen is open. 

Therefore, writing long macros is not recommended and should be 

avoided for this type of macro. 
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Initial Macro 

The Initial Macro is executed just prior to the startup screen being 

displayed. This macro is very useful when setting initial values in the 

HMi or in a PLC.  

 
 
 

Macro Name Descriptions 

Background Macro 

The purpose of the Background Macro is to execute one or more 

commands simultaneously since it runs as a separate task. If 

another Macro is executed, such as the Cycle Macro, it will not have 

any effect on the Background Macro although they will appear to be 

executed almost simultaneously. This type of macro does not need 

to be run in a loop because it will operate in a cycle continuously. 

Clock Macro 

The Clock Macro will complete the Macro once, and then wait for the 

Clock cycle time and execute the Macro again. This will continue as 

long as the project is running. The Clock cycle time is set in the 

Standard tab of the Configuration window under Options. This type 

of macro is similar to a Cycle Macro therefore, writing long macros is 

not recommended and should be avoided.  

Sub-macro 

There are 512 sub-macros for editing that can be used to write 

repeated actions or functions to save macro editing time. To call a 

sub-macro simply, use a CALL command from within a macro; an 

example would be CALL 1 to call the first sub-macro. 
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3.14.1.1 On Macro 

This macro is attached to a button element. The user can use On Macro for each 

specific button (Bit). It is called the On Macro because the Macro is executed once upon 

the button element (Bit) changing from OFF to ON. However, On Macro only can be 

executed when the corresponding Bit for the button is triggered to be ON through the 

action of pressing the button, i.e. if another source (another button or Controller) 

turns the bit on the On Macro will not be executed.  

If there is a Momentary button created on the screen and On Macro is used, when the 

button is pressed, the procedure is as follows:  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Momentary 
Button 

When the button is pressed 
(Set to be ON) 

Momentary 
Button is ON 

Execute ON 
Macro 

Momentary 
Button is OFF 

When the button is released 
(Set to be OFF) 
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3.14.1.2 Off Macro 

This macro is attached to a button element. The user can use Off Macro for each 

specific button (Bit). When the button is set from ON to OFF, the Off Macro will be 

executed ONCE. After execution, this macro will not be executed until the button is set 

from ON to OFF again. However, OFF Macro only can be executed when the 

corresponding Bit for the button is triggered to be OFF through the action of pressing 

the button, i.e. if another source (another button or Controller) turns the bit off the Off 

Macro will not be executed. 

If there is a Momentary button created on the screen and On Macro is used, when the 

button is pressed, the procedure is as follows:  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3.14.1.3 Before Execute Macro 

Momentary 
Button 

When the button is pressed 
(Set to be ON) 

Momentary 
Button is ON 

Momentary 
Button is OFF 

Execute OFF 
Macro

When the button is released 
(Set to be OFF) 
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This macro is attached to a button element or numeric / character entry element. The 

operation is that when the button element is pressed, the system will execute the 

command of this macro first and then perform the operation of this button.  

If there is a Momentary button or numeric entry element created on the screen and 

Before Execute Macro is used, when the button is pressed, the procedure is as follows:  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Momentary button or numeric entry element 

When the button is pressed 
(Set to be ON) or when the 
value of the numeric entry 

element is entered 

Momentary button is ON or  
Numeric Entry Element is written 

Perform Before Execute Macro 

Momentary button is OFF or  
Numeric Entry Element is written 

When the button is released 
(Set to be OFF) or when the 
value of the numeric entry 

element is entered 

Perform Before Execute Macro 
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3.14.1.4 After Execute Macro 

This macro is attached to a button element or numeric / character entry element. The 

operation is that when the button element is released, the system will perform the 

operation of this button first and then execute the command of this macro. 

If there is a Momentary button or numeric entry element created on the screen and 

Before Execute Macro is used, when the button is pressed, the procedure is as follows:  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Momentary button or numeric entry element 

When the button is pressed 
(Set to be ON) or when the 
value of the numeric entry 

element is entered 

Momentary button is ON or  
Numeric Entry Element is written 

Momentary button is OFF or  
Numeric Entry Element is written 

When the button is released 
(Set to be OFF) or when the 
value of the numeric entry 

element is entered 

Perform After Execute Macro 
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3.14.1.5 Screen Open Macro 

Each screen has a Screen Open Macro. Screen Open Macro will only be executed ONCE 

when the user open a screen or switch to a new screen. The screen elements will be 

displayed and executed after finishing executing Screen Open Macro.  
 
 

 

 

 

 

 

 

 

 

 

 

3.14.1.6 Screen Close Macro 

Each screen has a Screen Close Macro. Screen Close Macro will only be executed ONCE 

when the user close a screen or switch to a new screen. The same as Screen Open 

Macro, the screen elements on new screen will be displayed and executed after 

finishing executing Screen Close Macro.  
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Open a New Screen 

Execute  
Screen Open Macro 

Perform other actions on 
the screen 

Open a screen or 
switch to a new 

screen 

Close the screen 

Execute  
Screen Close Macro 

Open a New Screen 

Perform other actions 
on the screen 

Execute  
Screen Open Macro 
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3.14.1.7 Screen Cycle Macro 

Each screen has a Screen Cycle Macro and it can be executed repeatedly for a specified 

period of cycle time. The user can set the Macro Cycle Delay Time, i.e. the delay time 

between the end and restart of Screen Cycle Macro in Screen Properties dialog box (See 

Fig. 3-14-2). The system default setting is 100ms.  

 
Fig. 3-14-2 Macro Cycle Delay Time 

 

 

 

 

 

 

 

 

 

 

 

Open the Screen (Execute Screen Open Macro) 

Execute Screen Cycle Macro 

Set cycle delay time to 100ms 
 (This setting can be user-defined) 

Close the Screen (Execute Screen Close Macro) 

 

Perform other actions  

on the screen 
After Screen Cycle Macro 

is executed 

Repeat 
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3.14.1.8 Initial Macro 

The Initial Macro is executed first at the beginning of a program. So, the user can 

preset necessary initial values in this macro to avoid unexpected problem by an 

unknown initial value. If the user needs to setup any special setting in the special 

address of the external controller, the user can use initial macro to set them also.  

 

 

 

 

 

 

 

 

 

 

 

3.14.1.9 Background Macro 

The Background Macro and is executed continuously. The use of a Background Macro 

is to execute one or more commands at a time, continuously. After the last macro 

command is executed, the system will start to execute this macro again from the first 

macro command. The user can click Options > Configuration > General tab and use 

Background macro update cycle option to determine how many lines of the 

background macro command to by run each cycle. (see Figure 3-14-3) 

 
Fig. 3-14-3 Background macro update cycle 

For example, suppose that there are 25 element addresses on the screen and 

Background has 5 lines of macro commands, if the value of background macro update 

cycle is set to 2, when background macro is executed, HMi will first read 25 element 

When HMI is powered on or when the user exits 
the system menu to activate the HMiSoft 

(Execute Initial Macro) 

Execute Open Macro 

Open the Screen 
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addresses and then execute 2 lines of background macro in sequence.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Read 25 element addresses 

Execute 1st and 2nd line commands 
of Background Macro 

Read 25 element addresses 

Execute 3rd and 4th line commands 
of Background Macro 

Read 25 element addresses 

Execute 5th line commands of 
Background Macro 
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3.14.1.10 Clock Macro 

Similar to Screen Cycle Macro, it can be executed repeatedly for every specified period 

of preset clock time. The user can set Clock Macro Delay Time, i.e. the delay time every 

time between the end and the restart of Clock Macro in General tab of Configuration 

dialog box (See Fig. 3-14-4). The system default setting is 100ms.  

 

Fig. 3-14-4 Clock Macro Delay Time option 

 

 

 

 

 

 

 

 

 

Power on the HMI 

Execute Clock Macro 

Set cycle delay time to 100ms 
(This setting can be user-defined) 

Power off the HMI 

Repeat 
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3.14.1.11 Sub-Macro 

Each project (HMiSoft program) is capable of containing 512 sub-macros labeled from 

1 to 512 by default (Fig. 3-14-5, Fig. 3-14-6). Sub-macro is similar to the subroutine. 

The user can write repeated actions or functions in sub-macro to save macro editing 

time and to easily maintain. For example, a function is written named sub-macro 2, the 

user only needs to write “CALL 2” in Macro whenever it is used. In the sub-macro 

program, the user can also call other sub-macro. However, in order to keep sufficient 

memory, only 6 levels of CALL sub-macro can be used. If the user wants to change the 

name of the sub-macro to a more user-friendly description, the user can rename the 

sub-macro freely.  

 

 

         

             Fig. 3-14-5 Sub-macro Screen I             Fig. 3-14-6 Sub-macro Screen II 

 

To call a specific sub-macro, a CALL command is used.  

For example: 

Create a Screen Open Macro command and a Sub-Macro first (Fig.3-14-7, Fig. 3-14-8). 

The execution process of the Screen Open Macro will be shown as the Fig. 3-14-9. 

          

Fig. 3-14-7 Screen Open Macro             Fig. 3-14-8 Sub-Macro 1 

 

Number of the Sub-macro Name of the Sub-macro 
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  Fig. 3-14-9 Execution process of Screen Open Macro 

 

When CALL 1 is executed, it means that Sub-Macro 1 is called and executed. After 

executing Sub-Macro, the system will continue to execute Screen Open Macro till it 

ends. At this time, 0 = 0 and $1 = 1. 

 

NOTE   

When editing any macros, please pay close attention to the flow of macro command, especially 

the usage of loop and program. If the user writes an infinite loop (i.e. program that cannot be 

ended) in the macro or write a program which will not be executed until some certain condition 

is satisfied, it may make HMi work abnormally. Therefore, it is recommended that the user 

should use simulation function to verify the macro and check if HMi operation is correct after 

macro editing is completed. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3.14.2 Macro Editing 

$0 = 10 

CALL 1($0 = 0) 

$1 = 1 
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3.14.2.1 Macro Editing Widow and Toolbar 

After choosing the desired Macro command from the menu bar, the user can start 

editing the Macro by clicking any line in the editing window shown in Fig. 3-14-10. 

Please note that each macro is capable of containing 512 lines of code with a 

maximum of 128 characters per line.  

 
Fig. 3-14-10 Macro Editing Window 

 

The user can also use the icons on the toolbar (Fig. 3-14-11) for Macro editing.  

 

 

 

 

 

Fig. 3-14-11 Macro Toolbar 

 

 

 

 

 

Open 

 
 
 
 
 

Macro Editing Area 

Open Macro 

Save Macro 

Cut 
Syntax Check 

Update 

Copy 

Paste 

Wizard 
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 This command opens macro files.  

The user can open these files when reusing Macros from a different project. To open a 

macro file, click the Open icon and the following dialog box will show up (Fig. 

3-14-12).  

 

Fig. 3-14-12 Open Macro 

Save 

 This command saves macro files.  

The user can save and name a Macro file to help the user to backup and save reinput 

time. (Fig. 3-14-13). 

 
Fig. 3-14-13 Save Macro 

Cut 
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 This command cuts macro files.  

The user can also press Ctrl+X to execute this function. 

 

Copy 

 This command copies macro files. 

The user can also press Ctrl+C to execute this function. 

 

Paste 

 This command pastes macro files. 

The user can also press Ctrl+V to execute this function. 

 

Wizard 

 This command shows the Macro Command Dialog Box.  

After clicking on the Wizard icon and the following dialog box will pop up. The user 

can use this dialog box to edit a macro. If an address of the external controller is used 

in the macro, the address will be in brackets to distinguish it from internal memory. 

 

The user can enter the macro commands directly or click on the Command button to 

choose the command needed for the macro. For more details on macro commands, 

refer to the following section 3.14.2.2. 

 

 

 

 

Syntax Check 
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 This command examines if the macro syntax is correct. 

If the macro syntax has an error, the following error message dialog box will pop up to 

alert the user.  

 

Please note that the operation of Syntax Check is different than the compile operation 

of macro files. The compile operation of macro file is performed when the compile 

operation of HMi program is executed. The compile operation of the macro file and 

HMi program is executed simultaneously.  

 

Update 

 This command updates macro files. 

The modification will not be updated if Update button is not pressed after editing. 

This gives user a second chance to decide to modify the macros or not. 

 

After Yes button is pressed, the system will examine if the macro syntax is correct. If 

the macro syntax is correct, the update function will be executed and the macro files 

will be updated. However, if the macro syntax is not correct, the following error 

message dialog box will pop up on the screen to alert the user to examine the macro 

syntax again.  

 

3.14.2.2 Macro Command Dialog Box 

After clicking on  icon on the toolbar, the Macro Command Dialog Box will display 
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automatically (Fig. 3-14-14). 

 

              

 

 

 

 

 

 

 

Fig. 3-14-14 Macro Command Dialog Box 

 

Edit 

The user can edit the macro files via the edit option in the Macro Command dialog box 

(Fig. 3-14-15) or from the toolbar (Fig. 3-14-16).  

  

     Fig. 3-14-15 Edit options from menu bar   Fig. 3-14-16 Edit option from toolbar 

Previous 

 

 
This command moves up the selected line by one line. 

Next 

 

 
This command moves down the selected line by one line. 

Update 

 

 

This command updates macro files. If this function is not used after 

editing a macro, changes are not updated. When this icon is clicked, the 

Macro Editing Toolbar
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system will perform the examination of macro syntax. If the macro 

syntax is correct, the update function will be executed and the macro 

files will be updated. When the user tries to close Macro Command dialog 

box without pressing this Update button, the following dialog box will 

show up on the screen to alert the user.  

 
After Yes button is pressed, the system will examine if the macro syntax 

is correct. If the macro syntax is correct, the update function will be 

executed and the macro files will be updated. However, if the macro 

syntax is not correct, the following error message dialog box will pop up 

on the screen to alert the user. 

 

Insert 

 

 

This command inserts a macro between two lines. The lines below will 

move down by one line. 

Delete 

 

 

This command deletes the selected line. The lines below will move up by 

one line.  

Comment 

 

 

To write comments in programs, the user can put a comment mark (#) in 

front of sentences. The sentences from the comment mark to the end are 

comments. Please note that the content of the comments will not be 

executed. 

 

Command 

The user can use commands to edit the macro. The command and equation can be 

typed directly, or chosen from the menu bar (Fig. 3-14-17) or selected by clicking the 

Command button (Fig. 3-14-18).  
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Fig. 3-14-17 Command options from menu bar 

 

 
 

Fig. 3-14-18 Command options from drop-down list 

 

 

 

 

 

Fig. 3-14-20 ~ Fig. 3-14-29 show all the macro commands. For more details, please 

refer to the section 3.14.3. 
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Fig. 3-14-19 Commands 

options 

Fig. 3-14-20 

Arithmetic 

Fig. 3-14-21 

Logical 

Fig. 3-14-22 

Data 

Transfer 

 
   

Fig. 3-14-23  

Data Conversion 

Fig. 3-14-24 

Comparison 

Fig. 3-14-25 

Flow Control 

Fig. 3-14-26 

Bit Setting 

    

Fig. 3-14-27  

COM Port 

Fig. 3-14-28 

Drawing 

Fig. 3-14-29 

Others  

After macro command is selected, the user can click on Variable button to determine 

the necessary variables (Var1 ~ Var4) (Fig. 3-14-30, Fig. 3-14-31).  
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Fig. 3-14-30 Fig. 3-14-31 

 

Fig. 3-14-32 Double Word and Signed options 

 

Unsigned A unsigned value is a numeric value without polarity, 

Signed A signed value is a numeric value with polarity, which 
is used to represent both positive and negative values. 
A byte, word or double-word can be signed.  

WORD A word consists of 16 bits of continuous data. This is 
used to represent 16 bits of data or 0x0000 to 0xFFFF 
hexadecimal or 0 to 65535 decimal. 

DW, DWORD 

(DOUBLE WORD, DWORD) 

A double-word consists of 32 bits of continuous data. 
This is used to represent 32 bits of data or 0x000000 
to 0xFFFFFF hexadecimal or 0 to 4,294,967,295 
decimal. 

Table 3-14-2 Macro Definition 

If DW shows after the macro command, it indicates that the command is 32 Bit data, if 

DW doesn’t display, it indicates that the command is 16 Bit data. When the user set the 
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format of the device as Double Word, there will be two registers used. It means that if 

the user set the format of $0 as Double Word, $0 and $1 will be used for storing data. 

If Signed shows after the macro command, it indicates that the command is a numeric 

value with polarity. If Signed doesn’t display, it indicates that it is a numeric value 

without polarity. 

For example, when the macro command is set to $0 = $2(DW), i.e. make $2 a double 

word, as Double Word memory will take two registers; it will assign register $2 and $3. 

Press Update button and the macro command will be input in the editing window 

shown as Fig. 3-14-33. 

 

Fig. 3-14-33 Input Macro Command 

 

After complete macro command editing, the user needs to perform Syntax Check and 

Update function to makes sure that the macro syntax is correct. For more details on 

Update and Syntax Check function, please refer to section 3.14.2.1.  
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3.14.2.3 Keypad Entry 

For the convenience of editing the macro, the system allows the user to edit the macro 

commands by keying in the commands manually. The system will check the validity 

automatically, if there are any errors, a warning dialog box will pop up to alert the user.  

It is not critical that the user place the correct amount of spaces between commands 

and operands, when the line is updated the system will automatically adjust the 

spacing and warn of formatting errors. In addition, a list of the macro commands will 

appear automatically when the user keys in the commands manually (Fig. 3-14-33).  

 

Fig. 3-14-33 

After the macro command is entered, the user’s screen will look like Fig. 3-14-34 

below.  

 

Fig. 3-14-34 

After completing macro command editing, the user needs to perform Syntax Check 

and Update function to makes sure that the macro syntax is correct. For more details 

on Update and Syntax Check function, please refer to section 3.14.2.1.  

 

 

3.14.3 Macro Operation 
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3.14.3.1 Arithmetic Operation 

 

 

There are two Arithmetic Operations, which include Integer Operation and 

Float Operation. 

Each operand can be the internal memory or constant. The operands that store output 

results must be internal memory. For details, refer to this table and examples below. 

 

 + (Addition) 

Equation 

Var1 = Var2 + Var3 

 

Explanation 

Perform the addition on Var2 and Var3, and store the addition result in Var1. 

 

Note 

 The calculation result can be stored as signed or unsigned WORD and DWORD. 

When the data exceeds the length of designated unit, the data out of range will 

be discarded. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

 

Example 

Add a value of 1 to $0 and store the value in $0 (this is an operation of unsigned 
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16-bit data). 

 
Add a value of $1 to $2 and store the value in $3 (this is an operation of signed 16-bit 

data). 

 
Add a value of $4 to $6 and store the value in $8 (this is an operation of signed 32-bit 

data). 

 

 

 

 

 

 

 

 - (Subtraction) 
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Equation 

Var1 = Var2 - Var3 

 

Explanation 

Perform the subtraction of Var2 and Var3, and store the subtraction result in Var1. 

 

Note 

 The calculation result can be stored as signed or unsigned WORD and DWORD. 

When the data exceeds the length of designated unit, the data out of range will 

be discarded. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Subtract a value of 1 from $0 and store the value in $0 (this is an operation of 

unsigned 16-bit data). 

 

Subtract a value of $1 from $2 and store the value in $3 (this is an operation of 

signed 16-bit data). 

 
 

 

Subtract a value of $4 from $6 and store the value in $8 (this is an operation of 
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signed 32-bit data). 

 
 

 * (Multiplication) 

Equation 

Var1 = Var2 * Var3 

 

Explanation 

Perform the multiplication of Var2 and Var3, and store the multiplication result in 

Var1. 

 

Note 

 The calculation result can be stored as signed or unsigned WORD and DWORD. 

When the data exceeds the length of designated unit, the data out of range will 

be discarded. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Multiply $0 by 2 and store the value in $0 (this is an operation of unsigned 16-bit 

data). 

 
Multiply the value of $1 by $2 and store the value in $3 (this is an operation of signed 
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16-bit data). 

 
Multiply the value of $4 by $6 and store the value in $8 (this is an operation of signed 

32-bit data). 

 
 

 / (Division) 

Equation 

Var1 = Var2 / Var3 

 

Explanation 

Perform the division of Var2 and Var3, and store the division result in Var1.  

 

Note 

 The calculation result can be stored as signed or unsigned WORD and DWORD. 

When the data exceeds the length of designated unit, the data out of range will 

be discarded. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 The value contained within Var3 cannot be equal to 0 (zero). 

 

 

Example 
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Divide $0 by the value of 2 and store the value in $0 (this is an operation of unsigned 

16-bit data). 

 
Divide $1 by $2 and store the value in $3 (this is an operation of signed 16-bit data). 

 
Divide $4 by $6 and store the value in $8 (this is an operation of signed 32-bit data). 

 
 

 

 

 

 

 

 

 

 % (Get Remainder) 
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Equation 

Var1 = Var2 % Var3 

 

Explanation 

Perform the division of Var2 and Var3, and store the remainder in Var1.  

 

Note 

 The calculation result can be stored as signed or unsigned WORD and DWORD. 

When the data exceeds the length of designated unit, the data out of range will 

be discarded. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 The value contained within Var3 cannot be equal to 0 (zero). 

 

Example 

Divide $0 by the value of 2 and store the remainder value in $1 (this is an operation 

of unsigned 16-bit data). 

 
Divide $2 by $3 and store the remainder value in $4 (this is an operation of signed 

16-bit data). 

 
 

 

Divide $5 by $7 and store the remainder value in $9 (this is an operation of signed 
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32-bit data). 

 
 

 MUL64 (64-bit Multiplication) 

Equation 

Var1 = MUL64 (Var2, Var3) 

 

Explanation 

Perform the multiplication of Var2 and Var3, and store the multiplication result in 

Var1.  

 

Note 

 Uses 32 Bit data. 

 The calculation result can be stored as signed or unsigned DWORD.  

 Var1 occupies 4 Words. Var2 and Var3 occupy 2 Words. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Multiply the value of $0 by $2 and store the value in $4 (this is an operation of 

unsigned 32-bit data). 

 
Multiply the value of $8 by $10 and store the value in $12 (this is an operation of 
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signed 32-bit data). 

 
 

 ADDSUMW (Repeated Addition) 

Equation 

Var1 = ADDSUMW (Var2, Var3) 

 

Explanation 

Perform the addition on Var3 consecutive registers starting at register Var2 and 

store the repeated addition result in Var1. 

 

Note 

 Uses unsigned data. 

 The calculation result can be stored as unsigned WORD and DWORD. When the 

data exceeds the length of designated unit, the data out of range will be 

discarded. 

 Var1 and Var2 can be internal memory only. Var3 can be internal memory or 

constant. 

 

Example 

Add up the values contained within the internal memory address $0, $1, $2, $3 and 

$4, and the grand total is stored in the address $5 (this is an operation of unsigned 

16-bit data). 
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Add up the values contained within the internal memory address $6, $8 and $10, 

and the grand total is stored in the address $12 (this is an operation of unsigned 

32-bit data). 

 
 

 FADD (Floating Addition) 

Equation 

Var1 = FADD (Var2, Var3) 

 

Explanation 

Perform the addition on Var2 and Var3, and store the addition result in Var1. 

 

Note 

 Uses signed 32-bit data. 

 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Add a value of 1.0 to $0 and store the value in $0 (this is a floating point operation of 

signed 32-bit data). 
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Add a value of $4 to $2 and store the value in $6 (this is a floating point operation of 

signed 32-bit data). 

 
 

 FSUB (Floating Subtraction) 

Equation 

Var1 = FSUB (Var2, Var3) 

 

Explanation 

Perform the subtraction of Var2 and Var3, and store the subtraction result in Var1. 

 

Note 

 Uses signed 32-bit data. 

 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Subtract a value of 1.0 from $0 and store the value in $0 (this is a floating point 

operation of signed 32-bit data). 
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Subtract a value of $2 from $4 and store the value in $6 (this is a floating point 

operation of signed 32-bit data). 

 

 

 FMUL (Floating Multiplication) 

Equation 

Var1 = FMUL (Var2, Var3) 

 

Explanation 

Perform the multiplication of Var2 and Var3, and store the multiplication result in 

Var1. 

 

Note 

 Uses signed 32-bit data. 

 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 
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Example 

Multiply the value of $0 by 2.0 and store the value in $0 (this is a floating point 

operation of signed 32-bit data). 

 
Multiply the value of $2 by $4 and store the value in $6 (this is a floating point 

operation of signed 32-bit data). 

 
 

 FDIV (Floating Division) 

Equation 

Var1 = FDIV (Var2, Var3) 

 

Explanation 

Perform the division of Var2 and Var3, and store the division result in Var1. 

 

Note 

 Uses signed 32-bit data. 

 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 The value contained within Var3 cannot be equal to 0 (zero). 
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Example 

Divide the value of $0 by 2.0 and store the value in $0 (this is a floating point 

operation of signed 32-bit data). 

 
Divide the value of $2 by $4 and store the value in $6 (this is a floating point 

operation of signed 32-bit data). 

 
 

 FMOD (Get Floating Remainder) 

Equation 

Var1 = FMOD (Var2, Var3) 

 

Explanation 

Perform the division of Var2 and Var3, and store the remainder in Var1.  

 

Note 

 Uses signed 32-bit data. 

 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 The value contained within Var3 cannot be equal to 0 (zero). 
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Example 

Divide $0 by the value of 2.0 and store the remainder value in $2 (this is a floating 

point operation of signed 32-bit data). 

 
Divide $4 by $6 and store the remainder value in $8 (this is a floating point operation 

of signed 32-bit data).  

 
 

 SIN (Sine Function) 

Equation 

Var1 = SIN (Var2) 

 

Explanation 

Perform the sine function of the value within Var2, and store the result in Var1.  

 

Note 

 The definition of Var2 is an angle, not radius.  

 Uses signed 32-bit data. 

 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 

 Var1 can be internal memory only. Var2 can be internal memory or constant. 

 The display format of the variables must be floating point. 

 The input variable must be a signed decimal value without the decimal point. 



HMi Chapter 3 Creating and Editing Screens 

   3-315 

Example 

Perform the function of SIN30o and store the result in $0 (this is a floating point 

operation of signed 32-bit data). 

 
Perform the sine function of $2 and store the result in $4 (this is a floating point 

operation of signed 32-bit data). 

 
 

 COS (Cosine Function) 

Equation 

Var1 = COS (Var2) 

 

Explanation 

Perform the cosine function of the value within Var2, and store the result in Var1.  

 

Note 

 The definition of Var2 is an angle, not radius.  

 Uses signed 32-bit data. 

 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 

 Var1 can be internal memory only. Var2 can be internal memory or constant. 

 The display format of the variables must be floating point. 

 The input variable must be a signed decimal value without the decimal point. 
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Example 

Perform the function of COS30o and store the result in $0 (this is a floating point 

operation of signed 32-bit data). 

 

Perform the cosine function of $2 and store the result in $4 (this is a floating point 

operation of signed 32-bit data). 

 

 

 TAN (Tangent Function) 

Equation 

Var1 = TAN (Var2) 

 

Explanation 

Perform the tangent function of the value within Var2, and store the result in Var1.  

 

Note 

 The definition of Var2 is an angle, not radius.  

 Uses signed 32-bit data. 

 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 

 Var1 can be internal memory only. Var2 can be internal memory or constant. 
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 The display format of the variables must be floating point. 

 The input variable must be a signed decimal value without the decimal point. 

 

Example 

Perform the function of TAN30o and store the result in $0 (this is a floating point 

operation of signed 32-bit data). 

 
Perform the tangent function of $2 and store the result in $4 (this is a floating point 

operation of signed 32-bit data). 

 
 

 COT (Cotangent Function) 

Equation 

Var1 = COT (Var2) 

 

Explanation 

Perform the cotangent function of the value within Var2, and store the result in Var1.  

 

Note 

 The definition of Var2 is an angle, not radius.  

 Uses signed 32-bit data. 

 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 
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 Var1 can be internal memory only. Var2 can be internal memory or constant. 

 The display format of the variables must be floating point. 

 The input variable must be a signed decimal value without the decimal point. 

 

Example 

Perform the function of COT30o and store the result in $0 (this is a floating point 

operation of signed 32-bit data). 

 
Perform the cotangent function of $2 and store the result in $4 (this is a floating 

point operation of signed 32-bit data). 

 
 

 SEC (Secant Function) 

Equation 

Var1 = SEC (Var2) 

 

Explanation 

Perform the secant function of the value within Var2, and store the result in Var1.  

 

Note 

 The definition of Var2 is an angle, not radius.  

 Uses signed 32-bit data. 
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 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 

 Var1 can be internal memory only. Var2 can be internal memory or constant. 

 The display format of the variables must be floating point. 

 The input variable must be a signed decimal value without the decimal point. 

 

Example 

Perform the function of SEC30o and store the result in $0 (this is a floating point 

operation of signed 32-bit data). 

 
Perform the secant function of $2 and store the result in $4 (this is a floating point 

operation of signed 32-bit data). 

 
 

 CSC (Cosecant Function) 

Equation 

Var1 = CSC (Var2) 

 

Explanation 

Perform the cosecant function of the value within Var2, and store the result in Var1.  

 

Note 

 The definition of Var2 is an angle, not radius.  
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 Uses signed 32-bit data. 

 The calculation result can be stored as signed DWORD. When the data exceeds 

the length of designated unit, the data out of range will be discarded. 

 Var1 can be internal memory only. Var2 can be internal memory or constant. 

 The display format of the variables must be floating point. 

 The input variable must be a signed decimal value without the decimal point. 

 

Example 

Perform the function of CSC30o and store the result in $0 (this is a floating point 

operation of signed 32-bit data). 

 

Perform the cosecant function of $2 and store the result in $4 (this is a floating point 

operation of signed 32-bit data). 
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3.14.3.2 Logical Operation 

 
There are six logical operations which include OR, AND, XOR, NOT, Shift-left and 

Shift-right. There are three operands for each operation and each operand can be 

internal memory or constant, but it is internal memory only when outputting. The unit 

can be Word and Double Word. 

 

 | (Logical OR operation) 

Equation 

Var1 = Var2 | Var3 

 

Explanation 

Perform the logical OR operation on Var2 and Var3, and save the result of this 

calculation in Var1.  

 

Note 

 The calculation result can be stored as WORD and DWORD. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Perform the logical OR operation on $0 and $1, and save the result in $2 (this is an 

operation of unsigned 16-bit data) 

 
$2 = $0 | $1 Store the result of $2. $0 = F000H, $1 = 0F00H, then $2 = FF00H.  

Perform the logical OR operation on $3 and $5, and save the result in $7 (this is an 

operation of unsigned 32-bit data) 
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$7 = $3 | $5 (DW) Store the result of $7. $3 = F000F000H, $5 = 0F000F00H, then $7 

= FF00FF00H.  

 

 && (Logical AND operation) 

Equation 

Var1 = Var2 && Var3 

 

Explanation 

Perform the logical AND operation on Var2 and Var3, and save the result of this 

calculation in Var1.  

 

Note 

 The calculation result can be stored as WORD and DWORD. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Perform the logical AND operation on $0 and $1, and save the result in $2 (this is an 

operation of unsigned 16-bit data) 

 

$2 = $0 && $1 Store the result of $2. $0 = F000H, $1 = 0F00H, then $2 = 0000H. 
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Perform the logical AND operation on $3 and $5, and save the result in $7 (this is an 

operation of unsigned 32-bit data) 

 
$7 = $3 && $5 (DW) Store the result of $7. $3 = F000F000H, $5 = 0F000F00H, then 

$7 = 00000000H.  

 

 ^ (Logical XOR operation) 

Equation 

Var1 = Var2 ^ Var3 

 

Explanation 

Perform the logical XOR operation on Var2 and Var3, and save the result of this 

calculation in Var1.  

 

Note 

 The calculation result can be stored as WORD and DWORD. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Perform the logical XOR operation on $0 and $1, and save the result in $2 (this is an 

operation of unsigned 16-bit data) 
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$2 = $0 ^ $1 Store the result of $2. $0 = F100H, $1 = 0F00H, then $2 = FE00H.  

Perform the logical XOR operation on $3 and $5, and save the result in $7 (this is an 

operation of unsigned 32-bit data) 

 
$7 = $3 ̂  $5 (DW) Store the result of $7. $3 = F100F100H, $5 = 0F000F00H, then $7 

= FE00FE00H.  

 

 NOT (Logical NOT operation) 

Equation 

Var1 = NOT Var2 

 

Explanation 

Perform the logical NOT operation on Var2, and save the result of this calculation in 

Var1.  

 

Note 

 The calculation result can be stored as WORD and DWORD. 

 Var1 can be internal memory only. Var2 can be internal memory or constant. 

 

Example 

Perform the logical NOT operation on $0, and save the result in $1 (this is an 

operation of unsigned 16-bit data). 
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$1 = NOT $0 Store the result of $1. $0 = F100H, $1 = 0EFFH. 

Perform the logical NOT operation on $2, and save the result in $4 (this is an 

operation of signed 32-bit data). 

 

$4 = NOT $2 (Signed DW) Store the result of $4. $2 = F100 F100H, $4 = 0EFF 0EFFH. 

 

 << (SHL, Logical Shift-left operation) 

Equation 

Var1 = Var2 << Var3 

 

Explanation 

Shift Var2 (WORD/DWORD) data to left (number of bit is Var3). The result of this 

calculation is stored in Var1. 

 

Note 

 The calculation result can be stored as WORD and DWORD. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

$0 = F100H  

Shift-left 4 bits and becomes $1 = 1000H (this is an operation of unsigned 16-bit 

data). 
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$2 = F1000000H 

Shift-left 4 bits and becomes $4 = 10000000H (this is an operation of unsigned 

32-bit data). 

 
 

 >> (SHR, Logical Shift-right operation) 

Equation 

Var1 = Var2 >> Var3 

 

Explanation 

Shift Var2 (WORD/DWORD) data to right (number of bit is Var3). The result of this 

calculation is stored in Var1. 

 

Note 

 The calculation result can be stored as WORD and DWORD. 

 If the shift number of bit is more than the address itself, the number out of 

range will be discarded.  

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 
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Example 

$0 = F100H  

Shift-left 4 bits and becomes $1 = 0F10H (this is an operation of unsigned 16-bit 

data).  

 
$2 = F1000000H  

Shift-left 4 bits and becomes $4 = 0F100000H (this is an operation of unsigned 

32-bit data).  
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3.14.3.3 Data Transfer 

 

There are five commands for data transfer, including MOV, BMOV, FILL, FILLASC and 

FMOV. 

 MOV (Transfer Data) 

Equation 

Var1 = Var2 

 

Explanation 

Transfer data from Var2 to Var1. No data change within Var2 after executing MOV 

command. 

 

Note 

 The calculation result can be stored as WORD and DWORD. 

 Var1 can be internal memory only. Var2 can be internal memory or constant. 

 

Example 

$0 = 0  

The data within the internal memory address $0 is assigned to the constant 0 (this is 

an operation of unsigned 16-bit data).  

 
$1 = 99999 (Signed DW) 

The data within the internal memory address $1 is assigned to the constant 99999 

(this is an operation of signed 32-bit data).  
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 BMOV (Block Move Copy Block) 

Equation 

BMOV (Var1, Var2, Var3) 

 

Explanation 

BMOV (Var1, Var2, Var3) means to move sequential data of Var3 in length from 

address Var2 to address Var1 in block.  

 

Note 

 The calculation result can be stored as unsigned WORD. 

 If the block length is more than internal memory or max number of PLC register, 

there will be an error when compiling. 

 Var1 and Var2 can be controller address or internal memory. Var3 can be 

internal memory or constant. 

 

Example 

Move the data in $0, $1, $2, $3, $4 to $10, $11, $12, $13 in order (this is an 

operation of unsigned 16-bit data). 
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 FILL (Fill the Memory) 

Equation 

FILL (Var1, Var2, Var3) 

 

Explanation 

FILL (Var1, Var2, Var3) means to fill address Var1 with data in address Var2 for a 

sequential V3 number of registers.  

 

Note 

 The calculation result can be stored as unsigned or signed WORD. 

 If the block length is more than internal memory or max number of PLC register, 

there will be an error when compiling. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Executing FILL command to fill $0, $1, $2, $3, $4 with constant 0 (this is an 

operation of unsigned 16-bit data). 

 
 

 FILLASC (Convert Text to ASCII code) 

Equation 

FILLASC (Var1, “Var2”) 

 

Explanation 

FILLASC (Var1, “Var2”) means to convert text in address V2 to ASCII code and store in 

V1. 

 

Note 

 The calculation result can be stored as unsigned WORD. 

 The max length is 128 words. 
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 One address can store up to two words. The excess word will be stored in next 

address in order. The low and high bit of the converted ASCII code will be 

exchanged. 

 Var1 can be internal memory only. Var2 can be internal memory or constant. 

 

Example 

After executing FILLASC command, 4241H will be stored in $0 and 3130H will be 

stored in $1 (this is an operation of unsigned 16-bit data). 

 
 

 FMOV (Transfer Floating Point Data) 

Equation 

Var1 = FMOV (Var2) 

 

Explanation 

Transfer floating point data from Var2 to Var1. No data change within Var2 after 

executing FMOV command. 

 

Note 

 The calculation result can be stored as signed DWORD. 

 Var1 can be controller address or internal memory. Var2 can be controller 

address, internal memory or constant. 

 

Example 

Transfer constant 44.3 to the internal memory address $0 (this is an operation of 

signed 32-bit data). 
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Transfer the same data of PLC 1@C200 to the internal memory address $2 (this is an 

operation of signed 32-bit data). 
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3.14.3.4 Data Conversion 

 
 

There are various kinds of commands for data conversion. For more details, please 

refer to the following sections.  

 

 BCD (Convert BIN Data into BCD Value) 

Equation 

Var1 = BCD (Var2) 

 

Explanation 

The binary data in Var2 is converted into a BCD value and stored in Var1. 

 

Note 

 The calculation result can be stored as unsigned WORD or DWORD. 

 Var1 and Var2 can be internal memory only. 

 

Example 

After executing BCD command, the binary data in $0 is converted to a BCD value and 

stored in $1 (this is an operation of unsigned 16-bit data). 
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 BIN (Converts BCD Data into BIN Value) 

Equation 

Var1 = BIN (Var2) 

 

Explanation 

The BCD data in Var2 is converted into binary value and stored in Var1. 

 

Note 

  The calculation result can be stored as unsigned WORD or DWORD. 

 Var1 and Var2 can be internal memory only. 

 

Example 

After executing BIN command, the BCD data in $0 is converted to a binary value and 

stored in $1 (this is an operation of unsigned 16-bit data). 

 
 

 TODWORD (Convert WORD to DWORD) 

Equation 

Var1 = TODWORD (Var2) 

 

Explanation 

The WORD value in Var2 is converted into DWORD value and stored in Var1. 

 

Note 

 The calculation result can be stored as unsigned WORD or DWORD. 

 Var1 and Var2 can be internal memory only. 
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Example 

After executing TODWORD command, the WORD value in $0 is converted to a D 

WORD value and stored in $1. As it is in DWORD format, it indicates that the value 

has occupied $1 and $2 these two addresses. (this is an operation of unsigned 16-bit 

data). 

 
 

 TOWORD (Convert BYTE to WORD) 

Equation 

Var1 = TOWORD (Var2, Var3) 

 

Explanation 

Convert Var3 number of BYTE data from Var2 to Var3 number of WORD values and 

start storing the result in Var1.The high byte will be filled with 0. 

 

Note 

 The calculation result can be stored as unsigned WORD. 

 Var1 and Var2 can be internal memory only. Var3 can be internal memory or 

constant. 

 The unit of Var2 is WORD. Each WORD of Var2 can be converted to two WORDs. 

 After data conversion is completed, the low and high bit of the converted WORD 

data will be exchanged. 

 

Example 

Assume that the value of $0 is 12, this will convert 12 BYTES (6 WORDS) to 12 WORDS 

starting at $4 and store the result in $10 to $12 (this is an operation of unsigned 

16-bit data). 
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 TOBYTE (Convert WORD to BYTE) 

Equation 

Var1 = TOWORD (Var2, Var3) 

 

Explanation 

Convert Var3 number of WORD data from low-byte of Var2 to BYTE format and store 

the result in Var1. This will discard high-byte of Var2. 

 

Note 

 The calculation result can be stored as unsigned WORD. 

 Var1 and Var2 can be internal memory only. Var3 can be internal memory or 

constant. 

 After data conversion is completed, the low and high bit of the converted WORD 

data will be exchanged. 

 

Example 

Assume that the value of $0 is 12, this will convert 12 WORDS starting from the 

low-byte of $4 and convert these 12 WORDS into 12 BYTES (6 WORDS) and store the 

result in $10 to $16 (this is an operation of unsigned 16-bit data). 
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 SWAP (Swap High-Byte and Low-Byte Data) 

Equation 

SWAP (Var1, Var2, Var3) 

 

Explanation 

Swap high-byte and low-byte of Var3 number of words starting at Var2 and save it in 

memory starting at Var1. 

 

Note 

 The calculation result can be stored as unsigned WORD. 

 Var1 and Var2 can be internal memory only. Var3 can be internal memory or 

constant. 

 

Example 

Swap the high-byte and low-byte of $11 and store the result in $2 (this is an 

operation of unsigned 16-bit data). 

If $11 = 1234H, after executing SWAP command, $2 = 3412H. 

 
 

 XCHG (Exchange Data) 

Equation 

XCHG (Var1, Var2, Var3) 

 

Explanation 

Exchange Var3 number of words of data starting at Var2 with the same number of 

words starting at Var1. 

 

Note 

 The calculation result can be stored as unsigned WORD. 

 Var1 and Var2 can be internal memory only. Var3 can be internal memory or 

constant. 
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 The data of V1 and V2 will be exchanged after executing XCHG command. 

 

Example 

Exchange the data of $11 and $2 (this is an operation of unsigned 16-bit data). 

If $11 = 1234H and $2 = 5678H, $2 = 1234H and $11 = 5678H after executing XCHG 

command. 

 
 

 MAX (Get Maximum Value of a Range of Data) 

Equation 

Var1 = MAX (Var2, Var3) 

 

Explanation 

Get the maximum value from Var2 and Var3 and store the result in Var1. 

 

Note 

 The calculation result can be stored as signed or unsigned WORD and DWORD. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Get the maximum value from $0 and $1 and store the result in $2 (this is an 

operation of unsigned 16-bit data). 

If $0 = 2 and $1 = 10, $2 = 10 after executing MAX command. 
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 MIN (Get Minimum Value of a Range of Data) 

Equation 

Var1 = MIN (Var2, Var3) 

 

Explanation 

Get the minimum value from Var2 and Var3 and store the result in Var1. 

 

Note 

 The calculation result can be stored as signed or unsigned WORD and DWORD. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Get the maximum value from $0 and $1 and store the result in $2 (this is an 

operation of unsigned 16-bit data). 

If $0 = 2 and $1 = 10, $2 = 2 after executing MAX command. 
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 TOHEX (Convert 4 ASCII Code to a Four-Digit Integer in Hexadecimal Format) 

Equation 

Var1 = TOHEX (Var2) 

 

Explanation 

Convert a single ASCII code of Var2 and the next 3 words (4 WORDS) to a hex value 

and stores the result in Var1. 

 

Note 

 The calculation result can be stored as unsigned WORD. 

 Var1 and Var2 can be internal memory only.  

 

Example 

Convert a single ASCII code of $0 and the next 3 words (4 WORDS) to a hex value and 

stores the result in $10 (this is an operation of unsigned 16-bit data). 

$0 = 0034H (ASCII 4), 

$1 = 0033H (ASCII 3), 

$2 = 0036H (ASCII 6), 

$3 = 0038H (ASCII 8), 

$10 = TOHEX ($0)  

After executing TOHEX command, the data in $10 will be converted to 4368H. 
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 TOASC (Convert a Hexidecimal Value Var2 to Four Single ASCII Values (4 

WORDS) Starting at Var1.) 

Equation 

Var1 = TOASC (Var2) 

 

Explanation 

Convert Var2 (1 WORD in hexadecimal format) to the ASCII (4 WORDS) code and store 

the result in Var1. 

 

Note 

 The calculation result can be stored as unsigned WORD. 

 Var1 and Var2 can be internal memory only.  

 

Example 

Convert $0 (1 WORD in hexadecimal format) to the ASCII (4 WORDS) code and store 

the result in $10 (this is an operation of unsigned 16-bit data). 

$0 = 1234H 

$10 = TOASC ($0) 

After executing TOASC command, 

$10=0031H (ASCII 1) 

$11=0032H (ASCII 2) 

$12=0033H (ASCII 3) 

$13=0034H (ASCII 4) 
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 FCNV (Convert Integer to Floating Point Value) 

Equation 

Var1 = FCNV (Var2) 

 

Explanation 

Convert an integer in Var2 to floating point value and store in Var1. 

 

Note 

 The calculation result can be stored as signed DWORD. 

 Var1 can be internal memory only. Var2 can be internal memory or constant. 

 

Example 

Convert an integer in $0 to floating point value and store in $2 (this is an operation 

of signed 32-bit data). 

If $0 = 100, $2 = 100.0 after executing FCNV command. 

 
 

 ICNV (Convert Floating Point Value to Integer) 

Equation 

Var1 = ICNV (Var2) 

 

Explanation 

Convert a floating point value in Var2 to an integer and store in Var1. 

 

Note 

 The calculation result can be stored as signed DWORD. 

 Var1 can be internal memory only. Var2 can be internal memory or constant. 

 

Example 

Convert a floating point value in $0 to an integer and store in $2 (this is an operation 

of signed 32-bit data). 
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If $0 = 100.0, $2 = 100 after executing ICNV command. 

 
 

 

3.14.3.5 Comparison 

 

There are various kinds of commands for comparison. For more details, please refer to 

the following sections. 

 IF…THEN GOTO … 

Equation 

IF expression THEN GOTO LABEL identifier 

 

Explanation 

If the command of expression is true, then it will go to LABEL identifier and perform 

the program. 

 

Note 

 Please refer to the following Comparison command table for the command of 

expression. 

 

Example 

If the value in $2 is equal to or greater than 10, it will go to LABEL 1 and perform the 

program. 
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Equation 

IFB expression THEN GOTO LABEL identifier 

 

Explanation 

If the command of expression is true, then it will go to LABEL identifier and perform 

the program (for PLC register). 

 

Note 

 Please refer to the following Comparison command table for the command of 

expression. 

 

Example 

If 1@M0 is ON, it will go to LABEL 1 and perform the program. 

 
 

Equation 

IF expression THEN CALL sub-macro 

Explanation 

If the command of expression is true, then it will call sub-macro and perform the 

program. 
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Note 

 Please refer to the following Comparison command table for the command of 

expression. 

 

Example 

If the value in $2 is equal to 10, it will call sub-macro 1 and perform the program. 

 
 

 

Equation Explanation Note 

Var1 == Var2 Var1 is equal to Var2  

Var1 != Var2 Var1 is not equal to Var2 

Var1 > Var2 Var1 is greater than Var2 

Var1 >= Var2 Var1is equal to or greater than Var2 

Var1 < Var2 Var1 is smaller than Var2 

Var1<= Var2 Var1 is equal to or smaller than Var2 

Var1 && Var2 == 0 

Perform AND command on V1 and V2 

and the result of AND operation is 

equal to 0. 

Var1 && Var2 != 0 

Perform AND command on V1 and V2 

and the result of AND operation is not 

equal to 0. 

Var1 and Var2 can be 

internal memory or 

constant. 

Var1== ON Var1 is ON 

Var1== OFF Var1 is OFF 

Var1 can be the 

controller address or 

internal memory (BIT) 

Table 3-14-3 Comparison command table 
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 IF…ELSEIF…ELSE…ENDIF 

Equation 

IF expression1 

Statement1 

ELSEIF expression2 

Statement2 

ELSE 

Statement3 

ENDIF 

 

Explanation 

This is logical determination from multiple conditions. If expression1 is true, 

Statement1 will be executed. If expression1 is false, it will run expression2. If 

expression2 is true, Stemenent2 will be executed. If both expression1 and 

expression2 are false, Statement3 will be executed. ENDIF should be placed in the 

end of the IF comparison command 

 

Note 

 Please refer to the Comparison command table on previous page 3-343 for the 

command of expression. 

 

Example 

 

IF $0 == 0 

$10 = 0 

ELSEIF $0 ==1 

$10 = 1 

ELSE 

$10 = 2 

ENDIF 

If $0 is equal to 0,  

$10 is equal to 0; 

If $0 is equal to 1, not equal to 0,  

$10 is equal to 1; 

If $0 is equal to neither 0 nor 1,， 

$10 is equal to 2. 
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 FCMP (Floating Point Value Comparison) 

Equation 

Var1 = FCMP (Var2, Var3) 

 

Explanation 

Compare the floating point value in Var2 and Var3 and store the result in Var1. 

The comparison methods include: 

Var1=0, Var2 = Var3 

Var1=1, Var2 > Var3 

Var1=2, Var2 < Var3 

 

Note 

 The calculation result can be stored as signed DWORD. 

 Var1 can be internal memory only. Var2 and Var3 can be internal memory or 

constant. 

 

Example 

Compare the floating point value in $0 and $2 and store the result in $4 (this is an 

operation of signed 32-bit data). 

 
 

 

 

 

 

 

 

 

 

 

 

 



Chapter 3 Creating and Editing Screens HMi 

3-348  

3.14.3.6 Flow Control 

 

 

There are various kinds of commands for flow control. For more details, please refer to 

the following sections. 

 

 GOTO (Unconditionally Go To a Specific Label. GOTO command will jump to 

designated label like Label Var1 unconditionally) 

Equation 

GOTO LABEL Var1 

 

Explanation 

Go to the internal designated Label Var1 in the program unconditionally. 

 

Note 

 Var1 can be constant only.  

 

Example 

Go to the position of designated Label 1 and continue to execute the program 

unconditionally. 
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 LABEL (Label such as Label Var1) 

Equation 

LABEL Var1 

 

Explanation 

GOTO statement shifts the program execution to the position of LABEL 

unconditionally. 

 

Note 

 Var1 can be constant only.  

 A label value is unique per macro and it cannot be used more then once in a 

single macro. The user can only use LABEL 1 once per individual macro. 

 

Example 

LABEL 1. 

 
 

 CALL...RET (Call Sub-Macro Program) 

Equation 

CALL Var1…RET 

 

Explanation 

“CALL Var1” is to call sub-macro Var1. Var1 represents the sub-macro number.  

“RET” is to exit sub-macro Var1. It should be placed in the end of the Var1 sub-macro 

command. 

 

Note 

 The sub-macro number could be 001 – 512.  

 Var1 can be internal memory or constant. 
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Example 
CALL

RET

Main
Macro

Sub-Macro
A1

 
The rights of macro control will be transferred to sub-macro when executing CALL 

Var1 command. After CALL Var1 command is executed and completed, Var1 needs 

to return through RET command. RET command will transfer the rights of macro 

control to the next command of CALL command. The sub-macro number could be 1 

~ 512. Regarding the comment name of the sub-macro, the user can name it freely. 

In the sub-macro program, the users also can CALL another sub-macro but the levels 

for CALL sub-macro should be less than 6 levels due to memory limit and also for 

avoiding unexpected error. 

 

 FOR…NEXT (Program Loop) 

Equation 

FOR Var1 Statement NEXT  

 

Explanation 

It is for nested loops. ”FOR” is the start of the loop and “NEXT” is the end of the loop. 

When this command is executed, the number of Var1 Statement will be executed 

continuously. The users can change the Var1 value through command, but the 

number of times cannot be changed. 

 

Note 

 The nested loop can be up to 3 levels max.  

 Var1 can be internal memory or constant. 

 Statement is the combination of a section of macro commands and also can be 

within the nested loop. 

 

Example 

 If $0=0, after the operation, the result is $0 = 10 

 END (End the Macro) 

Equation 
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Statemenets1 END Statements2  

 

Explanation 

End command is used to end the macro program and all statements after the END 

command will not be executed. If this command is in a main macro then the program 

will go to the first line again and begin execution, if this command is in a sub-macro 

then the sub-macro will end and the program will return to the previous program. 

 

Note 

 Statement is the combination of a section of macro commands and also can be 

within the nested loop. 

 If there is END command in sub-macro, the program ends. If the user wants to 

return to the previous macro program, please user RET command. 

 

Example 

 

After the operation, the result is $1 = 11, not $1 = 12 as the END command has 

ended the macro program. 

 

 

3.14.3.7 Bit Setting 

 

There are various kinds of commands for Bit setting. For more details, please refer to 

the following sections. 

 BITON (Set Specific Bit to be ON) 

Equation 

BITON Var1 

 

Explanation 

This command sets Var1 bit to be ON. 

Note 

 Var1 can be the controller address or internal memory (BIT). 

 

Example 
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Set the 5th Bit within the internal memory $0 to be ON. 

If $0 = 0000000000000000, after the operation, $0 = 0000000000010000 

 
 

 BITOFF (Set Specific Bit to be OFF) 

Equation 

BITOFF Var1 

 

Explanation 

This command sets Var1 bit to be OFF. 

 

Note 

 Var1 can be the controller address or internal memory (BIT). 

 

Example 

Set the 5th Bit within the internal memory $0 to be OFF. 

If $0 = 1111111111111111, after the operation, $0 = 1111111111101111 

 

 BITNOT (Set Specific Bit to be Inversed. ON to OFF, OFF to ON) 

Equation 

BITNOT Var1 
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Explanation 

This command sets the specific Bit to be inversed. ON to OFF, OFF to ON 

 

Note 

 Var1 can be the controller address or internal memory (BIT). 

 

Example 

Set the 5th Bit within the internal memory $0 to be inversed. 

If $0 = 1111111111111111, after the operation, $0 = 1111111111101111 

 

 

 GETB (Get Bit value) 

Equation 

Var1 = GETB Var2 

 

Explanation 

This command gets Var2 Bit value and store in Var1 

 

Note 

 Var1 and Var2 can be the controller address or internal memory (BIT). 

 

Example 

Get the 5th Bit value within the internal memory $0 and store it to the 5th Bit value 

within the internal memory $1. 

If $0 = 1111111111111111 and $1 = 0000000000000000, after the operation, $1 

= 0000000000010000. 
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3.14.3.8 Communication 

 

There are various kinds of commands for communication. For more details, please 

refer to the following sections. 

 INITCOM (Initial setup COM port) 

Equation 

Var1 = INITCOM (Var2) 

 

Explanation 

This command uses initial setup COM port to start communication and set 

communication protocol. After the user sets each COM port, this command starts 

communication and stores the result in Var1. 

 

Note 

 Var1: Response value after communication 

1: Completed normally 

0: Failed 

 For the settings of Var2, please refer to the following table of Var2 Settings in 

INITCOM (Communication Protocol). 
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Var2 Settings in INITCOM (Communication Protocol) 

Item Type Code Note 

COM1 0 

COM2 1 COM Port 

COM3 2 

RS232 0 

RS422 1 
Communication 

Interface 
RS485 2 

7 Bits 0 
Data Bit 

8 Bits 1 

None 0 

Odd 1 Parity Bit 

Even 2 

1 Bits 0 
Stop Bit 

2 Bits 1 

300 0 

600 1 

900 2 

1200 3 

2400 4 

4800 5 

9600 6 

14400 7 

19200 8 

28800 9 

38400 10 

57600 11 

Baud Rate 

115200 12 

 

No Flow Control 0 

CTS RTS Flow 

Control 
1 

DTR DSR Flow 

Control 
2 

Flow Control 

Xon Xoff Flow 

Control 
3 

Please refer to the 

following descriptions. 
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No Flow Control: Flow control function is disabled. 

Flow Control: The transmission speed and communication validity are enhanced during 

communication due to new transmission technology, such as compress immediately, 

debug…etc. But the new technology also makes the transmission speed between HMi 

and PC take longer than the actual transmission speed. Therefore, ensure the data 

security and transmit complete data between computer and HMi, when transmitting data 

through serial communication port, the flow control is necessary. 

To make sure that data transmit between computer and HMi is completed, the user can 

use Flow Control functions. 

CTS / RTS: Flow control for hardware. It uses handshaking signal to control receiving 

and sending data. The control is achieved via internal modem or external modem 

that connects to HMi by a connecting cable. 

DSR / DTR: Flow control for hardware also. It is used when PC and HMi are connected 

directly by a cable. 

XON / XOFF: Flow control for software. Only used for 2400bps modem. The control 

method is to generate control code by software and add it in the transmission data. 

 

Example 

When the communication protocol is set to COM1, RS232, 7, Even, 1, 9600, and No 

Flow Control, if the response value is stored in $0, the user’s screen will look like the 

following figure.  

 
 

 ADDSUM (Use Addition to Calculate Checksum) 

Equation 

Var1 = ADDSUM (Var2, Var3) 

 

Explanation 

This command uses addition to calculate checksum. Var1 is the value after 

calculation, Var2 is the starting address for calculation and Var3 is data length. 
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Note 

 The calculation result can be stored as unsigned WORD. 

 Var1 and Var2 can be internal memory only. Var3 can be internal memory or 

constant. 

 

Example 

The starting address is for calculation $0, the data length is set to 2. After the 

communication, the calculated checksum through addition calculation is stored in 

$2 (this is an operation of unsigned 16-bit data). 

 
 

 XORSUM (Use XOR to Calculate Checksum) 

Equation 

Var1 = XORSUM (Var2, Var3) 

 

Explanation 

This command uses XOR to calculate checksum. Var1 is the value after calculation, 

Var2 is the starting address for calculation and Var3 is data length. 

 

Note 

 The calculation result can be stored as unsigned WORD. 

 Var1 and Var2 can be internal memory only. Var3 can be internal memory or 

constant. 

 

Example 

The starting address is for calculation $0, the data length is set to 2. After the 

communication, the calculated checksum through XOR calculation is stored in $2 

(this is an operation of unsigned 16-bit data). 
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 PUTCHARS (Output Characters by COM Port) 

Equation 

Var1 = PUTCHARS (Var2, Var3, Var4) 

 

Explanation 

This command outputs characters by COM port. Var1 is the response value after the 

communication, Var2 is the starting address of transmission data, Var3 is the data 

length, and Var4 is the allowance communication time (unit is ms). The result will be 

stored in Var1. 

 

Note 

 Var1: Response value after communication 

1: Completed normally 

0: Failed 

 Var1 and Var2 can be internal memory only. Var3 and Var4 can be internal 

memory or constant. 

 

Example 

Output three consecutive WORD data starting from $1 and store the result in $0. 
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 GETCHARS (Get Characters by COM Port) 

Equation 

Var1 = GETCHARS (Var2, Var3, Var4) 

 

Explanation 

This command gets characters by COM port. Var1 is the response value after the 

communication, Var2 is the starting address of transmission data, Var3 is the data 

length, and Var4 is the allowance communication time (unit is ms). The result will be 

stored in Var1. 

 

Note 

 Var1: Response value after communication 

1: Completed normally 

0: Failed 

 Var1 and Var2 can be internal memory only. Var3 and Var4 can be internal 

memory or constant. 

 

Example 

Get three consecutive WORD data starting from $1 and store the result in $0. 

 
 

 SELECTCOM (Select COM Port) 

Equation 

SELECTCOM (Var1) 

 

Explanation 

This command is used to select COM port. When not connecting to the external 

controller (set PLC to NULL) in Options > Configuration in HMiSoft program, the 

user can use two COM ports (0:COM1, 1:COM2, 3:COM3 (for some models only)) at 

the same time.  
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Note 

 Var1 can be constant only.  

 All communication commands will be processed via the COM port that the user 

selects after executing this command. Different macros will not support each 

other or have any interference. 

 

Example 

Select COM1 port. 

 
 

 CLEARCOMBUFFER (Clear the COM Port Buffer) 

Equation 

CLEARCOMBUFFER (Var1, Var2) 

 

Explanation 

This command is used to clear COM port buffer.  

Var1 is the number of communication port. It represents as constant 0(COM1), 

1(COM2) or 2(COM3). 

Var2 is the type of buffer area. It represents as constant 0 (receiving buffer area) or 1 

(sending buffer area). 

 

Note 

 Var1 and Var2 can be constant only.  

 

Example 

Clear the sending buffer area of COM2. 
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 CHRCHKSUM (Calculate Data Length of Texts or Characters and Checksum) 

Equation 

Var1 = CHRCHKSUM (“Var2”, Var3, Var4) 

 

Explanation 

This command is used to calculate the data length of texts or characters and 

checksum. 

Var1 is the internal memory address that stores the text length of Var2. 

Var2 is the string of text. 

Var3 is the internal memory address that stores the checksum of Var2. 

Var4 is the data length of the checksum that stores in Var3. 1 represents Byte and 2 

represents Word. 

Operation of checksum: 

Convert format of each data characters to ASCII code and add them up. For example, 

convert ’2’ to ASCII code ‘31H’, convert ’4’ to ASCII code ‘34H’ and the checksum is 

31Hex + 34Hex = 65H. 

 

Note 

 Var1 and Var3 can be internal memory only. Var2 can be a string of texts only. 

Var4 can be constant only.  

 

Example 

Calculate the data length of "24" and checksum 

$0 = CHRCHKSUM("24", $10, 2) 

After the above operation, 4 is stored in $0 and 4 represents the data length is 2 

WORDS. The checksum stored in $10 is 65H. 
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 LOCKCOM / UNLOCKCOM (Lock COM Port / Unlock COM Port) 

Equation 

Lock COM Port 

Var1 = LOCKCOM (Var2, Var3) 

 

Unlock COM Port 

Var1 = UNLOCKCOM (Var2) 

 

Explanation 

LOCKCOM command locks COM port. Var1 is the response value after the 

communication, Var2 is the COM port and represents as constant 0(COM1), 1(COM2) 

or 2(COM3). Var3 is the communication time out time (unit is ms). When the 

specified communication time out time is reached, if the COM port cannot be locked, 

an error will occur. When Var3 is set to 0, it indicates that HMi will continuously wait 

without time limit. 

UNLOCKCOM command unlocks COM port. Var2 is the COM port and represents as 

constant 0(COM1), 1(COM2) or 2(COM3).  

 

Note 

 Var1: Response value after communication 

1: Completed normally 

0: Failed 

 Var1 can be internal memory only. Var2 and Var3 can be constant only. 

 When the communication commands are used in different macros, such as 

Screen Cycle Macro, Clock Macro, Background Macro, Before/After Execute 

Macro, ON/OFF Macro, if LOCKCOM and UNLOCKCOM commands are not used, 

the different macros may have interferences and causes the error result. To 

ensure the correct communication and not to interrupt the communication at 

the same time, it is recommended to use these two commands. 
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 When Var3 is set to 0, it indicates that LOCKCOM command will be executed 

twice and HMi will continuously wait without time limit. At this time, HMi may 

have no response at all. 

Example 

 
 

Explanation of LOCKCOM Command 

 

 

 

 

 

 

 

In the above macro commands, the communication commands are all used. When 

Background Macro is executed first, COM1 will be locked. At this time, the 

execution of ON Macro and Screen Cycle Macro commands will stop when 

reaching LUCKCOM (0,0) this command. After UNLOCKCOM command in 

Background Macro is executed, the execution of ON Macro and Screen Cycle 

Macro command will be activated again. This can avoid the interference and 

incorrect calculation or communication result.  

 

Explanation of UNLOCKCOM Command 

 

 

 

 

 

 

If the macro command is set as shown as the above, the user can lock the COM 

port and transmission data by using Background Macro, and unlock the COM port 

by using ON Macro. It means that the actions of locking COM port and unlocking 

COM port can be separated. 

 

 

 

 

Background 

Macro 

 

$0 = LOCKCOM(0,0) 

$1 = PUTCHARS($1, 3, 

300) 

On 

Macro 

 

$0 = LOCKCOM(0,0) 

$1 = GETCHARS($1, 

3, 300) 

Screen Cycle 

Macro 

 

$0 = LOCKCOM(0,0) 

$1 = PUTCHARS($1, 

3, 300) 

Background 

Macro 

 

$0 = LOCKCOM(0,0) 

$1 = PUTCHARS($1, 3, 300) 

On 

Macro 

 

UNLOCKCOM(0) 
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 STATIONON (Station ON) 

Equation 

STATIONON (Var1, Var2) 

 

Explanation 

This command is used to enable the Var2 number of station of Var1 COM port. 

Var1 represents as constant 0(COM1), 1(COM2) or 2(COM3, for some models only). 

 

Note 

 Var1 and Var2 can be internal memory or constant.  

 This macro command cannot be used When Communication Interrupt times 

then ignore box is checked (Options > Configuration > COM Port). 

 

Example 

Enable the first station of COM1 port. 

 
 

 STATIONOFF (Station OFF) 

Equation 

STATIONOFF (Var1, Var2) 

 

Explanation 

This command is used to disable the Var2 number of station of Var1 COM port. 

Var1 represents as constant 0(COM1), 1(COM2) or 2(COM3, for some models only). 

 

Note 

 Var1 and Var2 can be internal memory or constant.  

 This macro command cannot be used When Communication Interrupt times 

then ignore box is checked (Options > Configuration > COM Port). 
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Example 

Disable the first station of COM1 port. 

 

 

 

3.14.3.9 Drawing 

 

There are various kinds of drawing commands. For more details, please refer to the 

following sections. 

 RECTANGLE (Draw a Rectangle) 

Equation 

RECTANGLE (Var1) 

 

Explanation 

This command is used to draw a rectangle on the screen. 

Var1 is the upper-left X-coordinate 

Var1+1 is the upper-left Y-coordinate 

Var1+2 is the width of the rectangle 

Var1+3 is the height of the rectangle 

Var1+4 is the color of the rectangle  

 

Note 

 Var1 can be internal memory only.  
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Example 

When the Screen Open Macro command is set as  

 

and the Screen Cycle Macro is set as 

 

the user’s screen will look like the figure shown below. 

 
 

 LINE (Draw a Line) 

Equation 

LINE (Var1) 

 

Explanation 

This command is used to draw a line on the screen. 

Var1 is the starting X-coordinate 

Var1+1 is the starting Y-coordinate 

Var1+2 is the ending X-coordinate 

Var1+3 is the ending Y-coordinate 

Var1+4 is the width of the line 

Var1+5 is the color of the line 

 

Note 

 Var1 can be internal memory only.  
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Example 

When the Screen Open Macro command is set as  

 
and the Screen Cycle Macro is set as 

 

the user’s screen will look like the figure shown below. 

 

 

 POINT (Draw a Point) 

Equation 

POINT (Var1) 

 

Explanation 

This command is used to draw a point on the screen. 

Var1 is the X-coordinate 

Var1+1 is the Y-coordinate 

Var1+2 is the color of the point 

 

Note 

 Var1 can be internal memory only.  
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Example 

When the Screen Open Macro command is set as  

 
 

and the Screen Cycle Macro is set as 

 

the user’s screen will look like the figure shown below. 

 

 

 CIRCLE (Draw an Ellipse) 

Equation 

RECTANGLE (Var1) 

 

Explanation 

This command is used to draw an ellipse on the screen. 

Var1 is the X-coordinate of the center of the ellipse 

Var1+1 is the Y-coordinate of the center of the ellipse 

Var1+2 is the length of the ellipse 

Var1+3 is the width of the ellipse 

Var1+4 is the color of the ellipse  

 

Note 

 Var1 can be internal memory only.  
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Example 

When the Screen Open Macro command is set as  

 

and the Screen Cycle Macro is set as 

 

 

the user’s screen will look like the figure shown below. 

 

 

 

3.14.3.10 Others 

 

For more details of other macro commands, please refer to the following sections. 

 Time Tick (Get the Time from System Startup to Present) 

Equation 
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Var1=TIMETICK 

 

Explanation 

This command is used to get the time from system startup to present and save into 

the specified address. The time unit is ms. 

 

Note 

 Var1 can be internal memory only.  

 

Example 

Get the time from system startup to present and save into $0. 

 
 

 GETLASTERROR (Get the Last Error Value) 

Equation 

Var1 = GETLASTERROR 

 

Explanation 

This command is used to get last error value. If there is no error, the result of 

GETLASTERROR will be 0. Even if each Macro is executed simultaneously, the error 

messages will not affect the macro. For more details on error code information, refer 

to section 3.14.4 Macro Error Messages on page 3-377. 

 

Note 

 Var1 can be internal memory only.  

 

Example 

Get the last error value and save into $0. 
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 # (Comment) 

Equation 

# Statement 

 

Explanation 

This command is used to insert macro descriptions and make the macro readable. 

Using this command will not affect the macro function. The user only need to put # 

symbol in front of the equation and the macro will become readable. To change the 

comment to be back to the equation, just remove the # symbol. 

 

Note 

 Statement can be a string of texts or macro commands.  

 

Example 

When the comment is a string of texts:  

When the comment is a string of macro commands:  

 

 Delay (System Delay) 

Equation 

Delay (Var1) 

 

Explanation 

This command is used to delay the actions between the current line before the delay 

macro and the line after it. Please note that too long delay time may result in slow 
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response of HMi. The unit of delayed time is ms. 

 

Note 

 Var1 can be internal memory or constant.  

 After Delay command is executed, HMi will stop the operation. The operation 

will resume after the delay time has elapsed (expired). 

 

Example 

Delay two seconds. 

 

 

 

 

 GETSYSTEMTIME (Get System Time) 

Equation 

Var1 = GETSYSTEMTIME 

 

Explanation 

This command is used to get the system time. Var1 is the starting address of 

continuous 7Words in the internal memory address. 

Var1 represents Year 

Var1 + 1 represents Month 

Var1 + 2 represents Date 

Var1 + 3 represents Week 

Var1 + 4 represents Hour 

Var1 + 5 represents Minute 

Var1 + 6 represents Second 

 

Note 

 Var1 can be internal memory or constant.  

 

Example 

Now the system time is 2009/02/27 FRI 13:20:06.  

This command gets the current system time, and stores it in $0 to $6. 

The user’s screen will look like the figure shown as below. 
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 SETSYSTEMTIME (Set System Time) 

Equation 

SETSYSTEMTIME (VAR1) 

 

Explanation 

This command is used to set the system time. Var1 is the starting address of 

continuous 7Words in the internal memory address. 

Var1 represents Year 

Var1 + 1 represents Month 

Var1 + 2 represents Date 

Var1 + 3 represents Week 

Var1 + 4 represents Hour 

Var1 + 5 represents Minute 

Var1 + 6 represents Second 

 

Note 

 Var1 can be internal memory or constant.  

 The input number should be a valid number or the system will not allow the 
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user to set the system time. For example, if a number of 8 is entered into the 

address of Var1+3 which represents Week, the system will determine the 

number of 8 is an invalid number and does not allow the user to change it. This 

is because the valid number for this address is from 1 to 7 (Monday to Sunday). 

 

Example 

Suppose that now the system time is set to 2009/02/27 FRI 13:25:34. 

The user’s screen will look like the figure shown as below. 

 

 

 

 

 

 

 

 

 

 GETHISTORY (Get History Data) 

Equation 

Var1 = GETHISTORY (Var2, Var3, Var4, Var5, Var6) 

 

Explanation 

This command is used to get the history data.  

Var1 is the internal memory address where the data length is stored. 

Var2 is the internal memory, constant, the buffer number of history buffer area. 

Var3 is the internal memory, constant, the starting address for sampling. 

Var4 is the internal memory, constant, the points for reading. 

Var5 is the internal memory, external controller address where the data is stored. 

Var6 is the internal memory, constant, the data type for reading. 

 

Note 

 Var1 can be internal memory only. 

 Var2, Var3 and Var4 can be internal memory or constant. 

 Var5 can be the external controller address or internal memory. 
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 Var6 can be internal memory or constant. 

0: Data, 1: Time, 2: Time and Data 

 

Example 

When the equation is set to $0 = GETHISTORY ($1, $2, $3, $4, $5), HMi can get the 

history data.  

 

 

 

 

 

 EXPORT (Output Data) 

Equation 

EXPORT (Var1) 

 

Explanation 

This command is used to output the data to the external interface. The function of 

EXPORT macro command is the same as the function of Report List button element. 

Var1 represents the output interface: 

0: SD card 

1: USB disk 

2: Printer 

 

Note 

 Var1 can be internal memory only. 

 

Example 
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When the equation is set to EXPORT(0), HMi can export the data to a SD card. 
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3.14.4 Macro Error Messages 

When compiling, it will shows errors in output window for user to find easily. The users can 

read error messages by macro. Once there is an error and the users execute a correct 

command before reading error messages, the error message will be overwritten. When 

executing each macro, each Macro error message will not be influenced by other macros.  

Error Messages While Editing 

 Code – 100 LABEL cannot be found 

There is no such LABEL that GOTO designates. 

 Code – 101 Recursion occurs 

This error message usually shows in sub-macro. The function of a sub-macro to call is 

called recursion whether the HMi calls it directly or not. Basically, recursion cannot be 

adopted for a sub-macro. You can use GOTO or FOR (infinite times) to replace it. 

 Code – 102 More than 10 nested FOR is used  

This error message statement is to warn the user not to use more than 10 nested FOR 

commands. The purpose is to avoid insufficient memory. The users can use GOTO or 

IF to replace it.  

 Code – 103 Sub-macro does not exist 

This error message means that there is no sub-macro in the program. For example, 

CALL 5 means CALL sub-macro 5. If the user does not edit sub-macro 5 in the program, 

this error message will display to warn the users. The purpose is to warn the users to 

be more careful when editing (reduce input error or avoid forgetting to edit the 

corresponding sub-macro) and prevent unexpected error 

 Code – 104 Number of NEXT is less than the number of FOR 

Numbers of NEXT and FOR should match. This error code is used to remind the user to 

find out the missing NEXT.  

 Code – 105 Number of FOR is less than the number of NEXT 

Numbers of FOR and NEXT should match. This error code is used to remind the user if 

there is any missing FOR.  

 Code – 106 Repeated LABEL 

This error message means that there are repeated LABELs in the same Macro. The 

program will be confusing with that. This may be caused by carelessness (an input 

error or forgetting to edit the corresponding sub-macro), and the user will get an error 

message during editing to help the user avoid unexpected error.  
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 Code – 107 There is RET in Macro 

This error message means that there is RET command in Macro. The RET command 

should be used for sub-macro to return program. But in Macro, it should use END not 

RET.  

 

HMi Macro Error Messages 

The users can read error messages by macro files. Once there is an error and the users 

execute a correct command before reading error messages, the error message will be 

overwritten. When executing each macro, each Macro error message will not be influenced 

by other macros.  

 Code – 10 GOTO Error 

This message means that there is a GOTO error in the macro.  

 Code – 11 Stack Overflow 

This message means that the stack in the macro is full. This may be caused by using 

too many sub-macros or executing different macros at the same time. This message 

appears to help avoid insufficient memory.  

 Code – 12 Empty Sub-macro 

This is a CALL sub-macro error. The sub-macro that is called should not be an empty 

sub-macro. This message is to avoid unexpected errors.  

 Code – 13 Data Read Error 

This is a data read error. Sometimes this may be caused by a memory data error, but 

most of the time it is an external controller data read error. 

 Code – 14 Data Write Error 

This is a data write error. Sometimes this may be caused by a memory data error, but 

most of the time it is an external controller data write error. 

 Code – 15 Divisor is 0 

This error message means that the devisor is 0 when performing a division operation. 
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Chapter 4 Examples 

4.1 How to Create a 16bits Recipe Data 

Create a new project first by pressing  or click File > New 

 

Enter the project name, screen name, screen No, and select Base Port controller or printer. 

Then, click OK.  

 
Click Options > Recipe, to open Recipe Setup dialog box. Enable the recipe function and 

set the non-volatile area to HMi. In this example, the Length is set to 5(ingredients), Group 

is set to 3(recipes) and Address is set to 1@D100. After pressing Input button, the user’s 
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screen will appear like the figure shown below. At this time fill in the chart with data for the 

recipes. 

 

Then, press OK button to complete the Recipe settings.  

 

Next, click Options > Configuration and select Control Block tab. To control the read and 

write operation of recipes, in this example, Control Address is set to 1@D0 and the Length 

is set to 8. After complete the above settings, the user’s screen will look like the figure 

shown below. 

 

Then, press OK button to complete the Control Block settings.  
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On a screen of HMi, create Numeric Entry elements to display recipe buffer (RCP0~RCP4), 

recipe table (RCP5~RCP19) and recipe read / write addresses (1@D100~1@D104). Next 

add the Recipe Number Designation Register (RCPNO) in a Numeric Entry. Finally add two 

set constant buttons, one to set the Recipe Write Register (1@D5) = 2 and one to set the 

Recipe Read Register (1@D5) = 4. When complete the screen should look like the figure 

below.  

 
Perform Compile operation and download the screen data into HMI.  

 

Once running the screen will look like the figure shown below. Since the default value of 

RCPNO (Recipe Number Select) is 1, the recipe buffer RCP0~RCP4 will display the 1st 4 

number of recipe data from RCP5~RCP9. At this time, the recipe data has not been written 

into PLC address 1@D100~1@D104. Therefore, the display values of 1@D100~1@D104 

are all 0. 
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Press Write button (HMi  ELC) on the screen and HMi will write the 1st recipe data into 

PLC address 1@D100~1@D104. At this time, the display value of 1@D100~1@D104 will 

become 1 shown in the figure below. 

 
 

Set RCPNO = 2 and the display value of Recipe buffer RCP0~RCP4 will change to 2.  
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Press Read button on the screen and HMi will read the recipe data in PLC and save the data 

in the 2nd recipe.  

 
Then, the values of 2nd recipe will be changed. 
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4.2 How to Create a 32bits Recipe Data 

Create a new project first by pressing  or click File > New 

 

Enter the project name, screen name, screen No, and select Base Port controller or printer. 

Then, click OK.  

 

 

Click Options > 32bits recipe, to open the 32bits Recipe Setup dialog box. In this example, 

two recipe tables are created, Click New the write address is set to 1@D100 and the 

non-volatile area is set to HMi. In the 1st recipe table, set the Length to 5 and set the Group 

to 5. In the 2nd recipe table, set the Length to 5 and set the Group to 3.  

Then press the OK button, the user’s screen will look like the figure shown below.  

 

 



HMi Chapter 4 Examples 

 

Revision Dec, 2010   4-7 

 

 

 

 

Then, exit  

 

Next, click Options > Configuration, select Control Block tab. To control the read and 

write operation of recipes, in this example, Control Address is set to 1@D0 and the Length 

is set to 8. After complete the above settings, the user’s screen will look like the figure 

shown below. 

Enable 

New 

Exit 
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Then, press OK button to complete the Control Block settings.  

 

 

On a screen of HMi, create Numeric Entry elements to display recipe buffer (RCP0~RCP4), 

recipe table (RCP5~RCP19) and recipe read / write addresses (1@D100~1@D108) Note 

this is a 32bit recipe there for the Numeric Entries must be configured with a Data 

length of Double Word to display correctly. Next add the Recipe Number Designation 

Register (RCPNO) and the Recipe Group Designation Register (RCPG) in Numeric Entries. 

Finally add two set constant buttons, one to set the Recipe Write Register (1@D5) = 2 and 

one to set the Recipe Read Register (1@D5) = 4. When complete the screen should look like 

the figure below.  
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Perform Compile operation and download the screen data into HMI.  

 

Once running the screen will look like the figure shown below. Since the default value of 

RCPG is 0 and RCPNO is 1, the value of history buffer RCP0~RCP4 and recipe table 

RCP5~RCP19 will be 0. The recipe data has not been written into PLC address 

1@D100~1@D108. Therefore, the display values of 1@D100~1@D108 are all 0. 

 

Set RCPG=2, the recipe table RCP5~RCP19 will display the data of the 2nd group of the 
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recipes and the history buffer RCP0~RCP4 will display the data of the 1st group of the 

recipes as Shown in the figure below.  

 
At this time, the recipe data has not been written into PLC addresses 1@D100~1@D108, 

therefore, the display value will still be 0.  

 

Press Write button (HMi  ELC) on the screen and HMi will write the 1st recipe data into 

PLC address 1@D100~1@D104. At this time, the display value of 1@D100~1@D104 will 

become 111 shown in the figure below. 
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Set RCPNO = 2, the 2nd group of recipe data will be displayed in RCP0~RCP4 as shown as 

the figure below.  

 
Press Read button on the screen and HMi will read the recipe data in PLC and save the data 

in the 2nd group of recipe data.  
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Then, the value of 2nd group of recipe data will be changed. 
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4.3 How to Use Windows Excel CSV File 

There are two kinds of format accepted by recipe editor. One is RCP file and the other is CSV file. 

RCP file can be opened and edited in HMi Soft software program only. The CSV file can be 

created and edited in Microsoft Windows Excel. The following section describes how to create 

and edit the CSV file in Microsoft Windows Excel environment. 

 

After finishing the editing of the recipe data, the user can save the recipe file as Windows Excel 

CSV file. 

 
 

16bits Recipe 

When the user opens a 16bits recipe CSV file in Microsoft Windows Excel environment, the first 

row shows the set value of data length and group, and the other rows shows the recipe data 

value. In this example, the Length is set to 5 and the Group is set to 3, i.e. it is a 5 x 3 recipe 

data.  
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32bits Recipe 

After finishing the editing of the recipe data, the user can save the recipe file as Windows Excel 

CSV file. 
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When the user opens a 32bits recipe CSV file in Microsoft Windows Excel environment, the first 

row shows the version of 32bits recipe data, i.e. RCP32-1.0.  

Save 
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In the figure above, the left side shows Microsoft Windows Excel and the right side shows the 

32bits recipe setup dialog box in HMiSoft. The 1st group of the recipes will be located in the 

upper area and the 2nd group of the recipes will be located in the lower area. Please note that 

there must be a blank row between the data of two recipe table. 
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Excel Quick reference. 

Column of Excel File Setting Value of Recipe Data 

A Length 

B Group 

C 

Integral Digits (The digit number will be a real 

decimal number only when the data format is selected as 

Floating.) 

D 

Fractional Digits (The digit number will be a real 

decimal number only when the data format is selected as 

Floating.) 

E 

Data format: 

2：Signed Decimal 

3：Unsigned Decimal 

6：Floating 
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4.4 How to Use Multi-Language Function 

Create a new project first by pressing  or click File > New 

 
Enter the project name, screen name, screen No, and select Base Port controller or printer. 

Then, click OK.  

 

 

 

 

 

Next, click Options > Configuration, select Control Block tab. To control the read and 

write operation of recipes, in this example, Control Address is set to 1@D0 and the Length 

is set to 8. After complete the above settings, the user’s screen will look like the figure 

shown below. 
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Then, press OK button to complete the Control Block settings.  

 

Next, click Options > Configuration, select Other tab (refer to the figure below). 
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Press Insert button to Add English, Spanish, and German. The setting values are 1, 2 and 3 

for each language respectively. 

     

 

In this example, the default setting is set to English and all the language settings will also 

be shown in the window.  

 
Then, press OK button to complete the settings. 
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Create a Text element on the screen. Then, set the display text of Text element in different 

languages. 

     
The user can define the font, text size and text color by preference. 

 

 

Next Create Three Set Constant buttons, one for each language. English = 1 Spanish = 2 

and German = 3 

 

 

 

 

In property setting of the Increment button element, double click the tabs and enter the 

text in different languages. 
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After complete the above settings, the user’s screen will look like the figure below. 

 
Select the Compile command and perform Compile operation and download the data into 

HMi.  

 

Then, user’s HMi screen will look like the followings. The default display language is 

English. The text of the Text element is changed to a different language by pressing the 

buttons. 
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4.5 How to Use Flash Transfer Function 

Flash Transfer is a program is used to read the data of Historical Trend Graph, Historical 

Data Table and Alarm data. In this case, Historical Trend Graph and Alarm Historical Table 

are used for example.  

Create a new project first by pressing  or click File > New 

 
Enter the project name, screen name, screen No, and select Base Port controller or printer. 

Then, click OK.  

 

 

Click Options > History Buffer Setup to add history buffer data read the data of the PLC 

corresponding address. Set the Read Address to $0 and select non-volatile area (Retained) 
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to HMi and check Stamp Time and Date shown as the figure below. 

 

 

 

After OK button in History Setting dialog box is pressed, a history buffer is created shown 

as the figure below. 

 

Press OK button in History Buffer Setup dialog box to complete the settings. 
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Next, click Options > Clock Macro to edit clock macro. When the HMi is running, the clock 

macro will be executed automatically by clock time. This will give moving data to monitor.  

 
 

Then, click Options > Alarm Setup to set the alarm. Two alarms are added. The trigger 

addresses are Internal Memory Address $100.0 and $100.1, and the non-volatile area is 

set to HMi shown as the figure below. 

 

Press OK button to complete the alarm settings. 
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Create a Historical Trend Graph element and an Alarm Data Table element on the screen. 

Complete the settings of Historical Trend Graph element shown as the figure below. Please 

make sure that the Buffer ID is selected.  

    

 

Next, create two Maintained button elements in order to trigger ALARM 1 and ALARM 2. 

The addresses of ALARM 1 and ALARM 2 are $100.0 and $100.1 respectively. Then, create 

a Report List element and a Remove storage element on the screen. When complete the 

screen will look like the figure below. 
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Click Tools > Compile command to perform Compile operation and download the screen 

data into HMi.  

 

At this time, user’s HMi screen will look like the figure below. Because the Clock Macro 

command ($0 = $0 + 1) is set, the user can see changes in Historical Trend Graph.  

 

 

The user can press two Momentary button elements to enable and disable the alarms. The 

alarm data will be recorded in Alarm Data Table for user’s reference.  
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After Report List button is pressed, HMi will transfer the history buffer data and alarm data 

saved in non-volatile area into the connecting USB disk. When all of the data has been 

transferred into USB disk, the user can press Remove storage button to remove the USB 

disk. 

 

Connect the USB disk to user’s computer and open it. The user will find an auto-generated 

file, DopFlash.dft on the USB disk. The user can only use Flash Transfer function to open it.  

 
 

To execute Flash Transfer, select Start >Programs > Eaton > HMi > HMi Soft 2.xx.xx > 

Flash Transfer and the following window will open. 
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Press  Open icon and the following dialog box will show up on the screen.  

 

Select the folder where DopFlash.dft is located. 

 

After OK button is pressed, the user’s screen will look like the figure below. 
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The user can read the exported data from HMi by using Flash Transfer function. 

 

4.6 How to Use Real Image Element (Version 2.1) 
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4.7 How to Create a Curve Element 

Create a new project first by pressing  or click File > New 

 

Enter the project name, screen name, screen No, and select Base Port controller or printer. 

Then, click OK.  

 

 

 

 

Next, click Options > Configuration, select Control Block tab. To control the read and 
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write operation of recipes, in this example, Control Address is set to 1@D0, the Length is 

set to 8 and the Auto Reset Flags has been set. After complete the above settings, the 

user’s screen will look like the figure shown below. 

  
Ensure to check the Auto reset flags box. If this box is unchecked, the user will be required 

to reset the flags. 

 

Create a trend graph element. Set the Sample Flag to 1, Sample Number to 5, and Read 

Address to $100. The user’s screen will look like the figure shown below. 
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Create Numeric Entry Element for addresses $100、$101、$102、$103 and $104. Then 

create a Set button Element to Set Sample Flag to 1, because the Control Block is set to $0, 

Sample Flag 1 is $2.0. 

 

 
Click Tools > Compile command to perform Compile operation and download the screen 

data into HMi.  

 

When sampling operation is performed, after the value is input into $100~$104, the HMi 

screen will look like the figure below. 
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Then, the user can press Draw button to get the Trend Graph shown in the following figure. 
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Chapter 5 System Menu 

5.1 System Menu Introduction 

 Access System Menu 

1. Press SYS key on HMi panel for two seconds. 

2. Then press the display area on HMi screen 

The System Menu will then be displayed as shown the figure below.  

 

 

 

 Exit System Menu 

1. Press SYS button again for two seconds to exit the system menu and return to the 

user screen.  

2. Press the  Button 

 

 Operating Methods 

1. The user can touch the icon on the screen directly to bring up the selected function 

screen.  

2. The user can press the function keys on HMi panel to select the desired function. 

Press  selects the desired icon. Press  to enter into the selected 

option. 

If the system menu is not selected, the foreground color of the icon will be white color, 

e.g. . If the system menu is selected, the foreground color of the icon will be 
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changed to yellow color, e.g. . 

 System Menu Flowchart 

 
TP Delay  

Set delay time of touch screen 

 
TP Force 

Set pressing force of touch screen 

 
Touch Panel 

 
TP Calibrate  

Touch screen calibration 

 
Date 

Set the date 

 
Time  

Set the time 
 

Date/Time 

 
Alarm Clock 

Set the alarm clock (Reserved) 

 
Contrast  

Adjust the contrast (Reserved) 

 
Brightness  

Adjust the brightness (Reserved) 
 

Display 

 
Gamma  

Adjust LCD Gamma value 

 
HMi 

Format HMi 

 
USB Disk 

Format USB disk 
(Memory must be 

attached) 

 
CF Card 

Format CFcard 
(Memory must be 

attached) 

 
System Setting 

 
File Manager 

 
Formatting 

 
SD Card 

Format SD card 
(Memory must be 

attached) 
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Copy File  

Copy the screen data file 

 
File Manager 

 
Multi-Screen File 

Multi boot display setting  

 
MISC.  

Miscellaneous settings 

 
Security 

Password table setup 

 
Volume 

Volume adjustment (Reserved) 

 
Audio 

 
Buzzer 

Buzzer sound effect 

 
System Setting 

 
COM Port 

Communication port 

 
COM1 

COM1 upload/download 

 
Standard Mode  

COM2 
COM2 upload/download 

Mode 1 COM1  COM2 Bypass 

Mode 2 COM1  COM3 Bypass 

 
Up/Download 

 
Bypass Mode Mode 3 COM2  COM1 Bypass 

 
Next Page 

 
System Info 

System Message 

 
Previous Page 

 
White Screen Test  

 
Black Screen Test  

 
HMi Doctor 

 
Red Screen Test 
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Green Screen Test  

 
Blue Screen Test 

 
Draw Line Test 

 
Buzzer/LED Test  

 
ADC Test  

 
USB Test 

 
Key Test 

 
HMI Doctor 

 
Color Screen Test 
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5.2 System Setting Menu 

 

 

 

 

 

 

 

 

 
 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When the background color of the screen is in 

grayscale, it indicates that this is a preview 

window displaying the settings of the screen. 

Clicking the icon directly will enter into the 

menu. After clicking the desired icon, a menu 

bar in blue background color will show up at 

the bottom of the screen immediately. 

Return to System Menu 

Pressing   can switch the menu options. When the 

background color of the option is in yellow, it indicates that this 

option is selected, e.g. . When the background color of the 

option is in blue, it indicates that this option is not selected, e.g. 
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1.  Touch Panel 

 The Touch Panel option under System Setting menu provides Set delay time for 

the touch screen, Set pressing force of touch screen and Touch screen 

calibration, etc. functions as the figure shown below. 

 
 

 

 

 

 

 

 

 

 

 

 

 Cross Reference of Function Keys and Screen Icons 

 
DEFAULT 

 
UP 

 
DOWN 

 
LEFT 

 
RIGHT 

 
BACK 

      

 

 

 

 

 

This is the function menu bar.  is used to restore to the default 

setting,   is used to cycle through the options,   are 

used to change the set values of the selected option and  is to exit 

this settings page.  



HMi Chapter 5 System Menu 

 

Revision Dec, 2010   5-7 

1.1  TP Delay – Set delay time of touch screen  

This option is used to set the sensitivity of the touch screen. This means that the user 

can speed it up or slow it down, based on user’s own preference. Touching RIGHT 

icon is to decrease the delay time and speed the screen sensitivity up. Touching LEFT 

icon is to increase the delay time and slow it down. 

1.2  TP Force – Set pressing force of touch screen 

This option is used to set the pressing force of the touch screen. Touching LEFT icon 

is to reduce the pressing force to allow the user to enable the icon more easily. 

Touching RIGHT icon is to strengthen the pressing force to make the user not to 

enable the icon so easily. 

1.3  Calibrate – Touch screen calibration 

This option is used to calibrate the touch screen to ensure accuracy of the touch 

areas. There are three points on the touch screen that the calibration is based around. 

When entering into the Calibrate function, the user will find three cross icons  on 

the top-left, bottom-right, and the center of the screen. Please touch these three 

icons to calibrate the touch panel. 

NOTE   

Please note that if the user does not touch the  on the center of these three calibration 

positions, a bigger position error may occur. Therefore, we recommend the user to use a stylist 

to perform the calibration. Please refer to the following figures for correct calibration steps. 

 

   

Step 1 Step 2 Step 3 

2. Date/Time 

 Set the date and time of HMi. Each touch of Up and Down icons is to increment 

and decrement the value by 1. Please note that the selected option will be lit in 

red color as shown the figure below.  



Chapter 5 System Menu HMi 

 

5-8  

 
 

 

 

 

 

 

 

 

 

 

 Cross Reference of Function Keys and Screen Icons 

 
CANCEL 

 
UP 

 
DOWN 

 
LEFT 

 
RIGHT 

 
BACK 

      
 

2.1  Date – Set the date 

 Set the values for the calendar fields Year, Month, Day of Month in 

order by touching UP and DOWN icons.  

2.2  Time – Set the time 

 Set the values for the clock fields Hour, Minute, Second in order by 

touching UP and DOWN icons. 

This is the function menu bar.    are used to cycle 

through the date and time settings,   used to change the 

setting values of the date and time,  is used to cancel the 

setting, and  is to exit this settings page. 
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2.3  Alarm Clock – Set the alarm clock (Reserved) 

 

3.  Display (LCD Display) 

 This option is used to set the LCD display settings. When the ground color of the 

option is in black, it indicates that this option is reserved and cannot be set. 

Please refer to the figure below: 

 
 

 

 

 

 

 

 

 

 

 Cross Reference of Function Keys and Screen Icons 

 
DEFAULT 

 
UP 

 
DOWN 

 
LEFT 

 
RIGHT 

 
BACK 

      

 

3.1  Contrast – Adjust the contrast (Reserved) 

3.2  Brightness – Adjust the brightness (Reserved) 

This is the function bar.  is used to restore the default setting,  

 are used to cycle through the options,   are used to change 

the setting value, and  is used to exit this setting page. 
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3.3  Gamma – Adjust LCD Gamma value 

 

4. File Manager 

 For the functions provided by File Manager, please refer to the figure below: 

 
 

 

 

 

 

 

 

 

 

 

 

 Cross Reference of Function Keys and Screen Icons 

 
LEFT 

 
RIGHT 

 
CLICK 

 
BACK 

    

 

4.1  Formatting  

This option is used to format the HMi internal memory or external memory. If the 

foreground color of the icon on the screen is in black, it indicates that this option is 

This is the function bar.   are used to cycle through the 

functions,  is used to choose the desired functions, and  is 

used to exit this setting page. When the foreground color of the 

option is in yellow, it indicates that this option is selected, e.g. 
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not available because the external memory is not attached or not compatible.  

 

 

 Cross Reference of Function Keys and Screen Icons 

 
HMI 

 
USB 

 
CF 

 
SD 

 
BACK 

     

4.1.1  HMi – Formatting HMI 

Touching  icon or press  function on HMi panel will pop up a confirm 

dialog box will display on the screen to ask if the user wants to format HMi 

memory. Press Sure button is to format HMi memory or press Cancel is to 

cancel the formatting operation.  

4.1.2  USB Disk – Format USB disk (Reserved)  

4.1.3  CF Card – Format CF card (Reserved) 

4.1.4  SD Card – Format SD card (Reserved) 

 

 

4.2  Copy File – Copy the screen data file 

This option is used to copy the files between internal and external memory. When 

using this option, entering the highest priority password is required.  



Chapter 5 System Menu HMi 

 

5-12  

 

 

 
 

 

 

 

 

 

 

 

 

 Cross Reference of Function Keys and Screen Icons 

 
UP 

 
DOWN 

 
CLICK 

 
LEFT 

 
RIGHT 

 
COPY 

 
BACK 

       

 

 Notes 

 HMi does not allow the user to copy the disk directly.  

 Regarding the file directories, only HMI-000 ~ HMI255 are provided.  

 When copying the files, it is recommended to format the destination first 

and then copy the file source directory. 

 

 When New… is selected, HMi will search the unused directory from HMI-000 

~ HMI-255 and create a directory from the available directories for use.  

 If the screen data file in the source directory is password protected, HMi will 

ask the user to enter the highest priority password or the copy function 

cannot be executed.  

Source Directory Location Designation Directory Location 

 

  are used to cycle through the source/designation directory location, 

  are used to move the disk,  is used to accept the changes,  

is used to copy the files, and  is used to exit this setting page. 
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4.3  Multi-Screen File – Multi boot display setting 

This option is used to set the boot display of the screen data files saved in HMi 

internal and external disk. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Cross Reference of Function Keys and Screen Icons 

 
CLICK 

 
UP 

 
DOWN 

 
ENTER 

 
BACK 

     

Screen data file directory Preview window 

  are used to cycle through the file directories,  is used to 

select the desired directory,  is used to determine the setting, i.e. 

set the selected directory to be the directory of boot display, and  

is used to exit this setting page. 
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 Notes 

 Regarding the file directories, only HMI-000 ~ HMI255 are available.  

 When HMi is powered up, if the directory of the boot display is missing, HMi 

will automatically use the screen data file but will not change the file 

directory of the boot display. Therefore. If the directory of the boot display is 

found at next startup, HMi will use it as the default boot display still. 

 When the directory of the boot display is stored in the external memory, the 

non-volatile data will be saved in the directory of the boot display weather 

the non-volatile data is set to be saved in internal or external memory. 

 

5.  MISC (Miscellaneous settings) 

 The settings include the followings: 

 Touch Cursor 

 ScreenSaver Time 

 Boot Delay Times 

 Default Language 

 Blue LED Function Mode 

 Boot Display 

 
 Cross Reference of Function Keys and Screen Icons 

 
DEFAULT 

 
UP 

 
DOWN 

 
LEFT 

 
RIGHT 

 
BACK 
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6. Security (Password table setup) 

 This option is used to set HMi password security level. The highest level is 7 and 

the lowest level is 0. When this password table is opened, the user can only view 

or change passwords with security levels lower than the users. Users cannot 

change or view those passwords with higher security settings. However, if the 

user has the highest priority password, then he or she can view and change all 

the password settings.  

 
 

 

 

 

 

 

 

 Cross Reference of Function Keys and Screen Icons 

 
LEFT 

 
RIGHT 

 
CLICK 

 
BACK 

    

 

7. Audio 

 For the functions provided by this option, please refer to the figure below: 

 are 

used to move the 

password security 

level. 

  are used to move the selected button,  is used to 

press the button, and  is used to exit this settings page. 
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 Cross Reference of Function Keys and Screen Icons 

 
DEFAULT 

 
UP 

 
DOWN 

 
LEFT 

 
RIGHT 

 
BACK 

      

 

7.1  Volume – Volume adjustment (Reserved) 

This option is used to adjust the volume. Touching LEFT icon is to decrease the 

volume and touching RIGHT icon is to increase the volume. 

 

7.2   Buzzer – Buzzer sound effect 

This option is used to adjust the buzzer sound. Touching LEFT icon is to decrease 

the buzzer sound and touching RIGHT icon is to increase the buzzer sound. 

8.  COM Port 

 For the functions provided by this option, please refer to the figure below: 

This is the function bar.  is used to reset the default settings,  

 are used to cycle through Volume and Buzzer options,   are 

used to change the settings, and  is used to exit this settings page. 
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 Cross Reference of Function Keys and Screen Icons 

 
DEFAULT 

 
UP 

 
DOWN 

 
LEFT 

 
RIGHT 

 
BACK 

      

 

 

 

This is the function bar.  is used to restore the default setting,  

 are used to cycle through the options,   are used to change 

the settings, and  is used to exit this settings page. 
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5.3 Up/Download Menu 

 There are two communication modes when connecting HMI to PC through COM serial port. 

1. Standard Mode 

2. Bypass Mode 

 

 

 Cross Reference of Function Keys and Screen Icons 

 
LEFT 

 
RIGHT 

 
CLICK 

 
BACK 

    

 

1.  Standard Mode 

 When this mode is selected, COM serial port is connected to PC directly and the 

data upload and download is performed through Screen Editor Software 

program.  COM1 and COM2 ports are available for selection.  

 
 Cross Reference of Function Keys and Screen Icons 
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COM1 

 
COM2 

 
BACK 

   

 

1.1  COM1 (COM1 upload/download) 

When COM1 is set, it indicates that the data transfer will be accessed through this 

COM serial port via the settings of HMiSoft software program.  

 

1.2  COM2 (COM2 upload/download) 

When COM2 is set, it indicates that the data transfer will be accessed through this 

COM serial port via the settings of HMiSoft software program.  

 

2.  Bypass Mode -旁通模式 

 Using the Bypass mode, the data transferred by the PC can be received by the HMI 

COM ports and then sent to another COM port of the HMi to the PLC. When 

planning the system, the user can use this function to update the program of the 

PLC. For example, when COM1 port of the HMi is connecting to the PLC, and the 

PLC program needs to be updated during operation, the user can select Bypass 

mode to transfer the new PLC program in the PC to the HMi via the COM2 port of 

the HMi and then download the new PLC program to the PLC via the COM1 port of 

the HMi.  
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 Cross Reference of Function Keys and Screen Icons 

 
1  2 

 
1  3 

 
2  1 

 
LEFT 

 
RIGHT 

 
ENTER 

 
BACK 

       

 

2.1 Mode 1 – COM1  COM2 Bypass 

When this mode is selected, it indicates COM2 port of HMi is connected to the PLC, 

the user can transfer the data in the PC to the HMi via COM1 port of the HMi and then 

transfer the data to the PLC via the COM2 port of the HMi (COM1 is the data source 

port and COM2 is the data transfer port).  

 

2.2 Mode 2 – COM1  COM3 Bypass 

When this mode is selected, it indicates COM3 port of HMi is connected to the PLC, 

the user can transfer the data in the PC to the HMi via COM1 port of the HMI and then 

transfer the data to the PLC via the COM3 port of the HMi (COM1 is the data source 

port and COM3 is the data transfer port).  

 

2.3 Mode 3 – COM2  COM1 Bypass 

When this mode is selected, it indicates COM1 port of HMi is connected to the PLC, 

the user can transfer the data in the PC to the HMi via COM2 port of the HMi and then 

transfer the data to the PLC via the COM1 port of the HMi (COM2 is the data source 

port and COM1 is the data transfer port).  
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5.4 System Info Menu 

 For the functions provided by this option, please refer to the figure below: 

 

 

 

 
 

 

 Function Keys 

PREVIOUS PAGE NEXT PAGE EXIT 

   

 

 

 

 

 

 

CPU Clock 
Model Type 

Firmware Version 

Flash ROM Sixe 

Current Date 

and Time 

Battery Capacity 

Connecting 

External 

Controller 

Connecting USB 

Interface 

No Information about the USB device 
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5.5 HMI Doctor Menu 

This option provides simple text programs to help the user perform simple and easy hardware 

testing. There are seven options available: LCD, Touch Panel, Buzzer, LED, USB, ADC Channel, 

and Hot Key. Please refer to the figure below. 

 

 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

 Function Keys  are used to cycle through the options,  is used to 

enter into the selected option, and  is used to implement HMi Doctor Setup. 

 

 

1.  White Screen Test 

When the background color of the screen is in 

grayscale, it indicates that this is a preview 

window and it displays the settings. Clicking 

the icon directly will enter into the menu.  
Return to System Menu 

When the background color of the option is in yellow, it indicates that 

this option is selected, e.g. . When the background color of 

the option is in blue, it indicates that this option is not selected, e.g. 

. Pressing   can switch the menu options. 
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 This option is used to test and detect if there is any dark pixel (unlit pixel) or a 

similar defect shown on the screen.  

 

2.  Black Screen Test 

 This option is used to test and detect if there is any red, blue, green, or white 

bright pixel shown on the screen.  

 

3.  Red Screen Test 

 This option is used to test and detect if there is any dark pixel (unlit pixel) or a 

similar defect shown on the screen.  

 

4.  Green Screen Test 

 This option is used to test and detect if there is any dark pixel (unlit pixel) or a 

similar defect shown on the screen.  

 

5.  Blue Screen Test 

 This option is used to test and detect if there is any dark pixel (unlit pixel) or a 

similar defect shown on the screen.  

 

6.  Draw Line Test 

 This option is used to test the touch screen. If there is a significant deviation from 

the place the screen is touch to the place a line appears at, please use Touch 

Screen Calibration function to calibrate it. 

 

7.  Buzzer/LED Test 

 Test if a buzzer sound is heard or not. 

 Test if red, blue and green LEDs function or not. 

 

8.  ADC Test  
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 Test if ADC channel changes correctly or not. It includes pressing force, system 

voltage and temperature, etc.  

 

9.  USB Test 

 Test if USB disk is connected correctly.  

 

10.  Key Test 

 Test if the function keys are functioning when pressed normally. When pressing 

~  keys on HMi panel, the corresponding icons will show on the screen. If 

there is no corresponding icon shown on the screen, it indicates this key is 

damaged.  

 

11.  Color Screen Test 

 Color level and saturation test 
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Appendix A List of Functions Added 

A.1 New Macro Commands  

 EXPORT 

The function of EXPORT macro command is the same as the function of Report List button 

element.  

Equation: EXPORT(Var1) 

Var1: It can be an internal memory or a constant. 

0: Export the data to SD card 

1: Export the data to USB disk 

2: Export the data to the printer for printing it out 
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 IMRCP16/32, EXRCP16/32  

 
IMRCP16/32 and EXRCP16/32 macro commands are used to import and export the recipe data. 

Export 16bits recipe 

Equation: Var1 = EXRCP16(Var2, Var3) 

Export the 16bits recipe data in Var2 to the external memory Var3 (in Windows Excel CSV 

file), and store the result in Var1. 

Import 16bits recipe 

Equation: Var1 = IMRCP16(Var2, Var3) 

Import the 16bits recipe data in Var2 from the external memory Var3 (in Windows Excel 

CSV file), and store the result in Var1. 

Export 32bits recipe 

Equation: Var1 = EXRCP32(Var2, Var3) 

Export the 32bits recipe data in Var2 to the external memory Var3 (in Windows Excel CSV 

file), and store the result in Var1. 

Import 32bits recipe 

Equation: Var1 = IMRCP32(Var2, Var3) 

Import the 32bits recipe data in Var2 from the external memory Var3 (in Windows Excel 

CSV file), and store the result in Var1. 

 

Explanation: 

Var1: Response value after communication 

1: Completed normally 

0: Failed 
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Var2: Address of import/export data 

Var3: External memory 

2: USB disk. 

3: SD card. 

 

For example: 

Suppose that the user needs to export a 16bits recipe data to the USB disk.  

First, click Options > Recipe command from the menu bar to create a 16bits recipe data shown 

as the figure below. 

 

Next, create a Momentary button on the screen. 
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In property setting of the button element, set On macro command as follows. 

 

 

FILLASC($100, “rcp”) Set the file name as RCP. 

$6789 = EXRCP16($100, 2) Export the recipe data in $100 to USB disk and store 

the result in $6789. 

 

Perform Compile operation and download the screen data to HMI screen. The user’s screen will 

look like the figure below. When the EXPORT button is pressed, the 16bits recipe data will be 

converted in Windows Excel CSV file and exported into USB disk immediately.  
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The recipe file exported to the USB disk. 

 

 

 

 STATIONON/STATIONOFF 

The user can use STATIONON / STATIONOFF macro commands to enable / disable the 

communication between HMI and the designated external controllers.  

Equation: STATIONON (Var1, Var2) 

 STATIONOFF (Var1, Var2) 

Var1 and Var2 can be an internal memory or a constant. 

Var1: Communication port 

0: COM1 

1: COM2 
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2: COM3 

Var2: PLC Station number 
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A.2 Print Typesetting - Custom Print 

In Print Typesetting dialog box, Custom Print option is available to meet user’s printing needs. 

 

The corresponding functions of each register addresses are described in the following table.  

$0 Read address of screen Designate the desired print screen. When the setting 

value is 0, all screens shown in the Print Typesetting 

dialog box will be printed out.  

$1 Left Set the print starting address of X coordinate  

$2 Top Set the print starting address of Y coordinate  

$3 Width Set the width of the printing range. 

$4 Height Set the height of the printing range. 

The user can use this function with the functions of printer flag, report list element and export 

macro command, etc.  
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A.3 New Input Element 

 Barcode Input 

This element is used to receive the barcodes which are scanned by a barcode reader through 

USB interface. There are two options, Touch and Active in Input mode drop-down list.  

When Input Mode is set to Touch: 

 

If Input Mode is set to Touch, when touching the barcode input element on the screen, it will 

enter into the waiting status to wait to receive the scanned barcodes. Touching the barcode 

input element again can release the waiting status. If there are more than one barcode input 

elements on the screen, after the first barcode input element receives the scanned barcode, the 

system will not receive the next scanned barcode automatically. To receive other scanned 

barcodes, the user needs to touch the other barcode input elements in sequence manually. 

If the user wants to modify the barcode data manually, the user must set Popup Bit option. Once 

the bit is turned to ON, a keypad element will pop up on the screen for the user to enter the 

values manually. 

 

When Input Mode is set to Active: 
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If Input Mode is set to Active, it needs to trigger the InterLock Address first. After the InterLock 

Address is triggered, the barcode input element will enter into the waiting status to wait to 

receive the scanned barcodes. If there are more than one barcode input elements on the screen, 

after the first barcode input element receives the scanned barcode, the system will receive the 

next scanned barcode automatically. To release the waiting status, the user needs to reset the 

InterLock Address of the barcode input element. 

 

If the user wants to modify the barcode data manually, the user must create a keypad element 

on the screen first. Once the InterLock Address of the barcode input element is triggered, the 

user can use the keypad element to enter the values manually. 

Please note that the Popup Bit option is disabled when Input Mode is set to Active. 
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A.4 Show Disk Access Error Message 

When this option is set, if an error occurs when accessing the alarm, history buffer, and recipe 

data via USB disk, an error message will show up on the screen to alert the user.  
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A.5 Additional Internal Parameters 

There are several additional internal parameters in the drop-down list. When Device Type 

drop-down list is activated, it displays a list of internal parameters, from which the user may 

select one. 

   
 

 

 

Name Explanation Attribute 

TP_Status Touch Status Read only 

TP_X Touch X coordinate  Read only 

TP_Y Touch Y coordinate Read only 

Time_Year Year Read / Write 

Time_Month Month Read / Write 

Time_Day Day Read / Write 

Time_Hour Hour Read / Write 

Time_Minute Minute Read / Write 
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Name Explanation Attribute 

Time_Second Second Read / Write 

Battery_Voltage 
Remained voltage percentage of 

backup battery 
Read only 

NET_IP1 Read only 

NET_IP2 Read only 

NET_IP3 Read only 

NET_IP4 

HMI IP Address 

For example, if HMI IP address is 

set to 192.168.0.1, 

NET_IP1 = 192 

NET_IP2 = 168 

NET_IP3 = 0 

NET_IP4 = 1 
Read only 
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A.6 Invisible Address 

When this option is set to On, the element will be invisible. The elements which support this 

function include: all button elements, multistate indicator element, numeric entry element, 

character element, and barcode input element. 
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A.7 Auto Reboot After Firmware Upgrading 

When this option is selected, HMI will automatically restart (power off and then on) after the 

firmware upgrading is completed. 
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A.8 USBCommMode (Data Transfer via USB Disk) 

USBCommMode is a new option provided in HMI System Menu and used to transfer (upload and 

download) the data via USB disk. After the firmware is updated, the user can press SYS key to 

enter into the System Menu. Touch System Setting icon on the screen to enter into System 

Setting Menu. In the System Setting Menu, choose MISC. icon shown as the figure below. Then, 

change the setting value of USBCommMode to 1 and connect HMI to PC USB port again.  

 

Touch MISC. icon 

 

 

Select USBCommMode option 
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When USBCommMode is set to 0, it indicates the traditional data transfer mode is selected. (Not 

compatible with Windows 7)When USBCommMode is set to 1, it indicates the new data transfer 

mode via USB disk is selected. After setting USBCommMode to 1, connect HMI to PC USB port 

again. Then, double click “My Computer” icon on the desktop to see if a removable device 

named Eaton is connected or not. If it is connected, it means that the user can upload and 

download files from and to USB disk by using HMiSoft program.  

This new function is compatible with Microsoft Windows XP, Windows Vista, and Windows 7 

operating systems. 
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